English Amiga Board


Go Back   English Amiga Board > Support > support.Apps

 
 
Thread Tools
Old 31 December 2014, 02:45   #21
daxb
Registered User
 
Join Date: Oct 2009
Location: Germany
Posts: 2,377
Only conflictapro fits.
daxb is offline  
Old 31 December 2014, 04:58   #22
Leandro Jardim
Registered User
Leandro Jardim's Avatar
 
Join Date: Nov 2009
Location: Legoland
Age: 40
Posts: 1,395
Oh sorry, I didnt think you would notice that. I did put different things, firstly because the datatype document is OS related too, and also because someone may find interest in the game-related file, although I dont...

Last edited by Leandro Jardim; 31 December 2014 at 11:56.
Leandro Jardim is offline  
Old 03 February 2015, 16:29   #23
eva
Registered User

 
Join Date: Oct 2014
Location: Constanta / Romania
Posts: 202
Perhaps just use the patches that you really need? I have recently ditched FBlit because in my setup I did not see any speed-up or slowdown with or without it. I am sure it does what it says but why would I run it if I cannot sense any difference?

I have ditched a bunch of patches when I realised that ScummVM would hang and just use a combo like MCP and a stack protector. I had a bunch of them, blazewcp, FBlit, FText, yadda yadda... And either removing or adding them did not change much on the Workbench - otherwise, WHDLoad does not seem to care either way, so good riddance.

The same with BlizKick - a bunch of modules that patch lots of stuff you have either not heard about or cannot really sense a difference. I've seen people here claiming that the "maprom" stuff from BlizKick gives you a major performance boost. I really have not seen any change with that option disabled or enabled.

Now I just load what I really need: stuff like icon.library for the nice icons, scsi.device because I need large HD support, NoClick because, ok - although I could really get rid of this and "SpeedyIDE" (which does not seem to make a difference either - perhaps it does for some people, I really cannot feel it in Workbench when copying stuff around).

Oh right, I also use FastIPrefs because it has some nice settings for the backdrop wallpaper, otherwise, I could get rid of that one as well. Hmm. Good point, I'll get rid of it today.

Last edited by eva; 03 February 2015 at 16:35.
eva is offline  
Old 05 February 2015, 01:19   #24
utri007
mä vaan
 
Join Date: Nov 2001
Location: Finland
Posts: 899
You had something wrong in your FBlit setup. Speed difference is very well noticeable. It is not like a 10%, it more like a 3x.

And don't foreget setup FText and FScreen
utri007 is offline  
Old 29 March 2015, 13:06   #25
eva
Registered User

 
Join Date: Oct 2014
Location: Constanta / Romania
Posts: 202
Quote:
Originally Posted by utri007 View Post
And don't foreget setup FText and FScreen
I did that and just yesterday while installing ScummVM, the Installer was missing all the text, both on the window and on the buttons. Once I uninstalled FText and FScreen, the text started to display properly.

Just like I said, the less patches the better - or, you can spend your time debugging which and what patch makes your software not work properly. I already know the drill: "program not working?" -> ok, uncomment all the patches in the startup-sequence and then try again -> start enabling all the patches one by one till you find which one is causing trouble... It's quite tedious.

Quote:
Originally Posted by utri007 View Post
Speed difference is very well noticeable. It is not like a 10%, it more like a 3x.
There are very many patches that increase the speed - in fact, if you patch your ROM to include some 3.9 updated libraries, especially the "beta" ones you find on the Internet, your Amiga will fly. Regrettably though, out of the window...

FBlit seems necessary with OS3.9 since it fixes the "icons in chipmem" problem. Otherwise, I have had to fumble with its settings many times due to graphics glitches - either as a result of other patches, ROM patches, or from FBlit itself.
eva is offline  
Old 29 March 2015, 20:42   #26
matthey
Banned
 
Join Date: Jan 2010
Location: Kansas
Posts: 1,284
Quote:
Originally Posted by eva View Post
FBlit seems necessary with OS3.9 since it fixes the "icons in chipmem" problem.
Even when you set SYS:Prefs/Worbench to use "Images in Other Memory"?
matthey is offline  
Old 29 March 2015, 21:50   #27
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,537
Yes, of course. You either need a gfx-card and P96 or CGX to load the icons into other memory or you will need FBlit to make this possible. And FBlit needs the correct configuration (for OS 3.5+) to work without graphics corruption.
PeterK is offline  
Old 30 March 2015, 05:03   #28
matthey
Banned
 
Join Date: Jan 2010
Location: Kansas
Posts: 1,284
Quote:
Originally Posted by PeterK View Post
Yes, of course. You either need a gfx-card and P96 or CGX to load the icons into other memory or you will need FBlit to make this possible. And FBlit needs the correct configuration (for OS 3.5+) to work without graphics corruption.
It makes sense to me now but it would be nice if AmigaOS had the support built in and was smart enough to switch to CPU blitting when gfx data is in fast memory. You can add that to your todo list for your new graphics.library .
matthey is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
[Guide] Installing AmigaOS 4.1 with FS-UAE amigafreak68k support.FS-UAE 101 16 November 2018 19:17
[Guide] Installing AmigaOS 3.9 with FS-UAE nexusle support.FS-UAE 30 23 November 2017 18:49
Guide: WinUAE PPC OS 4.0 Classic Install Guide (Beta 12+) BinoX support.WinUAE 168 11 April 2016 18:00
three in one? (SCSI Patch,Mac Patch,MapRom) RogerWilco09 support.Apps 0 05 May 2009 17:56
OSNews.com: Classic AmigaOS Emulation - A Guide for WinUAE MikeB Amiga scene 3 20 August 2002 10:06

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 20:39.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.07119 seconds with 13 queries