English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 02 December 2012, 22:10   #1
mark_k
Registered User
 
Join Date: Aug 2004
Location:
Posts: 3,179
WinUAE 2.5.0 graphics API change issue with A2024 modes

Note that I'm testing using Wine, but this issue doesn't look Wine-specific.

If the current screenmode is an A2024 mode and you change the graphics API (open settings window, in Miscellanous page) from Direct3D to DirectDraw, WinUAE seems to forget the special mode and clips/centres the output window assuming a native PAL/NTSC mode.

You can recover things by bringing a native screen to the front and back, then WinUAE correctly shows the A2024 display again.

Attached log is for this:
  • Start emulated (PAL) Amiga, boots to PAL high-res laced Workbench.
  • Run (NTSC-patched) A2024 monitor driver.
  • Set Workbench to A2024:15Hz 1024x800.
  • Run Imploder (which opens a PAL high res custom screen).
  • Put Imploder screen to back. The A2024-mode Workbench appears correctly.
  • Change graphics API from Direct3D to DirectDraw.
  • The A2024 display appears incorrect, clipped to the normal PAL/NTSC size, see pic.
  • Put Workbench screen to back so Imploder PAL screen to front. That appears correct.
  • Put Imploder to back. A2024 Workbench appears correct again.

Update to add: This issue also happens if you change the window style, e.g. from standard to extended. So it's not specifically related to the graphics API, more to when WinUAE closes and re-opens the emulation window.
Attached Thumbnails
Click image for larger version

Name:	A2024_WB.png
Views:	389
Size:	42.5 KB
ID:	33326   Click image for larger version

Name:	A2024_WB_clipped.png
Views:	286
Size:	33.9 KB
ID:	33327   Click image for larger version

Name:	Imploder.png
Views:	321
Size:	28.1 KB
ID:	33328  
Attached Files
File Type: txt winuaelog_A2024_issue.txt (24.6 KB, 104 views)

Last edited by mark_k; 07 December 2012 at 17:06.
mark_k is offline  
Old 08 December 2012, 11:10   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 45
Posts: 24,547
Confirmed and will be fixed.
Toni Wilen is offline  
Old 09 December 2012, 17:19   #3
UncleSpam
Registered User
UncleSpam's Avatar
 
Join Date: Jan 2007
Location: Burbank, CA
Posts: 161
I believe this also happens when in A2024 display mode and switching between Full Screen and Windowed mode.
UncleSpam is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Graphics refresh issue mark_k support.WinUAE 6 17 December 2012 18:12
Help needed please graphics issue Amiga_Geek support.WinUAE 2 29 October 2009 09:46
OoopsUp graphics issue formater support.WinUAE 8 14 February 2009 20:26
graphics issue madmatt2007 support.WinUAE 8 12 December 2007 20:02
Programmer API for WinUAE AmireX support.WinUAE 6 12 October 2005 18:36

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 02:50.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.11808 seconds with 16 queries