English Amiga Board


Go Back   English Amiga Board > abime.net - Hosted Projects > project.ClassicWB

 
 
Thread Tools
Old 11 January 2019, 05:44   #61
KKR75
Registered User

 
Join Date: Aug 2018
Location: Beirut / Lebanon
Posts: 57
Quote:
Originally Posted by cloverskull View Post
Thanks for doing all of this. It would be great if you could also help with the 3.5/3.9 versions as well, since many people upgrade 3.9 to 3.1.4, but I understand if that is asking a lot!
I will keep that in mind of course. This whole upgrade thing will be one package at a time, because it is very easy to get mixed and confused in the scripts.


More work happening today, a major revision update to FULL will be release later today, stay tuned.

Last edited by KKR75; 11 January 2019 at 07:06.
KKR75 is offline  
Old 11 January 2019, 07:21   #62
Fendrix
Registered User
Fendrix's Avatar
 
Join Date: May 2015
Location: Sweden
Posts: 62
Evil grin

Quote:
Originally Posted by KKR75 View Post
you need to be able to run classicwb-68K version 3.1.4 ? I guess that will be my next update project then, as I only updated the FULL so far for 3.1.4.
Absolutely great, thank you thank you thank you a million.

Yes, only 68000 cpu here

This is like Christmas all over again
Fendrix is offline  
Old 11 January 2019, 15:28   #63
KKR75
Registered User

 
Join Date: Aug 2018
Location: Beirut / Lebanon
Posts: 57
Evil grin

As promised, a major revision (v3.1) to FULL has been released (with a shortly thereafter release of v3.1.1 patch to roll back hard coding, see changelog).

Link below changelog.

Full CHANGELOG since initial release, for completeness:

Code:
ClassicWB-FULL Edition CHANGELOG
Version 3.0 upwards adapted by KKR75 using Original v2.8 final Bloodwych's work.

v3.1.1
	- Rolled back hardcoded "3.1.4" in Scalos top menu bar to original settings, as the way the scripts were originally written made it too difficult to maintain multiple versions of Scalos.prefs.
	  (just hardcode it yourself if you wish, under Scalos>Prefs>Titles in the dropdown menu, replacing %os with 3.1.4)

v3.1
	- Updated full WHDLoad package to latest beta prerelease v18.4, across ALL WB versions. The reason I opted for the latest beta is because v18.3 introduced a few bugs with certain games that was remedied in v18.4
	- Removed stale ReadMe's and Guides in the 3.1.4 version only, pertaining to old deleted patches.
	- Deleted "LargeHD" directory from MyFiles in the 3.1.4 version only, as Large HDs are already supported in vanilla 3.1.4.
	- LoadModule updated to v45.15 across all WB versions as found in PeterK's IconLib 46.4, ReadMe's added to SYS:Locale/Help/System/
	- Revamped icon.library lib install and support files as follows:
		? For version 3.1.4, as it already supports all icon types:
			§ deleted entire original MyFiles/Install/Icons/ files, directories and scripts,  and added the IconLib-46.4.511 full package there.
			§ Updated SYS:Libs/icon.library to latest version 46.4.511
		? For version 3.1 and 3.0:
			§ Updated SYS:Libs/icon.library to latest version 46.4.511
			§ Updated MyFiles/Install/Icons/Enable/Libs/icon.library to version 46.4.511
			§ Added IconLib-46.4.511 full package directory to MyFiles/Install/Icons
			§ All original dirs and scripts inside MyFiles/Install/Icons were kept in place to preserve integrity
	- Hardcoded "3.1.4" next to "Amiga" in the Scalos top menu bar, to avoid seeing the ?.?  When using the %os flag. This hack is only for v3.1.4. The other versions still use %os.

v3.0.3
	- Optimized script memory usage thanks to gulliver's suggestion. Full installation now uses 890KB Fast RAM.
	- Removed IconBeFast, StackAttack, BlazeWCP, PatchRAM and TagLiFe scripts / patches when using OS 3.1.4 only
	- Removed pointers to above patches in the Scalos pulldown menu, when using OS 3.1.4 only
	- Added support for latest PeterK's icon.library 46.4.511 (68020) across all ClassicWB FULL versions (3.0, 3.1, 3.1.4). This library file is now installed by default in LIBS: as well as in the MyFiles/Install/Icons/Enable/Libs folder

v3.0.2
	- Cleaned up stale installation files across all WB versions (3.0, 3.1, 3.1Cloanto, 3.1.4).
	- Cloanto 3.1 had missing files installed (MagTape, mfm, postscript, BRU). FIXED.
	- Minor install script speed improvement

v3.0.1
	- Cleaned up stale installation files
	- Support for Cloanto AmigaForever Workbench 3.1 Disk Installs

v3.0
	- Initial updated release from original Bloodwych v2.8 final release, supporting new Workbench 3.1.4.
ClassicWB FULL v3.1.1 Update

I've tried my best to test these fixes across all versions. Let me know if you find anything strange.

KKR75

Last edited by KKR75; 11 January 2019 at 16:51.
KKR75 is offline  
Old 11 January 2019, 17:36   #64
Sandancer
Registered User

 
Join Date: Mar 2017
Location: Wakefield/United Kingdom
Posts: 117
Tried it installed perfectly in WinUAE but when i try and load Dopus I get unable to open tool DirectoryOpus,
Sandancer is offline  
Old 11 January 2019, 18:00   #65
KKR75
Registered User

 
Join Date: Aug 2018
Location: Beirut / Lebanon
Posts: 57
Quote:
Originally Posted by Sandancer View Post
Tried it installed perfectly in WinUAE but when i try and load Dopus I get unable to open tool DirectoryOpus,
i just tried installing full-3.1.4 under winuae using 68030/aga/a1200 chipset with 2mb chip and 128mb ram, 3.1.4 a1200 rom.

when I click on RUN > DOPUS, it opens perfectly fine, and when I go to the System>Apps>DirOpus folder and run it from there, it also loads.

Care to describe your setup and how you are trying to run DOPUS?
KKR75 is offline  
Old 11 January 2019, 18:05   #66
EzdineG
Registered User

 
Join Date: Apr 2017
Location: Springfield, MO
Posts: 257
The time and diligence you're putting in to updating these beloved packs is very much appreciated.


Thank you.
EzdineG is offline  
Old 11 January 2019, 18:56   #67
Sandancer
Registered User

 
Join Date: Mar 2017
Location: Wakefield/United Kingdom
Posts: 117
Its fine go it sussed KKR75, I never changed ram settings. It's been one of those days, thank you again for this.
Sandancer is offline  
Old 11 January 2019, 19:03   #68
KKR75
Registered User

 
Join Date: Aug 2018
Location: Beirut / Lebanon
Posts: 57
Well after latest update to v3.1.1 on the FULL package, I consider it having reached a milestone, and will next proceed with updating the 68K version. Theoretically this should be a lot faster now that I know what needs to be done. But one never knows the caveats ....
KKR75 is offline  
Old 11 January 2019, 19:53   #69
rcman
Long time Amiga Owner

rcman's Avatar
 
Join Date: Jun 2017
Location: Uxbridge Canada
Age: 52
Posts: 103
Quote:
Originally Posted by KKR75 View Post
Well after latest update to v3.1.1 on the FULL package, I consider it having reached a milestone, and will next proceed with updating the 68K version. Theoretically this should be a lot faster now that I know what needs to be done. But one never knows the caveats ....
You are awesome for taking the time to work on this.

Thank you so much!

Much appreciated.

RC
rcman is offline  
Old 11 January 2019, 19:57   #70
Fendrix
Registered User
Fendrix's Avatar
 
Join Date: May 2015
Location: Sweden
Posts: 62
Quote:
Originally Posted by KKR75 View Post
Well after latest update to v3.1.1 on the FULL package, I consider it having reached a milestone, and will next proceed with updating the 68K version. Theoretically this should be a lot faster now that I know what needs to be done. But one never knows the caveats ....
This is soooo awesome, can't wait to use it with my machine http://eab.abime.net/showthread.php?t=80224


YOU....ARE.....THE....GREATEST

Fendrix is offline  
Old 11 January 2019, 22:49   #71
monkat
Registered User

 
Join Date: Jul 2015
Location: Guildford
Posts: 23
Just tried it - I have the Amiga 4000 disks - the checksum is failing on extras .. get “wrong checksum on block 886”




Sent from my iPhone using Tapatalk Pro
monkat is offline  
Old 11 January 2019, 22:54   #72
KKR75
Registered User

 
Join Date: Aug 2018
Location: Beirut / Lebanon
Posts: 57
ClassicWB-68K Preview

Sneak Peak of ClassicWB-68K .....

68K ClassicWB Theme

68K WB1.3 Theme

Won't be able to release it today. Maybe tomorrow intially, or later this weekend. Stay tuned.
KKR75 is offline  
Old 11 January 2019, 22:57   #73
KKR75
Registered User

 
Join Date: Aug 2018
Location: Beirut / Lebanon
Posts: 57
Quote:
Originally Posted by monkat View Post
Just tried it - I have the Amiga 4000 disks - the checksum is failing on extras .. get “wrong checksum on block 886”




Sent from my iPhone using Tapatalk Pro
Well I don't have any A4000 disks in my possession, I only have the 500/+/1200 ones.

Are you using known good ADFs, or physical floppies? If floppies, you are positive they all work 100% without bad blocks ?
KKR75 is offline  
Old 11 January 2019, 22:58   #74
monkat
Registered User

 
Join Date: Jul 2015
Location: Guildford
Posts: 23
Yes I have the adf files as I bought a digital download


Sent from my iPhone using Tapatalk Pro
monkat is offline  
Old 11 January 2019, 23:06   #75
KKR75
Registered User

 
Join Date: Aug 2018
Location: Beirut / Lebanon
Posts: 57
Quote:
Originally Posted by monkat View Post
Yes I have the adf files as I bought a digital download


Sent from my iPhone using Tapatalk Pro
I would have to have access to both the 4000 adfs and roms for me to be able to troubleshoot this. The problem is weird because nowhere do the scripts check for checksums.
KKR75 is offline  
Old 11 January 2019, 23:47   #76
Fendrix
Registered User
Fendrix's Avatar
 
Join Date: May 2015
Location: Sweden
Posts: 62
Happy

Quote:
Originally Posted by KKR75 View Post
Sneak Peak of ClassicWB-68K .....

68K ClassicWB Theme

68K WB1.3 Theme

Won't be able to release it today. Maybe tomorrow intially, or later this weekend. Stay tuned.
Wonderful
Fendrix is offline  
Old 12 January 2019, 00:01   #77
monkat
Registered User

 
Join Date: Jul 2015
Location: Guildford
Posts: 23
Ok I’ll try again with some different settings thanks


Sent from my iPhone using Tapatalk Pro
monkat is offline  
Old 12 January 2019, 23:47   #78
KKR75
Registered User

 
Join Date: Aug 2018
Location: Beirut / Lebanon
Posts: 57
As promised, below 2 links, first one for the latest FULL version 3.1.1 (only CHANGELOG.txt was added to the package).

2nd link for the initial release of the 68K version, now supporting WB3.1.4.

Hereon forward, all changes are recorded in CHANGELOG.txt in each package.

ClassicWB-FULL v3.1.1 release

ClassicWB-68K 3.0 initial release

More work to be done polishing both packages, especially pertaining to iconlib installs, and whdload updates in 68K.

Have fun
KKR75 is offline  
Old 13 January 2019, 00:35   #79
Fendrix
Registered User
Fendrix's Avatar
 
Join Date: May 2015
Location: Sweden
Posts: 62
Quote:
Originally Posted by KKR75 View Post
As promised, below 2 links, first one for the latest FULL version 3.1.1 (only CHANGELOG.txt was added to the package).

2nd link for the initial release of the 68K version, now supporting WB3.1.4.

Hereon forward, all changes are recorded in CHANGELOG.txt in each package.

ClassicWB-FULL v3.1.1 release

ClassicWB-68K 3.0 initial release

More work to be done polishing both packages, especially pertaining to iconlib installs, and whdload updates in 68K.

Have fun
Thank you so much
Fendrix is offline  
Old 13 January 2019, 00:54   #80
Fendrix
Registered User
Fendrix's Avatar
 
Join Date: May 2015
Location: Sweden
Posts: 62
Hmm, 68K version, OS 3.1.4 already installed in your System.hdf
Fendrix is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
ClassicWB OS3.9 in emulator elowan project.ClassicWB 3 16 January 2013 14:54
ClassicWB OS3.9/BB 3+4? esc project.ClassicWB 4 19 September 2011 12:00
ClassicWB OS3.5/3.9 question MethodGit project.ClassicWB 3 01 October 2010 11:00
Multiboot ClassicWB/3.1 and ClassicWB/OS3.9 MrGimper support.Hardware 4 16 September 2010 19:42
ClassicWB OS3.9 2.5 merlinkv project.ClassicWB 9 05 May 2010 12:33

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 08:25.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.09319 seconds with 14 queries