English Amiga Board


Go Back   English Amiga Board > Support > support.WinFellow

 
 
Thread Tools
Old 11 July 2004, 16:38   #1
macphisto
 
Posts: n/a
cant seem to get disk swapping to work

i use winfellow 0.4.2.
i have kickstart 1.3,and some games.
i can get the 1 disks games started,but the 2 disks or even more,i cant get them going.
no matter what i try,it keeps comming back with insert disk 2
if somebody could help me with this?
thanx already.
 
Old 11 July 2004, 22:46   #2
macphisto
 
Posts: n/a
can you tell me how to setup winfellow to work with more then 1 disk?
cause i cant get it going.
also when changing disk (pressing f 11) and resuming again,the emulator
resets?
no matter what ill try,it just reboots.
thanx in advance
 
Old 12 July 2004, 10:56   #3
carfesh
Moderator

carfesh's Avatar
 
Join Date: Jun 2004
Location: Düsseldorf, Germany
Age: 40
Posts: 54
The reboot is probably related to an old bug we had when using fastram emulation. I think the emulator sometimes could not resume emulation when using it. You should try slowram instead. This is fixed in a newer release.

About your disk-swapping problem, what kind of game are you trying to run? Are you inserting the second disk into floppy 1 or into which slot? Some games require you to insert the second floppy into the first floppy slot, because they only support one floppy drive. In that case it might also help to disable drives 2, 3, 4. I think some further information might be helpful.
carfesh is offline  
Old 12 July 2004, 12:07   #4
macphisto
 
Posts: n/a
the game i talking about is zool (i know when i played it on my amiga 500,the 2nd disk also must be insterted in df0
but it doesnt matter wich game ill take,i cant get any further then when they ask for the 2nd disk (lotus 2,project x,another world,body blows,chaos engine,super frog ect.)
and what do il have to do to use more diskdrive's,is activating them enough?
or have ill do something else.
thanx in advance.
 
Old 12 July 2004, 12:20   #5
killergorilla
Lesser Talent
killergorilla's Avatar
 
Join Date: Jan 2003
Location: UK
Age: 36
Posts: 7,924
When using more drives make sure they are activated before you load a game. If you activate them in the middle of running a game (i.e. when it asks for disk 2) then the amiga will not recognise them. They need to be active on boot.
killergorilla is offline  
Old 13 July 2004, 07:46   #6
carfesh
Moderator

carfesh's Avatar
 
Join Date: Jun 2004
Location: Düsseldorf, Germany
Age: 40
Posts: 54
So, I just took a look at your problem. Zool is one of those games that don't support the fast dma option, so first thing should be to disable it. Apart from that, since an original A500 only had one floppy drive, I disabled the other three. I set most options to what they should be for a standard A500 machine.

I tried inserting the floppy into the same slot floppy 1 was, Zool then wanted me to press fire. It may be that this is where the problem lies? Did you configure a keyboard layout for the joystick? Or do you use a real joystick? I had to press the right control key since I use keyboard layout 1. Zool then loaded up fine.

My config file looks like this (the board doesn't let me attach wfc files), does it work if you copy&paste that configuration into your config file:

Code:
config_description=winfellow amiga emulator v0.4.3 configuration
autoconfig=no
floppy0=..\..\..\..\Amiga\Games\Zool\Zool (2).adf
fellow.floppy0_enabled=yes
fellow.floppy0_readonly=no
floppy1=
fellow.floppy1_enabled=no
fellow.floppy1_readonly=no
floppy2=
fellow.floppy2_enabled=no
fellow.floppy2_readonly=no
floppy3=
fellow.floppy3_enabled=no
fellow.floppy3_readonly=no
fellow.floppy_fast_dma=no
fellow.last_used_disk_dir=..\..\..\..\Amiga\Games\Zool
joyport0=mouse
joyport1=kbd1
usegui=yes
cpu_speed=4
cpu_compatible=no
cpu_type=68000
sound_output=normal
sound_channels=stereo
sound_bits=16
sound_frequency=44100
fellow.sound_wav=no
fellow.sound_filter=original
sound_notification=mmtimer
sound_buffer_length=60
chipmem_size=2
fastmem_size=0
bogomem_size=2
kickstart_rom_file=..\..\..\..\Entwicklung\Amiga\ROMs\kick12.rom
kickstart_key_file=
gfx_immediate_blits=no
gfx_chipset=ocs
gfx_width=640
gfx_height=576
gfx_fullscreen_amiga=no
use_multiple_graphical_buffers=no
fellow.gfx_refresh=0
gfx_colour_mode=32bit
gfx_lores=no
gfx_linemode=scanlines
gfx_framerate=0
show_leds=yes
fellow.gfx_deinterlace=no
fellow.measure_speed=no
win32.map_drives=no
Another thing I noticed is that you are not using the newest WinFellow version. Try looking for a WinFellow alpha v0.4.3 Build 1 Snapshot from 2001/11/15 on our homepage at http://fellow.sourceforge.net, that is IIRC the newest release we had (atleast it's the newest file I have in my archive on my hd).

Does it work that way?
carfesh is offline  
Old 13 July 2004, 18:24   #7
carfesh
Moderator

carfesh's Avatar
 
Join Date: Jun 2004
Location: Düsseldorf, Germany
Age: 40
Posts: 54
Since RCK now enabled posting of wfc files, I can now post the config file (thanks again ); here we go, just save it to your WinFellow folder and try if it works with this one?

The only thing you should need to change are the path to the floppy image and the kickrom path.
Attached Files
File Type: wfc Zool.wfc (1.2 KB, 272 views)
carfesh is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
HXC Disk Swapping Woes manic23 support.Hardware 2 12 May 2013 16:40
Disk-swapping improvement (WinUAE) Maren request.UAE Wishlist 49 13 March 2010 22:34
Disk Swapping without the Keyboard IyonUK support.WinUAE 20 13 February 2007 16:05
disk swapping Frog support.WinFellow 17 10 October 2006 23:01
Full screen disk swapping Djay support.WinUAE 9 27 March 2003 23:12

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 09:37.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.06415 seconds with 16 queries