English Amiga Board


Go Back   English Amiga Board > abime.net - Hosted Projects > project.ClassicWB

 
 
Thread Tools
Old 21 October 2005, 12:47   #1
Anubis
Maj. Voodoo

Anubis's Avatar
 
Join Date: Jan 2005
Location: #Confefe
Age: 46
Posts: 2,327
ClassicWB P96 Version Problems

I got couple of small problems with this version of ClassicWB.

First of all a bit about my setup: after regular setup, I moved my system files to another hard disk, which is actual folder on my computer. (It’s much easier to access files this way, and there is no worry about size of HD) Everything worked fine except that for some strange reasons I can't delete folders. All of the files inside folder will be deleted, but folder it’s self can’t be deleted.

Another problem I got is that some icons don't show in CWB. (PNG ones I assume) Not sure if this will be addressed in any future update of CWB, but it would be great to see all the folders and icons.

In overall, this is great desktop, which I customized a bit for my own use.

Great work Bloodwych!

Here is screen shot of one of the problems.
Attached Thumbnails
Click image for larger version

Name:	Strange Error.png
Views:	283
Size:	40.4 KB
ID:	9553  
Anubis is offline  
AdSense AdSense  
Old 22 October 2005, 14:39   #2
Bloodwych
Moderator

Bloodwych's Avatar
 
Join Date: Jun 2001
Location: I'm behind you!
Posts: 3,763
Just attempted to re-creatre your issue with no success. I copied the Classicwb to a PC directory, unarchived "Beneath a streel sky cd32 voices" and deleted the folder without issues. (I am using WinME, not XP however).

Wow, that's one large archive! One thing I did notice is unarchiving with dopus (and the shell executable) is about 20x faster than double-clicking the archive and using Voodoo-X with associated libs.

It's certainly not a classicwb issue - must be something else causing the problem.

I do however mention in the instructions that "I don't support copying this Workbench into a PC directory; you may encounter problems with files."

Why? Well WinUAE PC directory emulation isn't 100% without problems. In my opinion, it's much better to use a HDF file for the workbench files and PC directories for games and demos - like in Classic WB for UAE. That version also dual boots the ClassicWB FULL in order to play WHDload games that don't like JIT CPUs.

Another thing when deleting files:

Q: When deleting multiple files in Workbench windows, only one gets deleted.
A: Rather than right-clicking on the highlighted files and choosing "Delete", try right-clicking on the window instead and select "Window-Delete Contents". This will deleted all files currently highlighted rather than a single file.

It's much better to use dopus than workbench windows when dealing with files and folders anyway, but the above is still useful to know.

All this and more is in the tips and FAQ, if you haven't had a read already.

http://classicwb.abime.net/classicweb/tips.htm

http://classicwb.abime.net/classicweb/faq.htm

Thanks for trying the classicwb - I hope you resolve your issue and I'm sorry I can't replicate it on my PC. PGN icons are supported in the newer Scalos so it may well be addressed in the future. If you're after more eye candy though, you may prefer the other packages - AIAB, AmigaSYS or AmiKitt. Do a search and you'll find them. Be aware that some WHDload games/demos may have issues with the JIT CPU however.

Hope this is of help.

Last edited by Bloodwych; 22 October 2005 at 14:47.
Bloodwych is offline  
Old 23 October 2005, 05:07   #3
Anubis
Maj. Voodoo

Anubis's Avatar
 
Join Date: Jan 2005
Location: #Confefe
Age: 46
Posts: 2,327
Thanks for fast reply!

I do have AIAB (old versions and new one), Cloanto, SYS2, WB3.1.... but I find your dektop more useful, as it contains some features that no other version has.

One of most important is sorting of files in folder.

I never new that Dir emulation was not 100% good. I will put system files back in hard disk file. I need only one share hard disk, and bigger game hard disk, whitch was easy to add/fix in user-startup.

Just as I said, great work!

Thank you!
Anubis is offline  
Old 23 October 2005, 10:57   #4
Bloodwych
Moderator

Bloodwych's Avatar
 
Join Date: Jun 2001
Location: I'm behind you!
Posts: 3,763
No problem - let me know if you continue to have problems when deleting files.
Bloodwych is offline  
Old 23 October 2005, 12:12   #5
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 21,503
Directory filesystem should be nearly perfect by now (if run under NTFS-filesystem, replaces not so good working __uaefsdb-files)

Of course programs like reorg etc.. can never work on directory filesystems before there is no block device under it
Toni Wilen is online now  
Old 23 October 2005, 12:22   #6
keropi
.
 
Join Date: Oct 2004
Location: Ioannina/Greece
Posts: 5,040
I NEED the icons from this screenshot...
the letter-drawer ones! perfect for whdload! gimme gimme gimme! thanx!
(sorry this has nothing to do with the prob...)
keropi is offline  
Old 23 October 2005, 19:25   #7
Anubis
Maj. Voodoo

Anubis's Avatar
 
Join Date: Jan 2005
Location: #Confefe
Age: 46
Posts: 2,327
Just download ClassicWB, and icons are in game folder under system.

Hi Toni,
It is very interesting that I did not have this problem before. (just like that other problem with CD32 emulation )

Last night after my last reply, I reinstalled CWB, then I tried to setup 1GB hard disk (1024MB), and neither WB3.1, nor CWB can recongnize and see it. I had to remove that 24MB and I could see and reformat hard disk. I don't remember this being a problem before either. Is there limit for HD now?

But after I installed everything, and installed couple of games, everything worked perfect.
Anubis is offline  
Old 23 October 2005, 20:48   #8
Marcuz
Wurk???
Marcuz's Avatar
 
Join Date: Jun 2002
Location: .
Age: 42
Posts: 5,215
hey Anubis, maybe the problem was caused by some windows running program, for instance some explorer functions, that stop the deleting or moving or renaming even when no program is apparently using that.
one of the thing you can try is ctrl+alt+canc to close explorer and some stuff and try again
Marcuz is offline  
Old 23 October 2005, 20:57   #9
Bloodwych
Moderator

Bloodwych's Avatar
 
Join Date: Jun 2001
Location: I'm behind you!
Posts: 3,763
Toni - thanks for the update.

Keropi - lettered icons in the zone.
Bloodwych is offline  
Old 23 October 2005, 21:26   #10
Anubis
Maj. Voodoo

Anubis's Avatar
 
Join Date: Jan 2005
Location: #Confefe
Age: 46
Posts: 2,327
Hi Marko,
I'm able to delete folders from AIAB (uses directories) and other WinUAE setups that are using directories. Even WB1.3 was able to do it.

That was one of the first thing I checked, then I checked security settings, and then if I can delete files from different setups.

Right now everything works fine while I'm using hard disk files.
Anubis is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
ClassicWB P96 in real Amiga? Retrofan project.ClassicWB 20 28 May 2011 10:21
ClassicWB P96 problem nsd project.ClassicWB 3 30 November 2010 17:53
ClassicWB OS 3.5 version Bloodwych project.ClassicWB 5 30 December 2009 19:12
ClassicWB P96 under WinUAE: A Couple Problems highvista project.ClassicWB 21 21 February 2007 05:09
Old ClassicWB P96 comments & return of Burseg! teh project.ClassicWB 72 15 June 2004 00:35

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 23:06.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.07244 seconds with 14 queries