English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 24 May 2019, 03:13   #3201
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,783
Quote:
Originally Posted by jack-3d View Post
Yes yes I know, but I still think mine can become alive if ram controller is exchanged. If not ram controller, then we will change cpu (I have spare CPU ready).

There are a few XPC107 on ebay, if you're feeling lucky.
grelbfarlk is offline  
Old 28 May 2019, 16:03   #3202
Hall80
Registered User

 
Join Date: Feb 2019
Location: Prague
Posts: 16
Quote:
Originally Posted by grelbfarlk View Post
Is Hall80 the one other than Indiegolemon that has a K1 working in the machine otherwise?

I would say just make sure P96 is running and CGX is removed, make sure ppc.library in rom is killed with Terminator... and I don't know enough about Blizzards to recommend much else.
Hi,

ad1.) Yes, we are diferent =D. Indigolemon has another accelerator in his A1200 - not BlizzardPPC like me.
But now my Killer K1 is in my new testing machine A4000D in Micronik tower with Mediator4K and - it`s working (Quake2 is very very FAST), but RAM on K1 is 64MB only and it causees crashes =o/.


ad2.) CGX is not instaled there. (Second instalation of OS 3.9 on second partition with BVision and CGX is for testing.)
ppc.library must be killed due startup for right funkcion of WarpUP.
In my case with bppcfix (if I remember right). No termination at WarpUp setting.

FYI: In my A1200 the Killer K1 was initialized and found every time at any PCI slot (with Voodoo3) but Ragnarok NOT! Sometimes Yes , sometimes no.
Ragnarok need Voodoo RAM at start up/init, K1 not. May be that this is the problem =o/.
But if yes...you can see the speed - over 1600 bogoMIPS =D.
K1 has 223 bogoMIPS !!! =)
Hall80 is offline  
Old 28 May 2019, 17:54   #3203
BULI
Registered User

 
Join Date: Dec 2017
Location: Rzeszów
Posts: 176
Anybody use mpeg.library for WOS from Aminet

http://aminet.net/package.php?packag...ega-WarpUP.lha

with AmigaAMP, or AMPLIFTER?
I don't remember when exacly, but on my Sonnet and RAGNAROK this library don't play correct now.
Could anybody check it?
BULI is offline  
Old 28 May 2019, 17:59   #3204
Hedeon
Sonnet Hacker

 
Join Date: Mar 2012
Location: Leiden / The Netherlands
Posts: 1,000
Been a long time I last checked, but I don't remember using this library with AmigaAMP Doesn't it use an external player which resides in the external folder?
Hedeon is offline  
Old 28 May 2019, 19:04   #3205
indigolemon
Bit Copying Bard

indigolemon's Avatar
 
Join Date: Jan 2017
Location: Kelty, Fife, Scotland
Age: 36
Posts: 717
That linked library kinda works for me. Lots of stutter though
indigolemon is offline  
Old 28 May 2019, 20:31   #3206
BULI
Registered User

 
Join Date: Dec 2017
Location: Rzeszów
Posts: 176
Quote:
Originally Posted by indigolemon View Post
That linked library kinda works for me. Lots of stutter though

Yes, i have the same. Stuttering, not smooth sound :-(
BULI is offline  
Old 28 May 2019, 20:38   #3207
BULI
Registered User

 
Join Date: Dec 2017
Location: Rzeszów
Posts: 176
Quote:
Originally Posted by Hedeon View Post
Been a long time I last checked, but I don't remember using this library with AmigaAMP Doesn't it use an external player which resides in the external folder?
If set is "autodetect" for WOS it will play on EXTERNAL player (fast and good for visualisations, but worse decoding quality mp3).
If you want play on mpeg.library you must set in config mpeg.library.
BULI is offline  
Old 28 May 2019, 23:29   #3208
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,783
mpeg.library only worked or me if I set it to buffer the whole file which I did not like-it was a stutterfest otherwise.

AmigaAMP with WarpUP plugin works fine for me with FM801/SB128 at 44khz /16-bit. Though if you all are talking about the plugins, they don't work correctly most of the time. Many of them want a 15-bit mode or start but it's many seconds behind the audio or they start to work but stutter.

I think we have some cli music players though that support OGG/MP3/Wav/Mod/Midi etc but that's no good if you want pretty visualizations (we all do probably).

Does ffmpeg have visualizations? I seem to recall it displaying a waveform of the audio I was trying to play...
grelbfarlk is offline  
Old 30 May 2019, 19:04   #3209
Hedeon
Sonnet Hacker

 
Join Date: Mar 2012
Location: Leiden / The Netherlands
Posts: 1,000
Quote:
Originally Posted by k0x View Post
J4YI - last week we attended Amiga party - Resetkani in Czech republic - arranged by Jack-3D. Two Ragnaroks, two Killers and two Sonnets were there to see

Jack-3D presented current state of Sonnet project.
No movies or pictures from big box Amigas with working cards? Playing Q3 against each other or something like that?
Hedeon is offline  
Old 01 June 2019, 04:03   #3210
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,783
Here's a cli WarpOS sound player if anyone needs a basic CLI only sound player for testing AHI. Uses AHI Unit 0, hopefully you have set up a mode that is compatible with what you're playing.

This was just a test program from a support library-credit goes to original author and Hedeon, but don't bother Hedeon about it.

Supports as far as I know OGG/MP3/WAV/FLAC/MOD and a couple other that I'm less familiar with. Someone reported MP3 to be working but it did not work for the test MP3 I threw at it.

Big limitation is that there is no way of stopping it when it starts playing, so don't play a 16 minute long song like I did unless you want to hear the whole thing, reboot, or try to abort the task with another utility.

1> Playsound without any flags will show the following options.

Code:
USAGE: playsound [...options...] [soundFile1] ... [soundFileN]

   Options:
     --rate n       Playback at sample rate of n HZ.
     --format fmt   Playback in fmt format (see below).
     --channels n   Playback on n channels (1 or 2).
     --decodebuf n  Buffer n decoded bytes at a time (default 16384).
     --audiobuf n   Buffer n samples to audio device (default 4096).
     --volume n     Playback volume multiplier (default 1.0).
     --stdin [ext]  Read from stdin (treat data as format [ext])
     --version      Display version information and exit.
     --decoders     List supported data formats and exit.
     --predecode    Decode entire sample before playback.
     --loop n       Loop playback n times.
     --seek list    List of seek points and playback durations.
     --credits      Shameless promotion.
     --help         Display this information and exit.

   Valid arguments to the --format option are:
     U8      Unsigned 8-bit.
     S8      Signed 8-bit.
     U16LSB  Unsigned 16-bit (least significant byte first).
     U16MSB  Unsigned 16-bit (most significant byte first).
     S16LSB  Signed 16-bit (least significant byte first).
     S16MSB  Signed 16-bit (most significant byte first).

   Valid arguments to the --seek options look like:
     --seek "mm:SS:ss;mm:SS:ss;mm:SS:ss"
     Where the first "mm:SS:ss" is the position, in minutes,
     seconds and milliseconds to seek to at start of playback. The
     next mm:SS:ss is how long to play audio from that point.
     The third mm:SS:ss is another seek after the duration of
     playback has completed. If the final playback duration is
     omitted, playback continues until the end of the file.
     The "mm" and "SS" portions may be omitted. --loop
     and --seek can coexist.
Attached Files
File Type: lha playsound_wos.lha (563.1 KB, 25 views)

Last edited by grelbfarlk; 02 June 2019 at 03:58.
grelbfarlk is offline  
Old 03 June 2019, 08:25   #3211
BULI
Registered User

 
Join Date: Dec 2017
Location: Rzeszów
Posts: 176
Many thanks for this player for WOS, very useful support many formats (like .ogg, mod!).

For fast playing with good quality mp3 in multitasking for WOS, I use WarpAMP from Aminet (cli command with AHI support).

About AmigaAMP, most plugins are work correct but with older version, not the newest.

Try 2.25 (06.04.11) version AmigaAMP, and fantastic plugin SUBSPACE (variable DisSigBounce must be turn off).

Last edited by BULI; 03 June 2019 at 08:55.
BULI is offline  
Old 01 July 2019, 04:27   #3212
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,783
There have been some changes to the Sonnetlib lately, so if anyone has a chance please upgrade to the latest build 421.

Features include:
- No need for DisSigBounce in envarc:sonnet/ for the best possible performance. So things this broke should work more correctly now without setting DisSigBounce.
- Other things
grelbfarlk is offline  
Old 03 July 2019, 16:55   #3213
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,783
Quote:
Originally Posted by Hedeon View Post
It seems that datatypes are not working properly.

However, renaming lha to lha_PPC does seem to do the trick regarding speed.

If that does not work, reset the protection bits.

Hedeon patched some functions which fixed lha and datatypes so both are now far faster than they ever were. Upgrade to build 422 to experience the taste sensation.
grelbfarlk is offline  
Old 04 July 2019, 12:05   #3214
indigolemon
Bit Copying Bard

indigolemon's Avatar
 
Join Date: Jan 2017
Location: Kelty, Fife, Scotland
Age: 36
Posts: 717
Quote:
Originally Posted by grelbfarlk View Post
Hedeon patched some functions which fixed lha and datatypes so both are now far faster than they ever were. Upgrade to build 422 to experience the taste sensation.
422 is actually the best this has ever run on my 1200! Been flipping between apps/games with no need for a reboot, amazing work Hedeon

[edit] Bah! Knew I shouldn't have posted this, sudden hard lockup Still, the best experience on the 1200 so far.

Last edited by indigolemon; 04 July 2019 at 12:11.
indigolemon is offline  
Old 08 July 2019, 19:40   #3215
BULI
Registered User

 
Join Date: Dec 2017
Location: Rzeszów
Posts: 176
I did some quick tests of version from Aminet (422)- I'm impressed!
DisSigBiunce is faster than before.
I have now on Ragnarok (overclocking VOODOO 3 3000 to 180MHZ) 58FPS in BLITZquake from Cowcat (timedemo demo1), 28 FPS in Q3 demo four - everything on full (details and textures on max, dynamic light etc).
And now with turn on DisSigBiunce WarpDatatypesWOS and Subspace visualisation for AmigaAMP working correct :-)

GREAT HEDEON- Thank You

Quote:
Originally Posted by grelbfarlk View Post
There have been some changes to the Sonnetlib lately, so if anyone has a chance please upgrade to the latest build 421.

Features include:
- No need for DisSigBounce in envarc:sonnet/ for the best possible performance. So things this broke should work more correctly now without setting DisSigBounce.
- Other things

Last edited by BULI; 10 July 2019 at 16:03.
BULI is offline  
Old 16 July 2019, 02:54   #3216
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,783
Quote:
Originally Posted by BULI View Post

About AmigaAMP, most plugins are work correct but with older version, not the newest.

Try 2.25 (06.04.11) version AmigaAMP, and fantastic plugin SUBSPACE (variable DisSigBounce must be turn off).

Wavesofthefuture3-PPC works now too, sort of.
grelbfarlk is offline  
Old 19 July 2019, 19:06   #3217
BULI
Registered User

 
Join Date: Dec 2017
Location: Rzeszów
Posts: 176
Cool- I will test it :-)

BTW
In the last time, I tried multi-vision-movies on Ragnarok, and I played on the same time (AMP2 BETA) 3 movies: mpeg2 360p (dowloaded from YT) without sound, and one DVD movie (Higlander) with sound. Every movies used OVERLAY screen, one movie used Overlay Window on Workbebch screen. Works fine- makes an impression :-)


Quote:
Originally Posted by grelbfarlk View Post
Wavesofthefuture3-PPC works now too, sort of.

Last edited by BULI; 20 July 2019 at 01:01.
BULI is offline  
Old 22 July 2019, 08:56   #3218
BULI
Registered User

 
Join Date: Dec 2017
Location: Rzeszów
Posts: 176
BTW
If you want play sound paraller from many applications who use AHI (application must use UNIT 0, 1, etc; but not Music Unit), we must use AHI.device 6.x not 4.11 (mixer in version 4.11 don't work correct with Sonnet.library).
BULI is offline  
Old 23 July 2019, 01:59   #3219
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,783
Quote:
Originally Posted by BULI View Post
BTW
If you want play sound parallel from many applications who use AHI (application must use UNIT 0, 1, etc; but not Music Unit), we must use AHI.device 6.x not 4.11 (mixer in version 4.11 don't work correct with Sonnet.library).

That is good info. Do you notice AHI version 6 is noticeably worse or slower than 4.18 or have you always run v6.x+? Many people will say and some are most likely right that 4.18 is assembler based and much faster than 6.x. I don't know for our applications whether that is still true or not as with many applications the PPC is doing the mixing and piping it to the 68k. Though I have for a long time used 4.18 at the suggestion of various people.
grelbfarlk is offline  
Old 25 July 2019, 09:16   #3220
BULI
Registered User

 
Join Date: Dec 2017
Location: Rzeszów
Posts: 176
Quote:
Originally Posted by grelbfarlk View Post
That is good info. Do you notice AHI version 6 is noticeably worse or slower than 4.18 or have you always run v6.x+? Many people will say and some are most likely right that 4.18 is assembler based and much faster than 6.x. I don't know for our applications whether that is still true or not as with many applications the PPC is doing the mixing and piping it to the 68k. Though I have for a long time used 4.18 at the suggestion of various people.
Usually, I use AHI 4.18 (Faster than ver. 6, but on Ragnarok and 060 system, I don't feel speed differences).
Version 6 of AHI, give better quality of mixer, cooperate correct with DeliTracker in AHI mode.
And more important for me now, with AHI 6 I can use paraller working applications using AHI, like playing MP3 and playing ProBoom with sound (both using AHI unit 0).
BULI is offline  
 


Currently Active Users Viewing This Thread: 2 (1 members and 1 guests)
waldiamiga
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
WANTED: PCI Sound Card VORTEX2 SuperQuard / SQ2500 or Turtlebeach SantaCruz pci card keropi MarketPlace 12 15 March 2017 02:48
Wanted:Sonnet Technologies QuadDoubler 50 (Doubler 4000) kronuz MarketPlace 0 16 June 2013 00:29
eBay : Sonnet Quaddoubler alexh MarketPlace 3 07 May 2013 00:50
Overlay problem on GeForce 7200 Leandro Jardim support.WinUAE 1 10 August 2010 15:50
Prometheus PCI & Voodoo 3 PCI GFX Card Slayer support.Hardware 21 05 September 2006 10:57

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 15:00.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.20474 seconds with 16 queries