English Amiga Board


Go Back   English Amiga Board > Coders > Coders. Language > Coders. AMOS

 
 
Thread Tools
Old 10 January 2020, 22:08   #1
appas
Registered User

 
Join Date: Jan 2020
Location: Tampere
Posts: 3
AMOS Save problem

Hi,
I am new to AMOS development, and am having a stumble just starting out.
I am using AMOS The Creator v. 1.31 with an A500 configuration on WinUAE under Windows 10. I have created a hard drive according to this tutorial, and am trying to save my work to it, but when I choose the drive and enter a filename in the Save or Save as command's file picker dialog, AMOS just says "Not done" and returns to the editing screen. Nothing gets output to the mounted directory on my hard drive.

I have verified that the directory is mounted RW in WinUAE. Maybe it is some other configuration issue? The AMOS User's Guide was not helpful in this regard, it seems like it should "just work"
appas is offline  
Old 12 January 2020, 21:01   #2
Dan
Registered User
Dan's Avatar
 
Join Date: Nov 2004
Location: Germany
Posts: 453
Strange.

Bughunting would look like:

Please do a test save. Start Amos, write: Print "Hi" and then save it.

And open a notepad or any other text editor, and try to save something from there.

Last edited by Dan; 12 January 2020 at 21:17.
Dan is offline  
Old 14 January 2020, 22:57   #3
appas
Registered User

 
Join Date: Jan 2020
Location: Tampere
Posts: 3
I tried creating a file in the hard drive directory and loading it in AMOS, but I just get "This is not an AMOS Program", even if I copy the code from the User's Guide.

I also tried the "set buffer" trick from this thread, but it didn't work.
appas is offline  
Old 14 January 2020, 23:11   #4
appas
Registered User

 
Join Date: Jan 2020
Location: Tampere
Posts: 3
Well, I got it to save by overwriting the text file I had created earlier.
appas is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with save states Grassini support.WinUAE 4 21 November 2018 19:09
Can't save work in Amos pro Brick Nash Coders. AMOS 8 01 June 2016 00:00
Problem with AMOS Pro compiler install amigapd support.WinUAE 2 16 December 2011 16:59
Elite save problem? Brakus support.Games 7 14 July 2008 18:45
Save State problem thepomy support.WinUAE 1 30 June 2002 16:06

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 13:43.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.07413 seconds with 14 queries