English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 14 March 2018, 23:44   #1821
Cego
Registered User

Cego's Avatar
 
Join Date: Dec 2015
Location: Germany
Posts: 85
I find AmiSSL important because of SimpleMail, which is the only E-Mail Client supporting IMAP. And pretty much all email services demand modern security protocols which are provided by AmiSSL. Problem is, even an 68060 is too slow to establish a connection.
While SimpleMail/IMAP is working on my MorphOS machine, it just wont connect to my email provider on my A4000. :-/
Dont know how Netsurf is handlich SSL connections, but AmiSSL is also essential for IBrowse.

Is there a way to motivate Hedeon a bit more with his work on GCC?

regarding Kheshkhash, i did not try it in Warp3D v3 mode. Never heard of that mode before. Will have a look at is as soon as my new CS MKII arrives!

All this stuff happening right now is so amazing! And from what i've seen, a lot of people are still interested in classic ppc and would love to buy a PCI PPC solution for their amigas, as long as the price range is acceptable.
Cego is offline  
AdSense AdSense  
Old 14 March 2018, 23:54   #1822
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,199
Quote:
Originally Posted by Cego View Post
I find AmiSSL important because of SimpleMail, which is the only E-Mail Client supporting IMAP. And pretty much all email services demand modern security protocols which are provided by AmiSSL. Problem is, even an 68060 is too slow to establish a connection.
While SimpleMail/IMAP is working on my MorphOS machine, it just wont connect to my email provider on my A4000. :-/
Dont know how Netsurf is handlich SSL connections, but AmiSSL is also essential for IBrowse.

Is there a way to motivate Hedeon a bit more with his work on GCC?

regarding Kheshkhash, i did not try it in Warp3D v3 mode. Never heard of that mode before. Will have a look at is as soon as my new CS MKII arrives!

All this stuff happening right now is so amazing! And from what i've seen, a lot of people are still interested in classic ppc and would love to buy a PCI PPC solution for their amigas, as long as the price range is acceptable.
I didn't realize the 060 was too slow for AmiSSL, that's pretty weird.

Hedeon can be motivated by money, surely. He just doesn't want mine though since it's only enough to buy beer with, which slows him down further.
grelbfarlk is offline  
Old 15 March 2018, 00:29   #1823
Marlon_
Amiga Programmer

Marlon_'s Avatar
 
Join Date: Mar 2016
Location: Sundsvall, Sweden
Age: 29
Posts: 409
Quote:
Originally Posted by grelbfarlk View Post
I guess I should have been clear all the work that's going on to getting a better dev toolchain is for the MOS2WOS package or MorphOS GCC4->WarpOS. Currently GCC 4.4.5 works fine, it's just G++ 4.4.5 which is the problem as newlib or glibc and stdc++ need porting/compiling for WarpOS.


Ah, yes, I understand
Marlon_ is offline  
Old 15 March 2018, 01:42   #1824
nexus
Registered User
 
Join Date: Aug 2017
Location: USA
Posts: 197
http://aminet.net/package/util/libs/AmiSSL-4.2
just released
nexus is offline  
Old 15 March 2018, 01:53   #1825
Cego
Registered User

Cego's Avatar
 
Join Date: Dec 2015
Location: Germany
Posts: 85
Quote:
Originally Posted by nexus View Post
yep, but still OS3.x/68k only. No PPC support for OS3.x sadly
Cego is offline  
Old 15 March 2018, 13:51   #1826
Hedeon
Sonnet Hacker

 
Join Date: Mar 2012
Location: Leiden / The Netherlands
Posts: 631
Had to look for it and finally found it...on our own wiki but it is ForceVersion. Put that in ENVARC:Warp3D and make it 3.

Regarding porting... I won't bother with the current state of what the tools are in. Being confined to 2.95. If that changes you guys are the first to know.

The test suite of newlib is not reporting issues except for locale and some float to integer stuff. If that is solved then a recompile of libstdc++ will be done. I already implemented sjlj for WarpOS, but the library was also looking for wc type functions that are not present in libnix. That will be solved by using newlib.
Hedeon is offline  
Old 15 March 2018, 18:33   #1827
Cowcat
Registered User
 
Join Date: Apr 2013
Location: Mallorca
Posts: 403
Quote:
Even with all that we're still kind of limited by sound, Paula DMA works great but the performance penalties seem to stack up quick if we use 16-bit audio, then it all goes through the 68k version of AHI and turn into a stutter fest. The exception being that Cowcat has some arcane spell that gets around this in Hexen 2-for some reason.


Don't know about the spell: Most likely I did something fast with mistakes. That sound code in Hexen2 looks like the standard done with Morphos ports. Doing the conversions needed for Warpos maybe I did something unusual.

But I don't really know what does different from other ports. I was going to update it with "regular Q2 AHI" for the DMA issues ( is the problem?) , but maybe I will break the magic.

So what are the sound issues/differences with:
Blitzquake -> Frank Wille AHI stuff.
Q2 & Q3 -> Q2 sound code.
Hexen2 GL -> Psychotropic induced code mod to make a warpos port.
Cowcat is offline  
Old 16 March 2018, 01:21   #1828
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,199
Quote:
Ah, yes, I understand
I know you understand Marlon, just for everyone who's not 1337 like you.


I was mainly speaking in reference to 16-bit sound from a PCI card.
I think one of the biggest problems is it's usually not clear what sound a program is outputting, so if you don't match it in AHI, it makes for a sad panda, and bleeding ears.

There should have been a way to detect what AHI device a program is using and say "Whoa there pardner, I want 16-bit 4 channel 44khz and you're using 8-bit 2 channel 22khz, it's going to be a bad day for you if you continue." AmigaAMP is the exception to this in that it at least says I need a Stereo++ mode or whatever.


Blitzquake, I think uses 8-bit sounds, but the sounds are slightly distorted with a little bit of stuttering. I know you can set sound rate, but not sure about bits.
Q2 sounds are a bit distorted with more stuttering
Hexen2 GL, you just specify a 16-bit mode and match the sound rate and it works and sounds great.
WarpSNES for instance if you set the correct hz it sounds terrible, stutters both audio and video and usually will crash.

Other programs like SDL stuff the system slows down significantly with heavy stuttering and usually some buzzing with short bursts of sound/music.

Haven't tested Q3 yet with a 16-bit sound card since your first releases. I'll do that soon.
grelbfarlk is offline  
Old 18 March 2018, 02:05   #1829
Cego
Registered User

Cego's Avatar
 
Join Date: Dec 2015
Location: Germany
Posts: 85
i nailed it down regarding ffmpeg and the slowdowns i'd encoutered.
Its because of AHI mixing down the frequency from 44100KHz to 22050KHz.
Videos encoded with 22050KHz are played properly without any slowdowns.
Seems like AHI/Paula Audio is slowing down the whole system considerably. What a mess.

This is the ffmpeg command line i use to get the best quality:

Code:
ffmpeg -i "inputfile" -vcodec mpeg2video -qscale 5 -s 640x360 -r 24 -acodec mp2 -aq 5 -ac 2 -ar 22050 "outputfile"
I have not yet test it with higher framerates, but this should be no problem.
Cego is offline  
Old 18 March 2018, 02:38   #1830
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,199
Quote:
Originally Posted by Cego View Post
i nailed it down regarding ffmpeg and the slowdowns i'd encoutered.
Its because of AHI mixing down the frequency from 44100KHz to 22050KHz.
Videos encoded with 22050KHz are played properly without any slowdowns.
Seems like AHI/Paula Audio is slowing down the whole system considerably. What a mess.

This is the ffmpeg command line i use to get the best quality:

Code:
ffmpeg -i "inputfile" -vcodec mpeg2video -qscale 5 -s 640x360 -r 24 -acodec mp2 -aq 5 -ac 2 -ar 22050 "outputfile"
I have not yet test it with higher framerates, but this should be no problem.
Yeah. I keep meaning to test the Rapture with a Delfina doing hardware decoding of audio, just out of curiosity. *Some day* someone should finish the WarpOS version of AHI, there's an alpha or beta floating around out there.
grelbfarlk is offline  
Old 18 March 2018, 03:50   #1831
Cego
Registered User

Cego's Avatar
 
Join Date: Dec 2015
Location: Germany
Posts: 85
here we go: http://www.lysator.liu.se/ahi/v4-sit...beta/Obsolete/

one of those should work on WarpOS. I'll try tomorrow.
Cego is offline  
Old 18 March 2018, 04:04   #1832
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,199
Quote:
Originally Posted by Cego View Post
here we go: http://www.lysator.liu.se/ahi/v4-sit...beta/Obsolete/

one of those should work on WarpOS. I'll try tomorrow.
You can try but I don't think they work. Hedeon I think tested it about a year ago with no good result, but the library was in much rougher shape then.
grelbfarlk is offline  
Old 18 March 2018, 05:01   #1833
Cego
Registered User

Cego's Avatar
 
Join Date: Dec 2015
Location: Germany
Posts: 85
i had a look into the archives and this one has WarpUp support according the included readme: http://www.lysator.liu.se/ahi/v4-sit...te/ahipre2.lha
Cego is offline  
Old 18 March 2018, 18:22   #1834
amigoun
Registered User
amigoun's Avatar
 
Join Date: May 2010
Location: Czech Rep
Posts: 496
Deeper in that readme says its the powerup version.
amigoun is offline  
Old 19 March 2018, 00:13   #1835
Cego
Registered User

Cego's Avatar
 
Join Date: Dec 2015
Location: Germany
Posts: 85
alright, so i did some more video encoding and testing.
A G3/G4 without Altivec @400MHz is just not powerful enough to play DVD quality videos.

720x576 (PAL) is just too much too handle, no matter how low you set the bitrate.

I used Mencoder (MorphOS) to rip a PAL DVD. With this command line i got the best results:

Code:
mencoder dvd://1 -vf crop=720:432:0:72,scale=640:288 -ovc lavc -lavcopts vcodec=mpeg2video:vbitrate=3500 -of mpeg -alang en -oac lavc -lavcopts acodec=mp2:abitrate=128 -channels 2 -srate 22050 -sid 1000 -o output.mpg
As you can see, i first cropped the video to 720x432 (removed the black borders) and then scaled it down to 640x324 to lower the resolution including the correct aspect ratio.
Additionally you can add "-ss hh:mm:ss -endpos #" to rip just a few seconds and test the output yourself.

I hoped that a G3/G4 running at 400MHz would be sufficient enough for DVD quality as i remember it very clear that my brothers PentiumIII @500MHz was capable of doing so. Maybe things will change when an Altivec supported player arrives. Who knows?

Maybe there are other ways of optimizing Frogger/AMP/G4 combo or mencoder options?

Edit: well, you can lower the bitrate to 1500kbit/s. That'll give a smooth 720x324 playback, but looks like shit.

Last edited by Cego; 19 March 2018 at 00:27.
Cego is offline  
Old 19 March 2018, 00:44   #1836
nexus
Registered User
 
Join Date: Aug 2017
Location: USA
Posts: 197
well that p3 system would need a powerful p3 to decode mpeg2 in software without a gpu/hw decoder and yes altivec would help this area
nexus is offline  
Old 19 March 2018, 00:50   #1837
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,199
Yeah I mean video cards on PC had fancy features like hardware motion compensation-stuff that P96 doesn't have that I know of. AMP has overlay support which might help a bit, this is broken in Frogger I think. One of these days I'll get back to trying to compile FFMPEG/Mplayer. Or maybe a MiniGL supported player is possible.
grelbfarlk is offline  
Old 19 March 2018, 03:18   #1838
Cego
Registered User

Cego's Avatar
 
Join Date: Dec 2015
Location: Germany
Posts: 85
@grelbfarlk

that would be awesome!!! My G4 needs something to eat
Cego is offline  
Old 20 March 2018, 01:59   #1839
Cego
Registered User

Cego's Avatar
 
Join Date: Dec 2015
Location: Germany
Posts: 85
does the sonnet work in every PCI slot? i was just wondering, because right now when i have the Sonnet in the 2nd PCI slot and the voodoo in the 4th everythings just fine. As soon as i put the Voodoo in the 1st slot and the Sonnet in the 3rd the system will crash in a matter of 30-60 seconds. Bootup to P96 WB and everythings fine though until then.
I wanted to switch places, because of better cooling possibilities.

Whats causing the crashes then?

btw, is there a tool to check the clock speed of the L2 cache?
Cego is offline  
Old 20 March 2018, 02:24   #1840
Cego
Registered User

Cego's Avatar
 
Join Date: Dec 2015
Location: Germany
Posts: 85
ok, i have found this old post from Hedeon about Voodoo card installed in top of the Sonnet

http://eab.abime.net/showpost.php?p=...&postcount=245

Is this still valid? Do i need a special sonnet library? I just downloaded the latest build 322, but havent tested yet.
Cego is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
WANTED: PCI Sound Card VORTEX2 SuperQuard / SQ2500 or Turtlebeach SantaCruz pci card keropi MarketPlace 12 15 March 2017 02:48
Wanted:Sonnet Technologies QuadDoubler 50 (Doubler 4000) kronuz MarketPlace 0 16 June 2013 00:29
eBay : Sonnet Quaddoubler alexh MarketPlace 3 07 May 2013 00:50
Overlay problem on GeForce 7200 Leandro Jardim support.WinUAE 1 10 August 2010 15:50
Prometheus PCI & Voodoo 3 PCI GFX Card Slayer support.Hardware 21 05 September 2006 10:57

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 05:37.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.16570 seconds with 16 queries