English Amiga Board


Go Back   English Amiga Board > Requests > request.Apps

 
 
Thread Tools
Old 24 November 2012, 05:04   #1
amigagenie
Registered User
 
Join Date: Dec 2008
Location: Mo/USA
Posts: 54
ToasterFX Program.....

Hello fellow Amigans. I am here to find any leads for the ToasterFx program and manual. I have one that was purchased, but to my dismay. It has no manual and I believe the disk maybe missing files. Any help is appreciated.
amigagenie is offline  
Old 24 November 2012, 20:41   #2
prowler
Global Moderator

prowler's Avatar
 
Join Date: Aug 2008
Location: Sidcup, England
Posts: 10,299
Hi amigagenie,

If you can make an .ADF image of your disk and upload it, I'll check it over for evidence of missing files and try to salvage them for you.

If it's an original disk, it's unlikely that they're missing without trace, unless it has suffered a serious mishap.
prowler is offline  
Old 25 November 2012, 06:53   #3
amigagenie
Registered User
 
Join Date: Dec 2008
Location: Mo/USA
Posts: 54
Not sure where you wanted me to upload it. Its in the Zone....

Last edited by amigagenie; 25 November 2012 at 06:58.
amigagenie is offline  
Old 25 November 2012, 20:39   #4
prowler
Global Moderator

prowler's Avatar
 
Join Date: Aug 2008
Location: Sidcup, England
Posts: 10,299
That's good enough for me!

Thanks, amigagenie. I'll have a look at that tomorrow for you.
prowler is offline  
Old 27 November 2012, 00:37   #5
prowler
Global Moderator

prowler's Avatar
 
Join Date: Aug 2008
Location: Sidcup, England
Posts: 10,299
PM received and reply sent!
prowler is offline  
Old 27 November 2012, 04:12   #6
amigagenie
Registered User
 
Join Date: Dec 2008
Location: Mo/USA
Posts: 54
Tried installing on an A4000T with 040 and 16 megs ram and OS 3.9. Also tried on A2000 with GVP 040 with 8 megs ram and OS 3.1 . Keeps telling me IFX not installed, I tried it with IFX 4.0 4.5 3.0. Both machines have toaster 4000 in them and the A4000T also has flyer installed. A file on the disk has no name, thats why I think something may be wrong with the disk. I really wished the darn thing came with its manual... lol
amigagenie is offline  
Old 27 November 2012, 23:48   #7
prowler
Global Moderator

prowler's Avatar
 
Join Date: Aug 2008
Location: Sidcup, England
Posts: 10,299
I've mapped just over half the blocks on the disk now, and everything seems normal so far. No evidence yet of any missing files or "files with no name". There are indications that some files and directories may have been renamed, but that's not unusual with original disks, believe it or not.

I'll have to check the filenames I find against those in the Installer script when I've finished mapping the blocks.

The disk is FFS-formatted, so it's almost impossible to tell whether individual files have been modified without another copy of the software, but that shouldn't cause missing files, of course.

I may be able to complete this task tomorrow.
prowler is offline  
Old 28 November 2012, 03:03   #8
amiman99
Registered User

amiman99's Avatar
 
Join Date: Sep 2009
Location: San Antonio, TX USA
Age: 46
Posts: 931
I have original ToasterFX disk and it shows 44% full. I tried to create ADF out of it, but gives me disk error in later tracks.
When I try to copy files manually, it does work fine, so it looks like the errors are on the empty side of the disk.
amiman99 is offline  
Old 28 November 2012, 23:53   #9
prowler
Global Moderator

prowler's Avatar
 
Join Date: Aug 2008
Location: Sidcup, England
Posts: 10,299
I've now finished mapping the disk blocks.

I have found your "file with no name". Actually, The file does have a name - it's three space characters!

Spaces are usually used instead of a filename when the file's icon includes the program or file name. The only example I can think of is Compute!'s Boulder Bob AmigaBasic game. (In this case, the program name is two space characters and the .info file has two space characters as well.)

I'll have to check the Installer script to see if it takes account of that.

The disk contains the following files and directories:
Code:
Directory "df0:"
ReadMe.info                  467 ----rw-d 10-Mar-94 06:54:11
TFX_Install                 2911 ----rw-d 10-Mar-94 07:25:04
Installer                 115144 ----rwed 07-Mar-94 12:46:39
Disk.info                    736 ----rw-d 10-Mar-94 06:54:17
TFX_Install.info             698 ----rw-d 10-Mar-94 06:54:12
1                            Dir ----rwed 08-Mar-94 00:26:07
2                            Dir ----rwed 08-Mar-94 14:10:59
3                            Dir ----rwed 10-Mar-94 07:11:49
4                            Dir ----rwed 09-Mar-94 13:27:29
5                            Dir ----rwed 07-Mar-94 14:11:42
ReadMe                      2729 ----rwed 05-Apr-94 22:32:00
6 files - 5 directories - 258 blocks used
 
Directory "df0:1"
modules                      Dir ----rwed 08-Mar-94 00:36:39
1 directory - 2 blocks used
 
Directory "df0:1/modules"
loaders                      Dir ----rwed 10-Mar-94 03:38:01
render                       Dir ----rwed 08-Mar-94 12:22:34
savers                       Dir ----rwed 08-Mar-94 12:22:09
preview                      Dir ----rwed 08-Mar-94 12:23:01
4 directories - 8 blocks used
 
Directory "df0:1/modules/loaders"
Framestore                  3744 ----rwed 10-Mar-94 10:08:36
1 file - 9 blocks used
 
Directory "df0:1/modules/render"
VideoToaster                6152 ----rwed 08-Mar-94 12:22:37
1 file - 14 blocks used
 
Directory "df0:1/modules/savers"
Framestore                 16256 ----rwed 08-Mar-94 12:22:14
1 file - 33 blocks used
 
Directory "df0:1/modules/preview"
VideoToaster                9276 ----rwed 08-Mar-94 12:22:51
1 file - 20 blocks used
 
Directory "df0:2"
modules                      Dir ----rwed 08-Mar-94 03:23:35
1 directory - 2 blocks used
 
Directory "df0:2/modules"
preview                      Dir ----rwed 08-Mar-94 12:23:22
1 directory - 2 blocks used
 
Directory "df0:2/modules/preview"
VideoToaster                9252 ----rwed 08-Mar-94 12:23:26
1 file - 20 blocks used
 
Directory "df0:3"
ToasterFX.info               897 ----rw-d 10-Mar-94 06:26:01
TFX                         7718 ----rwed 08-Mar-94 13:38:00
TFX.prefs                   7718 ----rwed 08-Mar-94 12:47:24
ToasterFX                   1620 ----rwed 10-Mar-94 06:26:00
SetPrefs.info                454 ----rw-d 09-Mar-94 13:27:20
TFX_Commodity              14544 ----rwed 10-Mar-94 07:11:51
SetPrefs                    1180 ----rwed 08-Mar-94 13:49:09
7 files - 78 blocks used
 
Directory "df0:4"
SetPrefs.info                454 ----rw-d 09-Mar-94 13:27:19
SetPrefs                     536 ----rwed 08-Mar-94 13:59:02
2 files - 5 blocks used
 
Directory "df0:5"
___                         3568 ----rwed 07-Mar-94 14:06:23
tfx.library               156588 ----rwed 07-Mar-94 10:19:18
2 files - 315 blocks used
 
TOTAL: 22 files - 12 directories - 766 blocks used
The file with three spaces as the filename is shown with underscores instead.

As amiman99 says, the disk is about 44% full. All meaningful data are in the first 932 disk blocks.

If this is an image of an original disk, it shows signs of having contained an earlier version of the software to begin with, and this has been updated by copying later versions of the files to the disk.

An FFS-formatted disk is usually filled from the root block 880 to the end of the disk, and then from the third disk block back to the centre. Disk block 879 willl normally be the last to be allocated.

However, this disk has all the directory and file headers in disk blocks 882 and up (disk block 881 is the bitmap block), and the data blocks and list extension blocks (with a few exceptions) in the first half of the disk.

The second half of the disk contains most of the old version files.

However, I think the software is intact and there are no disk errors, so I'm assuming that there were no read errors when the ADF image in The Zone was dumped.

Tomorrow I will check the bitmap block and study the Installer script.

Edit:
@amiman99: I have just found the LHA archive you uploaded to The Zone! That has given me a second copy of the software to check the files on amigagenie's disk with. Could you upload your disk image for me too, please, even with its disk errors? I should be able to fix it by pasting in corresponding blocks from amigagenie's disk image if they match sufficiently well.

Last edited by prowler; 30 November 2012 at 00:20. Reason: Typo.
prowler is offline  
Old 29 November 2012, 02:38   #10
amiman99
Registered User

amiman99's Avatar
 
Join Date: Sep 2009
Location: San Antonio, TX USA
Age: 46
Posts: 931
ADF with bad blocks is in the Zone. Last few tracks had errors, so I just ignored it.
See if you can fix it.
amiman99 is offline  
Old 29 November 2012, 09:29   #11
amigagenie
Registered User
 
Join Date: Dec 2008
Location: Mo/USA
Posts: 54
As far as I know its an original disk. I didn't get any errors when I ADF'd it. All that stuff you posted lol its all Greek to me. I kinda understand it. If my disk helps fix another disk cool. I just hope you can help me fix my installation woes....
amigagenie is offline  
Old 29 November 2012, 15:28   #12
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,544
i did an install test. using version 2.6 all installs just fine. using version 4.0 the trouble starts. all with your disk, amigagenie.

the problem with 4.0 is the new assign. in s:user-startup you can read:
assign ImageFX4: PATH-to-your-INSTALL
while imageFX 2.6 uses
assign ImageFX: PAth-to-your-INSTALL

the install script of TFX is looking for "ImageFX" not "ImageFX4".
so you can try version 2.6 or add a new line in s:user-startup with "ImageFX" additionaly to "ImageFX4".
do not delete "ImageFX4" line, just add "ImageFX" line.
reboot and the TFX installer should work.

once installed TFX, you have ToasterFX and SetPrefs icons of TFX in ImageFx folder. start ToasterFX and then ImageFX.
in ImageFX choose "Prefs" , select "VideoToaster" module for "Render" and "Preview".

give it a try.

Last edited by emufan; 29 November 2012 at 15:36.
emufan is offline  
Old 29 November 2012, 21:17   #13
prowler
Global Moderator

prowler's Avatar
 
Join Date: Aug 2008
Location: Sidcup, England
Posts: 10,299
Quote:
Originally Posted by amiman99 View Post
ADF with bad blocks is in the Zone. Last few tracks had errors, so I just ignored it.
See if you can fix it.
Thanks. I'd better do it soon, before the disk mapping that's imprinted in my brain begins to fade...

Quote:
Originally Posted by amigagenie View Post
As far as I know its an original disk. I didn't get any errors when I ADF'd it. All that stuff you posted lol its all Greek to me. I kinda understand it. If my disk helps fix another disk cool. I just hope you can help me fix my installation woes....
Well, as you've probably gathered, I haven't really found any problems with your disk. In the meantime, what emufan has said above makes a lot of sense, so give that a try.

Quote:
Originally Posted by emufan View Post
I did an install test...
Great work, emufan! Thanks for that.

Last edited by prowler; 30 November 2012 at 00:22. Reason: Typo.
prowler is offline  
Old 29 November 2012, 23:53   #14
prowler
Global Moderator

prowler's Avatar
 
Join Date: Aug 2008
Location: Sidcup, England
Posts: 10,299
While online this evening, I have checked the bitmap block in amigagenie's disk image. Disk blocks 2-161, 882 and 931-1759 are marked as unused, which is in accordance with the files and directories shown when listing all the disk's contents at the CLI (reproduced in the boxout above).

Secondly, I have compared the files in amigagenie's disk image with those in amiman99's LHA archive uploaded yesterday and they are identical, except ReadMe.info and TFX_Install.info files. (The Workbench icons for the ReadMe file and TFX-Installer Utility have probably been moved on one or both of the disks.) Curiously, 3/TFX and 3/TFX.prefs are identical files in both sets of software.

Thus, there is absolutely nothing amiss on amigagenie's disk. All that is required is to follow emufan's suggestions for installing the software.


@amiman99: I will have a look at your disk image tomorrow. If the disk layout is the same, then you may as well download amigagenie's disk image and use that instead. I will also check which of the ReadMe.info and TFX_Install.info files are more original.

Edit:
A quick binary comparison of amigagenie's disk image and amiman99's with bad blocks reveals the following differences:
(1) Root block time and date stamps and checksum,
(2) Bad blocks on amiman99's disk at offset $B0000-$B2BFF,
(3) Bad blocks on amiman99's disk at offset $B5800-$C8BFF,
(4) Offsets $C8FB6 [$53]->[$52] and $C8FC2 [$53]->[$52], and
(5) Bad Blocks on amiman99's disk at offset $CB800-$D3BFF.

Thus, the changes to the ReadMe.info and TFX_Install.info files in amiman99's LHA archive were made when they were copied out of the disk. Also, amiman99's disk contains a Disk.info file in addition to the files in the LHA archive.

All the above differences are trivial. Only the root block changes are on a used area of the disk.

Last edited by prowler; 30 November 2012 at 23:37. Reason: Typo.
prowler is offline  
Old 30 November 2012, 17:38   #15
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,544
Quote:
Originally Posted by prowler View Post
Curiously, 3/TFX and 3/TFX.prefs are identical files in both sets of software.
i think this is on purpose. hexreading "setprefs" reveals:
copy ImageFX:TFX ImageFX:TFX.prefs
so i think it is just a mastercopy, if things went bad.
emufan is offline  
Old 30 November 2012, 21:36   #16
prowler
Global Moderator

prowler's Avatar
 
Join Date: Aug 2008
Location: Sidcup, England
Posts: 10,299
Quote:
Originally Posted by emufan View Post
Quote:
Originally Posted by prowler View Post
Curiously, 3/TFX and 3/TFX.prefs are identical files in both sets of software.
i think this is on purpose. hexreading "setprefs" reveals:
copy ImageFX:TFX ImageFX:TFX.prefs
so i think it is just a mastercopy, if things went bad.
Thanks, emufan. Yes, that explanation makes sense.

@amiman99: amigagenie's disk is a slightly earlier version than yours.
amigagenie's disk was both created and last modified on 05-APR-94 at 13:28:46. Your disk was both created and last modified on 05-APR-94 at 21:26:22. The only other differences between the disks are in the unused area. The differences at offsets $C8FB6 [$53]->[$52] and $C8FC2 [$53]->[$52] look like bits dropped by disk read errors, since the code (containing '$53's) occurs elsewhere on the disk too.

You really won't go wrong by using amigagenie's disk image, which is still in The Zone (filename: TFX.ADF).

Last edited by prowler; 01 December 2012 at 00:05. Reason: Additional info.
prowler is offline  
Old 01 December 2012, 07:16   #17
amigagenie
Registered User
 
Join Date: Dec 2008
Location: Mo/USA
Posts: 54
Thanks for all your help Prowler and emufan. It installed. Gives me a resorce.library V44 error. I think I might start from ground zero and reintall everything and see where my problems start.
amigagenie is offline  
Old 01 December 2012, 23:36   #18
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,544
one at amiga.org got same resource.libnrary problem after installing imageFX.
imagefx does overwrite some system library and gadgets in libs: . one suggest to reinstall OS.
here at eab is also a possible solution.
emufan is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
External windows program communicating with program running inside WinUAE xxxxx support.WinUAE 10 19 February 2013 09:27
Paint program or program....... amigagenie request.Apps 2 29 January 2013 19:56
For a beginner what Program and Program language would you recommend? amigang New to Emulation or Amiga scene 5 27 March 2012 13:06
Calling another program from a compiled Amos program...? andyr support.Apps 3 24 October 2004 23:47
Need this program! Tbird request.Apps 15 22 January 2003 10:55

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 00:43.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.09519 seconds with 15 queries