English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 02 March 2020, 10:58   #1
prl1975au
Registered User

 
Join Date: Mar 2020
Location: Brisbane Australia
Posts: 2
Smile A570 + Terriblefire534

Hi all.

I have the A570 with an A500+, Gary Mod to 3MB (2mb Chip 1MB Slow).
Also have a TF534i with FPU installed. QUADKICK installed roms 1.3, 2.05, 3.1.4 and Diagrom.

I was wondering if anyone else out there is successfully using this hardware combination. A570 doesn't seem to play well with the TF534.

Is anyone able to vouch for the compatiblity / incompatibility ?

Thanks in Advance.

prl1975au is offline  
Old 02 March 2020, 11:05   #2
E-Penguin
Banana

E-Penguin's Avatar
 
Join Date: Jul 2016
Location: Darmstadt
Posts: 944
Probably an autoconfig issue; I've had all sorts of trouble with things sitting on the CPU slot and things on the expansion slot. It seems to be one or the other.
E-Penguin is offline  
Old 02 March 2020, 12:35   #3
dalek
Registered User

 
Join Date: Nov 2014
Location: NSW/Australia
Posts: 378
See here: https://exxoshost.co.uk/forum/viewtopic.php?f=68&t=1900

I've got a few ideas, and I've recently received a logic analyzer from China, but no free time at the moment
dalek is online now  
Old 02 March 2020, 13:16   #4
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 45
Posts: 23,960
There probably is also another problem: A570 (like A590/A2091) uses DMA and DMA is only 24-bit. It won't work if accelerator is not DMA capable or has RAM outside of first 16M of address space. Driver won't have fallback for this situation.
Toni Wilen is offline  
Old 02 March 2020, 13:36   #5
dalek
Registered User

 
Join Date: Nov 2014
Location: NSW/Australia
Posts: 378
Stephen has resourced cdtv.device and I was able to reassemble it changing the memory allocation from any to chip and put it back in rom. But yes - could be other places in rom that also expect to be able to do DMA.
dalek is online now  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Some questions about an A570 Jim support.Hardware 89 10 November 2013 10:56
A570 Issue musashi5150 support.Hardware 1 22 May 2011 01:01
A570 Help tronko request.Other 13 21 July 2010 02:13
A Few A570 Questions HogWild support.Hardware 4 17 June 2009 09:02
How to mount A570? JackTheKnife support.Hardware 37 21 December 2008 17:13

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 08:16.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.06461 seconds with 15 queries