English Amiga Board


Go Back   English Amiga Board > Support > support.Apps

 
 
Thread Tools
Old 23 June 2020, 09:33   #1
thyslo
Registered User
 
Join Date: Apr 2018
Location: Germany
Posts: 76
DOpus 5.82 and XADopus - wrong timestamp of unpacked files

I've recently installed XADopus for DOpus 5.82 and then noticed that the timestamps of files unpacked with XADopus always are set to the current date/time:
  • When double clicking a LHA archive its contents are opened in a new listener
  • Therein I can browse the directories, all files have their original timestamp
  • When I now select a file and copy it into the destination lister, the time stamp of the destination file is changed to current date time.
On contrary, when using c:xadunfile to extract the whole archive, the original time stamps are preserved. So it might be caused by the XADopus extension and not by XAD itself.

Did anybody here notice this too or maybe have an idea how to fix it?
thyslo is offline  
Old 23 June 2020, 14:19   #2
daxb
Registered User
 
Join Date: Oct 2009
Location: Germany
Posts: 2,600
It may use "copy" instead of "copy clone" somewhere. Have you tried to contact the author of XADopus? You can check the DOpus environment settings "Copy" where you can set if the source time stamp shall be copied or not.
daxb is offline  
Old 23 June 2020, 14:59   #3
thyslo
Registered User
 
Join Date: Apr 2018
Location: Germany
Posts: 76
I suppose you're right and "copy" instead "copy all" is used from inside XADopus.

I've just checked the environment setting you mentioned and it is set to "Copy date from sorce", so this should work.

So, maybe I'll mail the XADopus author and inform about this - but probably meanwhile he is out of reach given the release was about 20 years ago.

Last edited by thyslo; 23 June 2020 at 15:01. Reason: Spelling
thyslo is offline  
Old 24 June 2020, 09:54   #4
npagonis73
Registered User

npagonis73's Avatar
 
Join Date: Sep 2019
Location: Corfu / Greece
Posts: 102
I contacted the author a week ago for a question I had for a xad command but he replied that he is not active and told be ciao!!!!!
npagonis73 is offline  
Old 24 June 2020, 15:45   #5
daxb
Registered User
 
Join Date: Oct 2009
Location: Germany
Posts: 2,600
Then it it might be a good idea to ask for source code and allow that someone can upload it to Aminet. So, anybody can have a look and may fix bugs. At least asking shows interest.
daxb is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
DOpus: Doesn't like executing files with long names Foebane support.Apps 14 30 July 2018 20:45
Naming LHA files when creating in DOPUS? pixelsmack Amiga scene 6 08 June 2017 22:07
Changing date/timestamp of AmigaDOS directory? rhester72 support.Apps 1 27 May 2015 23:42
Dopus suddenly won't extract LhA Files manic23 support.Apps 3 30 March 2013 13:43
Unable To Play Mod Files In DopuS Mag1c1an support.Apps 6 06 July 2006 16:52

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 14:16.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.06510 seconds with 15 queries