English Amiga Board


Go Back   English Amiga Board > Support > support.FS-UAE

 
 
Thread Tools
Old 30 June 2020, 15:53   #1
hoderer
Registered User

 
Join Date: Jun 2020
Location: Cologne, Germany
Posts: 1
Weird Speedlink Competition Pro (2018 model) detection problem

After I plugged the controller in, it is correctly detected as "SPEEDLINK COMPETITION PRO" in windows 10 device manager:

HID\VID_0738&PID_2217&REV_0109
HID\VID_0738&PID_2217
HID\VID_0738&UP:0001_U:0005
HID_DEVICE_SYSTEM_GAME
HID_DEVICE_UP:0001_U:0005
HID_DEVICE

When I start FS-UAE I hear a windows 10 system sound and the device turns directly into "Game Controller for Android" in the device manager with a different button mapping:

HID\VID_0079&PID_181C&REV_0101
HID\VID_0079&PID_181C
HID\VID_0079&UP:0001_U:0005
HID_DEVICE_SYSTEM_GAME
HID_DEVICE_UP:0001_U:0005
HID_DEVICE

I read something about a driver issue in Windows 10, but people say it has been fixed. It happened the first time when I tried two of the same joysticks, before that - with one joystick - everything was fine. Maybe the driver issue is indeed fixed, but only if you use one joystick.

I did some digging and found this in another forum. Maybe this could be helpful:

"The same issue was already fixed by SDL author blacklisting the device from HID enumeration, so I hope you can do the same to solve this problem forcing me to unplug the device every time: https://hg.libsdl.org/SDL/rev/64d32e614d64"

Thanks for any help! I really appreciate it!!!
hoderer is offline  
Old 14 November 2020, 17:35   #2
dtech
Registered User

 
Join Date: Oct 2020
Location: Sweden
Posts: 1
Hi!

I got the very same issue. Actually mailed Speedlink about it and got a reply saying there isn't much they can do regarding "systemic errors".

But Windows 10 is certainly the problem. When plugged into my Macbook Pro, it is detected and works just fine in FS-UAE.

Should you find a solution, please do tell!
dtech is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Amiberry and Speedlink competition Pro Joystick HellFish support.OtherUAE 15 22 October 2020 01:50
SPEEDLINK Competition Pro USB PC Joystick lags? hexaae support.WinUAE 52 11 November 2019 01:17
Zipstik and/or _vintage_ (no SpeedLink!) Competition Pro (4 buttons only) SunChild MarketPlace 0 21 July 2013 18:14
Oil Imperium Error w/Speedlink Competition Pro showview support.WinUAE 15 25 April 2013 02:41
Remapping problem with Competition Pro crusader86x support.WinUAE 3 16 August 2010 21:48

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 10:59.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.11863 seconds with 13 queries