English Amiga Board


Go Back   English Amiga Board > Support > New to Emulation or Amiga scene

 
 
Thread Tools
Old 01 August 2020, 14:43   #1
vujas
Registered User

 
Join Date: Jul 2020
Location: Novi Sad/Serbia
Posts: 5
Help with my old Amiga 500 rev 6a

Can someone help me identify part/mini board on my amiga marked red?








I bought it ,back in days,second hand,not sure if that was some modification or original part.Cant find any picture online that match it.It was sitting in basement for last 25 years for sure,was working fine before i store it there.Now it give me green screen(trying to troubleshoot it but i am total noob in this).It also had trap-door expansion but i cant find it.
Also,are jumpers set right for my memory configuration?















Excuse me for any grammar/spelling mistake.Any help appreciate
vujas is offline  
Old 01 August 2020, 16:20   #2
Nobby_UK
Registered User
Nobby_UK's Avatar
 
Join Date: Jul 2013
Location: Liverpool
Posts: 1,557
Seems normal:
http://amiga.resource.cx/photos/a500,4
Nobby_UK is offline  
Old 01 August 2020, 17:29   #3
vujas
Registered User

 
Join Date: Jul 2020
Location: Novi Sad/Serbia
Posts: 5
Quote:
Originally Posted by Nobby_UK View Post

Hm,yes,didn't find picture like this one ,was find other one whit IC on it.Thank you
vujas is offline  
Old 02 August 2020, 01:08   #4
solarmon
Registered User

solarmon's Avatar
 
Join Date: Dec 2018
Location: UK
Posts: 1,179
The small board is a factory mod, so nothing to worry about.

JP2 looks like it has been modded to make any expansion ram as Chip ram, rather than Fast ram.
solarmon is offline  
Old 02 August 2020, 22:30   #5
vujas
Registered User

 
Join Date: Jul 2020
Location: Novi Sad/Serbia
Posts: 5
Quote:
Originally Posted by solarmon View Post
The small board is a factory mod, so nothing to worry about.

JP2 looks like it has been modded to make any expansion ram as Chip ram, rather than Fast ram.
Thank you,i missed it on google picture search,other type is more common it seems.
vujas is offline  
Old 03 August 2020, 14:55   #6
B2k_ad
Registered User

 
Join Date: Jul 2018
Location: Braunschweig / Germany
Posts: 36
If it is configured for expecting 1 Meg of chip ram a green screen would make sense
if the only chip mem available is 512k.
Good luck with your Amiga and geetings
B2k_ad is offline  
Old 03 August 2020, 21:56   #7
vujas
Registered User

 
Join Date: Jul 2020
Location: Novi Sad/Serbia
Posts: 5
Quote:
Originally Posted by B2k_ad View Post
If it is configured for expecting 1 Meg of chip ram a green screen would make sense
if the only chip mem available is 512k.
Good luck with your Amiga and geetings

Thank you!
vujas is offline  
Old 26 August 2020, 20:33   #8
vujas
Registered User

 
Join Date: Jul 2020
Location: Novi Sad/Serbia
Posts: 5
Thanks all for help,tried to recap motherboard,no difference.Then replaced Fat Agnus socket,it looked bit damaged,but also no difference.Then i replaced Gary socket and socketed memory chips and it work,i suspect that Gary socket was corroded.
vujas is offline  
Old 01 September 2020, 13:44   #9
Tomislav
Registered User

 
Join Date: Aug 2014
Location: Zagreb / Croatia
Posts: 231
Rev 6a can have 2 MB Chip RAM on board, but needs more modifications than for 1 MB.
Tomislav is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Trying to repair rev 6A Amiga 500... Bren McGuire support.Hardware 10 28 August 2020 22:58
Amiga 500 - Rev 6A - Troubleshooting. Tiger4x support.Hardware 2 08 July 2020 11:41
Amiga 500 Rev 6a Power Supply Rev 312503-01: -12V line/pin has 0V xbox123 support.Hardware 0 04 March 2020 16:09
Amiga 500 Rev.6A VS Amiga 500 Plus with 2MB chip and ACA 500 turrican9 support.Hardware 0 24 December 2016 02:16
amiga 500 rev 6a motherboard NfernalNfluence support.Hardware 2 13 May 2007 22:18

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 00:11.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.07199 seconds with 15 queries