English Amiga Board


Go Back   English Amiga Board > Coders > Coders. General

 
 
Thread Tools
Old 19 December 2016, 20:29   #1
carrion
Registered User

carrion's Avatar
 
Join Date: Dec 2016
Location: Warsaw area
Posts: 50
Titanics - Unknown Hunk

It's my first post here so Hello to everyone! I read this awesome forum for long time but decided to post today because I encountered a problem while working on my small demo.

When using Titanics cruncher I get this message:
File has unknown hunk. The code is $000000000

packed file hags while loading.
unpacked file runks OK (size ~300 kb)

in my asm code I have sections like this:
SECTION MainCode,CODE
SECTION "Chip Data",DATA_C
SECTION "Chip Buffers",BSS_C
SECTION "FastMem Data",DATA_f

I use VASMem under Mac OS

I tried to google but no results found. What may be the problem?
TIA
carrion is offline  
AdSense AdSense  
Old 19 December 2016, 22:03   #2
meynaf
son of 68k
meynaf's Avatar
 
Join Date: Nov 2007
Location: Lyon / France
Age: 44
Posts: 2,459
You shouldn't be using DATA_F.
If you force something to fastmem, your code will fail on machines without some fast (e.g. unexpanded A1200). Mere data will go to fastmem anyway if there is some.
This was a generic hint, but perhaps this is also what confuses titanics cruncher.
meynaf is offline  
Old 19 December 2016, 22:25   #3
Asman
68k

Asman's Avatar
 
Join Date: Sep 2005
Location: Somewhere
Posts: 628
@carrion
Titanics1.2 has problem with HUNK_SYMBOL. Please use -nosym option then vasm will strip symbols.
Asman is offline  
Old 19 December 2016, 23:01   #4
carrion
Registered User

carrion's Avatar
 
Join Date: Dec 2016
Location: Warsaw area
Posts: 50
@Asman
Thanks a lot. I t works now.
carrion is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Resourcer supporting OVERLAY hunk???? CFOU! Coders. General 1 07 March 2017 00:06
Amiga Hunk HUNK_RELOC32 jeremysmith Coders. System 6 26 February 2016 14:50
Input: Bad loadfile hunk Turran project.ClassicWB 0 23 November 2013 12:33
Bad LoadFile Hunk amiga support.Apps 4 26 June 2008 03:31
Problem with bad hunk files on WHDload Peanutuk support.Apps 12 01 August 2004 19:06

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 21:36.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.11428 seconds with 12 queries