English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 14 October 2018, 23:12   #1
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,383
Damaged Mousepointer scrolling right on LowRes Overscan OCS

I'm not sure if this bug is WinUAE related or exists on real OCS screens, too?

It happens on PAL LowRes screens, only with Overscan (362x283), and only with OCS (not ECS or AGA) when I move the mousepointer over the right screen border and the screen starts scrolling to the left, then the pointer gets damaged until I move it to the left border again.

Can somebody confirm that with a real OCS Amiga?
Attached Thumbnails
Click image for larger version

Name:	MouseTest.png
Views:	82
Size:	20.9 KB
ID:	60270  
Attached Files
File Type: 7z BadMousePointer.7z (310.6 KB, 17 views)
PeterK is offline  
Old 15 October 2018, 15:43   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,017
I am not interested in swapping Agnus chips but it is almost surely caused by OCS Agnus bug where sprite's second DMA slot get disabled if following cycle is used by bitplane DMA. ECS Agnus fixed this bug (and it was not documented anywhere).
Toni Wilen is offline  
Old 15 October 2018, 15:48   #3
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,383
Thanks Toni.
If this is a real OCS chipset bug, then WinUAE is doing a perfect emulation.
PeterK is offline  
Old 15 October 2018, 19:19   #4
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,017
Real A1000 (ACA500plus connected to get more RAM and KS 3.1) shows identical glitch. A1000 Agnus have same bug.
Toni Wilen is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
switch lowres -> hires fullwindow turrican3 support.WinUAE 6 15 May 2018 02:32
set 1 filter for hires and 1 for lowres ? turrican3 support.WinUAE 3 11 March 2014 23:16
autoswitch between hires and lowres ? turrican3 request.UAE Wishlist 9 06 January 2008 00:48
Mousepointer restoration and varying audio pitch at savestate restoration NoX1911 support.WinUAE 0 22 January 2007 21:19
No mousepointer in recent releases knolle support.WinUAE 0 27 November 2002 13:25

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 04:28.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.06170 seconds with 16 queries