English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 25 June 2018, 04:43   #1
turrican3
Moon 1969 = amiga 1985

turrican3's Avatar
 
Join Date: Apr 2007
Location: belgium
Age: 43
Posts: 3,358
which sound card for winuae ???

Hi Toni,
it's a question specialy for :
Is there a modern sound card which could give a better result with winuae...
In any aspect ???
Do you use a separate soundcard or the one on your motherboard ?


ps: if anyone want to give an advice he's welcome, other than your question is stupid or things like that... I won't feed the trolls this time !

Last edited by turrican3; 25 June 2018 at 09:34.
turrican3 is offline  
Old 25 June 2018, 09:33   #2
onkelarie
Registered User

onkelarie's Avatar
 
Join Date: Aug 2004
Location: Spijkenisse / the Netherlands
Age: 49
Posts: 466
For me,the onboard ac95 soundchip works great with winuae. Low latency and no stuttering. Main issue is to be sure the vsync runs at a nice 50hz in PAL mode.
onkelarie is offline  
Old 25 June 2018, 09:41   #3
chip
Registered User
 
Join Date: Oct 2012
Location: Italy
Age: 44
Posts: 996
About audio issue, what do you think of a separated pair of speakers ?

I noticed a LOT of difference between the internal notebook speakers and the Logitech system i bought
chip is offline  
Old 25 June 2018, 21:36   #4
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,354
I still use SoundBlaster Z. Onboard Realteks probably always keep sucking.
Toni Wilen is offline  
Old 26 June 2018, 02:31   #5
turrican3
Moon 1969 = amiga 1985

turrican3's Avatar
 
Join Date: Apr 2007
Location: belgium
Age: 43
Posts: 3,358
Quote:
Originally Posted by Toni Wilen View Post
I still use SoundBlaster Z. Onboard Realteks probably always keep sucking.
Is there an advantage specific of this kind of soundcard for the emulation or do you mean the overall quality ?
By the which kind of speakers do you use ???
Like you test the stuffs on your hardware i find it interesting to know about it.
turrican3 is offline  
Old 26 June 2018, 11:05   #6
hexaae
Registered User
hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 43
Posts: 1,119
Quote:
Originally Posted by Toni Wilen View Post
Onboard Realteks probably always keep sucking.
Don't understand why this garbage is industry standard on every mobo in the world. There are no Realtek competitors?

I've just bought a Creative Sound Blaster X-Fi Go Pro (external sound card) for 34€... let's see if this helps with strange crackles I have with WinUAE (even though I've already mitigated the issue a lot excluding winuae.exe from Defender, experimenting with custom settings in NVidiaProfileInspector, disabling Loudness Equalisation option...)
hexaae is offline  
Old 21 December 2018, 03:48   #7
turrican3
Moon 1969 = amiga 1985

turrican3's Avatar
 
Join Date: Apr 2007
Location: belgium
Age: 43
Posts: 3,358
Quote:
Originally Posted by Toni Wilen View Post
I still use SoundBlaster Z. Onboard Realteks probably always keep sucking.
Toni, i bought a soundblaster zx and i must say that the sound is incredible !!! But i have a big problem !!! I don't know if you could see it in a log, but if you need it i'll give you one. When i set in the soublaster x pro studio : surround , after some minutes or seconds, it depends of the game launched by winuae, The sound begin to be crazy with strange sounds very squeaky !
I don't have this problem youtube videos or looking a movie with vlc or listening a mp3. for the moment it just happened with winuae... If i don't stop winuae and let it go for some minutes the sound nearly shutdowns i can ear a little noise... And even if i quit winuae the problem still present, i have to reboot the pc. But if i don't set surround in the soundblaster x studio, winuae has no problem and the sound is good. Did you have this problem ?? I'll give you a log if needed.
turrican3 is offline  
Old 21 December 2018, 09:46   #8
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 4,303
@Toni
It sometimes happens to me that the audio disappears if I use WinUAE while I see and listen to a TV RealTime at the same time.

@turrican3
To reactivate or adjust the audio you do not need to restart Windows just stop "Service Audio the Windows" and then re-enable it.

In any case, AHI helps a lot as shown in the past it is possible to listen to more mp3 at the same time without any hiccups:

[ Show youtube player ]

Last edited by AMIGASYSTEM; 21 December 2018 at 12:19.
AMIGASYSTEM is offline  
Old 21 December 2018, 10:57   #9
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,354
I have never used any effects stuff.
Toni Wilen is offline  
Old 21 December 2018, 18:10   #10
turrican3
Moon 1969 = amiga 1985

turrican3's Avatar
 
Join Date: Apr 2007
Location: belgium
Age: 43
Posts: 3,358
Thanks AMIGASYSTEM and Toni,
i will post the logs perhaps it could help ??? will see.
turrican3 is offline  
Old 21 December 2018, 19:03   #11
turrican3
Moon 1969 = amiga 1985

turrican3's Avatar
 
Join Date: Apr 2007
Location: belgium
Age: 43
Posts: 3,358
Ok, the logs.
It does the same if you set dialog plus.
Perhaps you could try to duplicate the problem with your own sb z.
But our config are surely different.
My config :
win 7
gtx 970
16 gig ram 1333 mhz
sound blaster z
logitech 5.1 (i'll change those later to match the quality of the sb z)

monitor lg 34UC79G-B
Attached Files
File Type: txt winuaebootlog.txt (19.3 KB, 35 views)
File Type: txt winuaelog.txt (43.2 KB, 35 views)
turrican3 is offline  
Old 21 December 2018, 19:13   #12
turrican3
Moon 1969 = amiga 1985

turrican3's Avatar
 
Join Date: Apr 2007
Location: belgium
Age: 43
Posts: 3,358
I launched again xenon 2 (after he crashed the 1st time) and this time again nearly no sound, i say nearly because i can ear a little noise.
see logs.Don't know if the logs help.
Attached Files
File Type: txt winuaebootlog.txt (16.4 KB, 36 views)
File Type: txt winuaelog.txt (15.0 KB, 36 views)

Last edited by turrican3; 22 December 2018 at 03:48.
turrican3 is offline  
Old 22 December 2018, 14:49   #13
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,354
Try WASAPI sound mode.
Toni Wilen is offline  
Old 23 December 2018, 00:19   #14
turrican3
Moon 1969 = amiga 1985

turrican3's Avatar
 
Join Date: Apr 2007
Location: belgium
Age: 43
Posts: 3,358
Quote:
Originally Posted by Toni Wilen View Post
Try WASAPI sound mode.
I already tried Toni, sadly it doesn't help.
I'm often in wasapi.
Do you need i record the sound problem with audacity or else ??
turrican3 is offline  
Old 01 January 2019, 13:19   #15
bernd roesch
Registered User
 
Join Date: Apr 2012
Location: germany
Posts: 125
yesterday i find the perfect sound solution for winuae and real time playing softsynth with hd-rec and toccata soundcard work too.

only with voicemeeter https://www.vb-audio.com/Voicemeeter/banana.htm it work good on my i5 8600k. in earlier days i have a i5 760 and with this winuae work a little better as on i5 8600k without voicemeeter. so i guess, it help on all PC to get perfect sound. In winuae prefs need choose buffer 1, port audio [ASIO] Voicemeeter virtual asio. then in voicemeter can choose for output WDM buffer size 256 or 512 or 1024. values between always crackle. The important step is, that you set in sound setting of windows prefs the sounddevice that should output that exclusive mode is enable. it work all i test on a cheapest logi link USB 7.1 soundbox with spdif out that cost around 25$ and soundblaster z with very low latency. the voicdemeeter virtual asio can be shared so other programs can it use too. for windows sound in windows sound pref can choose VoiceMeeter Input. this output sound device can too work with more than 1 program. In voicemeeter mixer, the outputs can see on Voicemeter VAIO input level meter. If have a soundcard as soundblaster z with own asio driver there can use in voicemeter output ASIO soundblaster z. or if you are really unhappy with WDM, there can use asio for all as output with all soundcards

the only disadvantage of this way is that in winuae even if select in voicemeeter hook volume keys for output, the volume with the ascii keyboard volumer knobs can not control when winuae is fullwindow or fullscreen or active. but with other apps it work. maybe Toni can tell, if it is a problem in voicemeeter hook or winuae ?

I wish all a happy new year. and now in 2019 my winuae have perfect sound after 19 years of unhappy with winuae sound latency for realtime keyboard play. there are many other virtual cables for windows. but other crackle on my PC and are unusable. was on i5 760 same bad
Attached Thumbnails
Click image for larger version

Name:	exclusive enable.jpg
Views:	75
Size:	71.0 KB
ID:	61399  
bernd roesch is offline  
Old 01 January 2019, 14:19   #16
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 4,303
Ciao Bernd and good 2019 to you too, i hope chenel 2019 there is some news for AFA-OS.
AMIGASYSTEM is offline  
Old 18 January 2019, 05:34   #17
turrican3
Moon 1969 = amiga 1985

turrican3's Avatar
 
Join Date: Apr 2007
Location: belgium
Age: 43
Posts: 3,358
Thank you bernd, i'll give it a try !!!
Happy new year too.


PS: Toni, do you think it could be possible for winuae to use in a better way the asio system from the sbz ?? Or at least a proper way ??
ps2: Happy new year too and to all amigans.

Quote:
Originally Posted by bernd roesch View Post
yesterday i find the perfect sound solution for winuae and real time playing softsynth with hd-rec and toccata soundcard work too.

only with voicemeeter https://www.vb-audio.com/Voicemeeter/banana.htm it work good on my i5 8600k. in earlier days i have a i5 760 and with this winuae work a little better as on i5 8600k without voicemeeter. so i guess, it help on all PC to get perfect sound. In winuae prefs need choose buffer 1, port audio [ASIO] Voicemeeter virtual asio. then in voicemeter can choose for output WDM buffer size 256 or 512 or 1024. values between always crackle. The important step is, that you set in sound setting of windows prefs the sounddevice that should output that exclusive mode is enable. it work all i test on a cheapest logi link USB 7.1 soundbox with spdif out that cost around 25$ and soundblaster z with very low latency. the voicdemeeter virtual asio can be shared so other programs can it use too. for windows sound in windows sound pref can choose VoiceMeeter Input. this output sound device can too work with more than 1 program. In voicemeeter mixer, the outputs can see on Voicemeter VAIO input level meter. If have a soundcard as soundblaster z with own asio driver there can use in voicemeter output ASIO soundblaster z. or if you are really unhappy with WDM, there can use asio for all as output with all soundcards

the only disadvantage of this way is that in winuae even if select in voicemeeter hook volume keys for output, the volume with the ascii keyboard volumer knobs can not control when winuae is fullwindow or fullscreen or active. but with other apps it work. maybe Toni can tell, if it is a problem in voicemeeter hook or winuae ?

I wish all a happy new year. and now in 2019 my winuae have perfect sound after 19 years of unhappy with winuae sound latency for realtime keyboard play. there are many other virtual cables for windows. but other crackle on my PC and are unusable. was on i5 760 same bad
turrican3 is offline  
Old 07 February 2019, 03:34   #18
turrican3
Moon 1969 = amiga 1985

turrican3's Avatar
 
Join Date: Apr 2007
Location: belgium
Age: 43
Posts: 3,358
OK, i tried every possibilities, nothing changed.

xenon 2 is the Game which crash the sound the more fastly ??? why ???
Some others game crash it but it took some time and others doesn't seem to crash the sound.
Why xenon 2 ?? It's really a mystery !!
Tony, do you think that it could be possible to diable the sbz surround just for winuae paula emulation ??? cdda is working well. And by the way surround has nearly no interest with paula under winuae, because paula with winuae is already in 4.0 (if you have a 5.1 speaker of course or 4.0 at least.).
turrican3 is offline  
Old 11 February 2019, 18:22   #19
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,354
I am not sure if it is same problem but I got rid of SB Z because it started to randomly glitch, sound stops for 100ms or so, slowly pause becomes longer and longer (may take 30-60mins) until sound completely stops. Changing SB control panel sound mode (DD<>DTS encoding) fixes it until problem starts again..

So I bought SB AE-5 (I refuse to use Realteks!). Hopefully it works better. At least it has low latency support, lowest supported seems to be 160 samples. (Usual min is 400-500).

Quote:
ony, do you think that it could be possible to diable the sbz surround just for winuae paula emulation
I don't know or care, sorry. Perhaps some startup script would work.
Toni Wilen is offline  
Old 13 February 2019, 20:18   #20
sonninnos
Registered User

sonninnos's Avatar
 
Join Date: Nov 2018
Location: Finland
Posts: 3
Zero problems and complaints with mobo's Realtek ALC887. Low latency wasapi and very low noise.
sonninnos is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
WANTED: PCI Sound Card VORTEX2 SuperQuard / SQ2500 or Turtlebeach SantaCruz pci card keropi MarketPlace 12 15 March 2017 03:48
Best Zorro II sound card? 8bitbubsy support.Hardware 7 30 May 2011 01:53
WinUAE 2.0.1.0 crash when adjusting sound card volume Photon support.WinUAE 12 31 December 2009 03:49
Toccata Sound Card jimbo100 support.Hardware 3 16 August 2007 14:38
Delfina Sound Card ant512 support.Hardware 8 19 September 2004 18:10

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 11:01.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.09385 seconds with 16 queries