English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 09 March 2018, 16:37   #1
Steffest
Registered User

 
Join Date: Jan 2017
Location: Antwerp / Belgium
Posts: 75
CDTV with kickstart 3.1 - boot from CD

Hey!

Recently I acquired a CDTV.
It has kickstart 3.1, bootroms 2.30, 2 MB chip ram and 4MB fast ram on a Rev2.2A board.
It also has some IDE controller with a 1 GB CF card with ClassicWB on it.
Everything works as expected except that I can't boot from the CD drive.
The CD drive works because when I boot into Workbench and then insert a CD, it reads fine but when I power up the device with a CD inserted nothing happens. (black screen)
The guy I got it from thought you had to press some key combination on the remote to access the "CDTV mode" after which the CDTV logo would appear.

Anyone got some ideas how to access this CDTV mode?
Steffest is offline  
Old 09 March 2018, 17:33   #2
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,546
on the Greg Donner website you can find this (#6 of the comments) :
Quote:
The machine will then boot to 3.1 from floppy with the CD drive active.
It can also boot to 3.1 from the CD drive, but will reboot when the "eject" button is pressed.
not sure, if it's the one you are looking for.
look at the website, maybe you can find the answer there.
emufan is offline  
Old 09 March 2018, 17:48   #3
Steffest
Registered User

 
Join Date: Jan 2017
Location: Antwerp / Belgium
Posts: 75
Quote:
Originally Posted by emufan View Post
on the Greg Donner website you can find this (#6 of the comments) :

not sure, if it's the one you are looking for.
look at the website, maybe you can find the answer there.
Hey!
Yes I've read that too, but I believe that's referring to the physical eject button on the device after you have boot from CD. (There is no Eject button on the remote)

On Epsilon's blog he describes the exact same problem: no boot from CD after upgrading to KS3.1 ( http://amigax1000.blogspot.be/2016/0...-upgrades.html )
He reverted back to 1.3 but according to the guy I got it from there must be a way.
Maybe I should take the machine apart to see exactly what IDE controller is used (it's hidden away underneath the motherboard)
I've got a feeling that this magical key combination is used to switch the IDE controller off so the boot control changes back to the CD drive.
Steffest is offline  
Old 09 March 2018, 17:50   #4
alexh
Thalion Webshrine
alexh's Avatar
 
Join Date: Jan 2004
Location: Oxford
Posts: 12,166
Quote:
Originally Posted by Steffest View Post
It also has some IDE controller with a 1 GB CF card with ClassicWB on it.
You'll need to identify that controller in order for us to help.
alexh is offline  
Old 09 March 2018, 17:55   #5
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,546
maybe there is a kickstart-swicher with 1.3 and 3.1 and you have to switch that?
maybe a more modern, which does work when holding certain keys/buttons while booting, so it flips to 1.3?

open the device, make some nice images we can investigate
emufan is offline  
Old 09 March 2018, 18:50   #6
Steffest
Registered User

 
Join Date: Jan 2017
Location: Antwerp / Belgium
Posts: 75
Quote:
Originally Posted by alexh View Post
You'll need to identify that controller in order for us to help.
OK, I opened up the device.
There's no Kickstart switcher. Only Kickstart 3.1.
The SCSI controller is this one:
http://amiga.resource.cx/exp/mhcdtvscsi
very recent.

Attached is the SCSItoSD adapter from Amigakit:
https://amigakit.amiga.store/catalog...oducts_id=1264

If I pull out the SCSI controller and power it on, the CDTV logo appears and I can boot from CD.
With the SCSI Controller attached, it doesn't boot from CD.
It should, no?

Anyway - there's a "disable" jumper on the SCSI board.
I can always bring that outside and add a switch to quickly disable it.

Actually I should also bring that SCSItoSD adapter outside so I can easily switch SD cards without opening up the case.

Anyway: that "press some buttons on the remote to switch to CDTV mode" seems very unlikely. But I'm still puzzled why the CD doesn't boot.
Steffest is offline  
Old 10 March 2018, 23:54   #7
kolla
Registered User
kolla's Avatar
 
Join Date: Nov 2007
Location: Trondheim, Norway
Posts: 1,573
Is jumper JP15 set, or unset?
kolla is offline  
Old 11 March 2018, 07:19   #8
xArtx
Registered User
 
Join Date: Jun 2013
Location: Australia
Posts: 679
What revision Kickstart do you have? Is it original? 3.1 isn’t a Kickstart revision.
The revision is shown in Workbench in the About section, or for original ROMs, it’s printed in the ROM chip itself.
For a non-AGA Amiga, it might be something like 40.63.
xArtx is offline  
Old 11 March 2018, 09:14   #9
Steffest
Registered User

 
Join Date: Jan 2017
Location: Antwerp / Belgium
Posts: 75
The kickstart version is indeed 40.63.
It's an original. (but obviously not original to the CDTV)

Jumper 15 is set.
If I unset it, then both the CD drive and the SCSI controller are disabled and the 3.1 bootscreen appears.
I can then boot from external floppy if I connect one.

the SCSI controller is a.o. described at http://www.amibay.com/showthread.php...ets-BULK-ORDER where it clearly states: "The CDTV still boots from your CD-Drive first, if a CD is present"
But it doesn't.

Maybe there's something wrong with the CD drive.
I noticed that - after booted in Workbench - sometimes it starts ticking and doesn't spin the CD when I insert one, but other times it loads OK.
Steffest is offline  
Old 22 March 2018, 13:02   #10
Steffest
Registered User

 
Join Date: Jan 2017
Location: Antwerp / Belgium
Posts: 75
Just to wrap up this thread:
It turned out to be a faulty SCSI controller.
I replaced it with a brand new one and now everything is working as it should.

Happy Camper!
Steffest is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
CDTV Kickstart Location? gurth support.Hardware 3 26 January 2015 00:06
ACA500 and boot CF with Kickstart 1.3 gurth support.Hardware 9 14 April 2014 22:56
Getting WinUAE to boot from HDD with Kickstart 1.2 8bitbubsy support.WinUAE 12 17 April 2013 19:19
Custom Kickstart boot screen? Akira Hardware mods 15 26 December 2011 13:54
Later Kickstart ROMs in CDTV? Fingerlickin_B support.Hardware 7 16 April 2008 17:23

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 00:00.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.07699 seconds with 15 queries