English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 21 October 2020, 02:42   #21
hexaae
Bug hunter

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 44
Posts: 1,605
Need some demo with parallax horizontal scrolling multilevel then...
But I do already notice the difference with Beast parallax on my g-sync monitor between 3.4.0b1 and 3.3.0 and before. It's minimal and a sort of random "hesitation" more than clear stuttering but is still visible paying attention to the tree or the big logo.

Last edited by hexaae; 22 October 2020 at 11:57.
hexaae is offline  
Old 21 October 2020, 18:53   #22
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 45
Posts: 24,318
I'll do some nice and simple parallax effect later
Toni Wilen is online now  
Old 23 October 2020, 10:07   #23
hexaae
Bug hunter

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 44
Posts: 1,605
Another game where you can notice it is YoJo. Super smooth scrolling up to 3.3.0, some random micro lags after 3.4.0b1
hexaae is offline  
Old 26 October 2020, 20:57   #24
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 45
Posts: 24,318
If I disable sound ("disabled but emulated"), FPS counter shows 49.9 almost always, sometimes it also shows 49.8. Do you really get 48-51 jumps without sound?

With sound enabled, it has larger jumps but it is by design to keep sound stable. (But perhaps it can be adjusted a bit..)
Toni Wilen is online now  
Old 27 October 2020, 21:03   #25
hexaae
Bug hunter

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 44
Posts: 1,605
Quote:
Originally Posted by Toni Wilen View Post
If I disable sound ("disabled but emulated"), FPS counter shows 49.9 almost always, sometimes it also shows 49.8. Do you really get 48-51 jumps without sound?

With sound enabled, it has larger jumps but it is by design to keep sound stable. (But perhaps it can be adjusted a bit..)
With "Disabled" I get a smoother frame rate in the tight range of ~49.9-50.1 yes... but the problem is that in those games I still can see some rare micro-lags compared to the silky smooth parallax multi-level scrolling without a single "hiccup" of WinUAE 3.3.0. That's my only regret with recent WinUAE builds

Don't know what happened with 3.4.0b1* and after, but something in the gfx emu of any 50Hz smooth scrolling game got a little bit worse IMHO. The difference is very minimal and I have to pay attention, but I can notice it on my G-Sync monitor.

*
Quote:
Chipset updates:

- 24-bit addressing on the fly change + reset crash fixed.
- Disable AGA subpixel scrolling if odd and even plane has different subpixel scroll value, current emulation can't support it. (Worms DC and ACSYS)
- Added hack that fixes Smooth Copper part in demo Coolfridge / Upfront.
- Sprite to bitplane collision stupid optimization fixed. Fixes Jumpman Junior.
- Emulate "extreme" AGA-only bitplane DMA overrun special case, if display position is exactly right, it is possible to have overrun that does not conflict with other DMA channels (at least when disk DMA is inactive), 32/64-bit fetch mode only. Fixes game Moon Child.
- Implemented "secret" Akiko PIO mode CD command/response packet transmit/receive emulation.
- Fixed edge case where invalid word or long access (by some buggy program) to end of UAE expansion space crashed the emulation.

Last edited by hexaae; 27 October 2020 at 21:22.
hexaae is offline  
Old 27 October 2020, 21:37   #26
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 45
Posts: 24,318
Quote:
Tested also with Audio: Disabled and won't change the issue
Quote:
With "Disabled" I get a smoother frame rate in the tight range of ~49.9-50.1 yes.
Huh? So sound enabled or not makes no difference or it does make a difference?

This is probably the most important detail!
Toni Wilen is online now  
Old 27 October 2020, 23:30   #27
hexaae
Bug hunter

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 44
Posts: 1,605
Can improve framerate stability as you noted, but no, it won't "fix" this occasional scrolling minor-stuttering. I don't think is related to framerate numbers but more on some changed chipset emu or video refresh changes, IMHO.

EDIT:
I suggest for testing:
  • Fantastic Dizzy AGA
  • Risky Woods
  • Beast
  • YoJo or Disposable Hero (these are smoother but occasional micro-lags still occur)
These games run constantly silky smooth on 3.3.0, but after 3.4.0b1 they show some occasional micro-lag... kind of "hesitation", for one of the parallax planes while scrolling. No matter if you try to adjust cpu speed etc.

Last edited by hexaae; 28 October 2020 at 12:44.
hexaae is offline  
Old 01 November 2020, 11:16   #28
hexaae
Bug hunter

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 44
Posts: 1,605
Toni, are there some secret options to change display buffering options etc.? I wanted to set it to single buffer or try something else and see if this helps in this minor yet annoying issue with g-sync...
hexaae is offline  
Old 01 November 2020, 17:12   #29
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 45
Posts: 24,318
I checked 340b1 changes and there are lots of changes but I couldn't find anything directly related to this issue and I can't duplicate it, because I get unstable frame rates currently, any winuae version (probably some Windows Insider "feature" at this point..)

So lets start from beginning. Important in these tests is to confirm if _something_ changes. Is it (slightly) worse or (slightly) better? Keep sound emulation off. ("Disabled but emulated"). Check also display's FPS counter (if it has one) stability.

Does this have any differences: https://download.abime.net/winuae/files/b/winuae2.7z

EDIT: also make sure to test if GPU power mode makes any differences. (max performance vs others)
Toni Wilen is online now  
Old 02 November 2020, 06:09   #30
hexaae
Bug hunter

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 44
Posts: 1,605
This ver runs ROCK SOLID 50fps (99.5% of the time) for me with Audio: Disabled but emulated!
I'd say it runs DEFINITELY BETTER and possibly on par with 3.3.0.

If I enable WASAPI or PortAudio (audio enabled) I see micro-stuttering and fluctuating fps mini-adjustments though... but... I've done an interesting experiment: if I set DSOUND: Primary Sound Driver + this OpenAL wrapper (adds dsound.dll + dsound.ini to exe directory) I can even play without micro-lags at steady 50fps just like when in Audio Disabled but Emulated mode!

Last edited by hexaae; 02 November 2020 at 07:02.
hexaae is offline  
Old 02 November 2020, 06:13   #31
Retro-Nerd
Missile Command Champion

Retro-Nerd's Avatar
 
Join Date: Aug 2005
Location: Germany
Age: 48
Posts: 12,100
As i thought. Likely audio/audio driver related on your side.
Retro-Nerd is online now  
Old 02 November 2020, 18:39   #32
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 45
Posts: 24,318
Quote:
Originally Posted by Retro-Nerd View Post
As i thought. Likely audio/audio driver related on your side.
Probably not but sound is not relevant at this point.

Quote:
Originally Posted by hexaae View Post
This ver runs ROCK SOLID 50fps (99.5% of the time) for me with Audio: Disabled but emulated!
I'd say it runs DEFINITELY BETTER and possibly on par with 3.3.0.
winuae2.7z updated (confirm date=02.November). Same or worse than previous winuae2.7z? And if worse, it is still better than >3.3 versions?
Toni Wilen is online now  
Old 02 November 2020, 20:10   #33
hexaae
Bug hunter

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 44
Posts: 1,605
Have to wait site cache flush (it still downloads firs winuae2.7z 01.Nov)...

In the meanwhile I noticed that the problem of unstabe fps happens only !='DSOUND: Primary Sound Driver'. With DSOUND fps is locked at 50fps (50=99.5%, 49=0.5%) even after 3.4.0b1!

To recap after further testing:
  • 3.3.0 whatever I choose (DSOUND, WASPI, PortAudio...) stable fps and no micro-lags
  • 3.4.0b1+ DSOUND only has stable FPS, anything else including WASAPI adds fps fluctuations!
hexaae is offline  
Old 02 November 2020, 21:20   #34
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 45
Posts: 24,318
Try other browser. It usually solves this. (I don't know whats wrong with the server, I guess it tells the browser nothing has changed.. Not my problem anyway)

I thought you already tested other sound modes because it is the second most obvious test..

But anyway, as I already said, sound is not important at this point. It just a side-effect.
Toni Wilen is online now  
Old 02 November 2020, 22:32   #35
hexaae
Bug hunter

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 44
Posts: 1,605
Tested (again a trojan for Win Defender... sigh...).
I'd say in the same conditions (Audio disabled but emulated, or with DSOUND audio output) they run equally good at steady 50fps and look smooth.

Major stuttering introduced by switchting audio on and WASAPI or PortAudio (OAL not tested but was the slowest AFAICR) 48-51fps.
WASAPI or PortAudio + Audio disabled but emulated still run fine at steady 50fps.
Audio ON + DSOUND no noticeable stuttering and 50fps.

Quote:
Originally Posted by Toni Wilen View Post
I thought you already tested other sound modes because it is the second most obvious test..
.
I did but never paid attention to fps counter before, hence never connected different audio devices to micro-lags but only to crackling sounds

P.S.
Are these WinUAE2 betas using a different JIT compared to official 4.5.0beta branch? Because their JIT don't have the bugs of 4.5.0 public betas

Last edited by hexaae; 02 November 2020 at 22:43.
hexaae is offline  
Old 03 November 2020, 19:03   #36
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 45
Posts: 24,318
Quote:
Originally Posted by hexaae View Post
P.S.
Are these WinUAE2 betas using a different JIT compared to official 4.5.0beta branch? Because their JIT don't have the bugs of 4.5.0 public betas
No. Only difference is in frame timing calculation.

EDIT: except build optimization level but it shouldn't affect JIT anyway. Does 32-bit and 64-bit have same problem?

Last edited by Toni Wilen; 03 November 2020 at 19:12.
Toni Wilen is online now  
Old 03 November 2020, 19:30   #37
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 45
Posts: 24,318
Another winuae2.7z update (03.Nov). Does WASAPI audio now work more smoothly?
Toni Wilen is online now  
Old 03 November 2020, 19:46   #38
Mclane
Old retro god.

Mclane's Avatar
 
Join Date: Apr 2002
Location: Northolt, West London
Age: 59
Posts: 684
Quote:
Originally Posted by hexaae View Post
Have to wait site cache flush (it still downloads firs winuae2.7z 01.Nov)...[/LIST]
Just use the link and add a ? at the end

ie

https://download.abime.net/winuae/files/b/winuae2.7z?

That refreshes the cache..
Mclane is offline  
Old 04 November 2020, 03:03   #39
hexaae
Bug hunter

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 44
Posts: 1,605
Quote:
Originally Posted by Mclane View Post
Just use the link and add a ? at the end

ie

https://download.abime.net/winuae/files/b/winuae2.7z?

That refreshes the cache..
Oh, thanks for the trick
hexaae is offline  
Old 04 November 2020, 03:21   #40
hexaae
Bug hunter

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 44
Posts: 1,605
Quote:
Originally Posted by Toni Wilen View Post
No. Only difference is in frame timing calculation.

EDIT: except build optimization level but it shouldn't affect JIT anyway. Does 32-bit and 64-bit have same problem?
Tested 450b8 32 and 64bit: only 64bit is affected by JIT issue as reported also at http://eab.abime.net/showpost.php?p=...&postcount=244
32bit is ok.

Quote:
Originally Posted by Toni Wilen View Post
Another winuae2.7z update (03.Nov). Does WASAPI audio now work more smoothly?
Definitely better WASAPI now: 50fps most of the time. Still a little bit worse than DSOUND though: WASAPI suffers (a few rare) audio clicks in comparison.

Last edited by hexaae; 04 November 2020 at 03:56.
hexaae is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
WinUAE AB3D:TKG vs AGA 060 framerate Angus support.WinUAE 14 06 May 2020 17:20
Understanding framerate MartinW Coders. C/C++ 2 05 July 2019 13:15
Saint Dragon framerate fix Puggsy project.WHDLoad 20 22 May 2019 20:05
OS 4.1 FE Classic in WinUAE, very unstable? BarryB support.Other 5 31 May 2018 22:57
Stunt Car Racer framerate john4p support.WinUAE 18 03 December 2008 22:45

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 16:59.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.11901 seconds with 15 queries