English Amiga Board


Go Back   English Amiga Board > Support > support.Apps

 
 
Thread Tools
Old 22 August 2020, 13:17   #1
paul1981
Registered User

paul1981's Avatar
 
Join Date: Oct 2013
Location: England
Posts: 263
SystemPatch and the Workbench titlebar

When I run SystemPatch2.99 it changes the format of my free memory readings on the Workbench titlebar to Italia style 'fullstops' instead of the 'commas' which should be in use according to my Locale region (GB). I've also noticed that the filesize readings in filerequesters have the 'fullstops' also. I can fix it by starting SystemPatch with the NOEXEC option, but then I am missing out on the exec patch goodies.

Has anyone else had this problem? I have tried the 3.3b but that's the same in this regard. Is the author still working on this software?

Last edited by paul1981; 22 August 2020 at 13:41.
paul1981 is offline  
Old 22 August 2020, 14:50   #2
thomas
Registered User
thomas's Avatar
 
Join Date: Jan 2002
Location: Germany
Posts: 6,121
Just a guess: try to run SystemPatch early in startup-sequence, before someone else opens locale.library. Locale patches RawDoFmt. If SystemPatch patches it again, the locale patch is gone.
thomas is online now  
Old 22 August 2020, 15:06   #3
daxb
Registered User
 
Join Date: Oct 2009
Location: Germany
Posts: 2,694
You might want to read the SystemPatch documentation. At least how to install/use it is needed to know. You can do -<patch> +<patch> for single patches. So launch "SystemPatch -RawDoFmt" to disable that patch. I can't remember why but I've disabled RawDoFmt for some reason. SystemPatch V3.3b here.
daxb is offline  
Old 22 August 2020, 15:29   #4
paul1981
Registered User

paul1981's Avatar
 
Join Date: Oct 2013
Location: England
Posts: 263
Quote:
Originally Posted by thomas View Post
Just a guess: try to run SystemPatch early in startup-sequence, before someone else opens locale.library. Locale patches RawDoFmt. If SystemPatch patches it again, the locale patch is gone.
Thanks, I tried SystemPatch just before IPrefs and it fixed the problem. The problem I have now is that VirusZ doesn't load anymore as it complains about my xvs.library version, even though there's nothing wrong with it. Also, in the SystemPatch docs it specifies the installation of SystemPatch AFTER IPrefs, although he doesn't explain why.
paul1981 is offline  
Old 22 August 2020, 15:32   #5
paul1981
Registered User

paul1981's Avatar
 
Join Date: Oct 2013
Location: England
Posts: 263
Quote:
Originally Posted by daxb View Post
You might want to read the SystemPatch documentation. At least how to install/use it is needed to know. You can do -<patch> +<patch> for single patches. So launch "SystemPatch -RawDoFmt" to disable that patch. I can't remember why but I've disabled RawDoFmt for some reason. SystemPatch V3.3b here.
Right, I shall have another look at this this evening. Thanks awfully.
paul1981 is offline  
Old 22 August 2020, 18:33   #6
daxb
Registered User
 
Join Date: Oct 2009
Location: Germany
Posts: 2,694
Quote:
Originally Posted by paul1981 View Post
Also, in the SystemPatch docs it specifies the installation of SystemPatch AFTER IPrefs,
Maybe IPrefs patch/use some functions? At least FastIPrefs patches 10 functions of different libraries here. One of it is RawDoFmt(). I start SystemPatch before FastIPrefs.
daxb is offline  
Old 23 August 2020, 13:34   #7
paul1981
Registered User

paul1981's Avatar
 
Join Date: Oct 2013
Location: England
Posts: 263
Right then, running SystemPatch with the options -RawDoFmt has fixed the Workbench titlebar / filerequester number format issue! Thanks awfully!

I have found the VirusZ issue too... You need to load SystemPatch with the -LoadSeg option. I suppose VirusZ keeps a checksum of LoadSeg and its xvs.library or similar, at any rate it is not happy at all with the LoadSeg of SystemPatch. The other solution is to load SystemPatch after VirusZ instead (just put it after VirusZ in the user-startup). Hmm..just found that in the SystemPatch docs about xvs.library! If it detects it it disables LoadSeg itself!

Next question, does anyone know why Intuition patch disable option NT is used by default (SystemPatch installs it this way into user-startup).

Next next question, does the 3.3b version add anything over 2.99 other than TLSFmem and ObtainBestPenA patches? Does the latter conflict with the new PeterK icon.library?
paul1981 is offline  
Old 23 August 2020, 15:48   #8
daxb
Registered User
 
Join Date: Oct 2009
Location: Germany
Posts: 2,694
Maybe the NT options is used as default because of known problems. About 3.3b vs. 2.99 the history says the same you wrote. If there is some hidden changes you need to ask Sante but he left Amiga several years ago. I think ObtainBestPenA() patch is obsolete with PeterK's icon.library but just ask Peter to be sure. If you don't need/want TLSFmem and ObtainBestPenA() then you can save use 3.3b and disable both. Here it works.

Last edited by daxb; 24 August 2020 at 15:45.
daxb is offline  
Old 24 August 2020, 10:37   #9
paul1981
Registered User

paul1981's Avatar
 
Join Date: Oct 2013
Location: England
Posts: 263
I find under WinUAE I can't really judge what improvements the TSLSFmem and ObtainBestPenA (OBPA) patches are doing, I'll have to fiddle around with my spare real A1200 when I get around to it. I did find 3.3b did cock-up one of my older pieces of software, and I assumed it to be TLSFmem, but as soon as I turned on the OBPA (as I had it disabled at the time), then TLSFmem worked and so maybe there's a bit of weirdness going on there. I just might stick with 2.99 after all.

What a shame Sante has left the Amiga though, I hope he comes back.
paul1981 is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
WinUAE request: show version in window titlebar hexaae support.WinUAE 6 24 April 2020 16:26
SystemPatch 3.1 ziosante News 32 30 August 2018 15:08
WB Screen Titlebar Enhancer Hewitson request.Apps 9 12 February 2008 15:55
SystemPatch 3.0 ziosante News 11 02 January 2008 01:50
Edit Workbench Titlebar *Please help* viddi request.Apps 9 17 June 2006 12:20

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 18:21.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.08842 seconds with 15 queries