English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 29 April 2019, 22:29   #1
blatboy
Registered User

blatboy's Avatar
 
Join Date: Mar 2017
Location: NYC/USA
Posts: 51
Battle of the ROMs - 3.4.1 & a3660 roms

A3000D

I've got 3.4.1 on the way with its custom ROMs

I have an a3660 installed, along with the custom ROMs it came with for the A3000.

I would assume (and I'm usually wrong when I do that) that it would be easier to add libraries to the 3.4.1 KS than the other way around. (I'm assuming there's less custom stuff on the a3660)

I'm rocking an 060 with FPU. Looking at Chucky's post on his site about the a3660 development:

Quote:
this board is technically just a 3640 board with internal 040-060 adapter. So this have a drawback. IF you have a full 060 cpu (with FPU) your machine WILL end at a endless guru. So you still will need a custom kickstart that disables the FPU at poweron. (that setpatch later enables.)
So, I would imagine that I take the 3.4.1 KS and add something that would turn off the FPU at poweron, and also add any 68060 library/libraries that need to be added?

I do have a ROM burner. (TL866) I haven't tried it yet. I have no experience with Remus or RomSplit. Happy to learn. Doesn't look like rocket science once I get me head around the overall job that needs to be done.

I have some 37C400s on the way. Perhaps I should have asked here first, now I'm wondering if they're compatible with the A3000...

I'm finding bits of info here and there but nothing that addresses this specific thing.

Any suggestions on how I should approach this?
blatboy is offline  
Old 29 April 2019, 22:52   #2
trixster
Guru Meditating

 
Join Date: Jun 2014
Location: England
Posts: 1,449
I believe 3.1.4 roms already have the code in to disable the fpu at boot. The fpu is then re-enabled by setpatch when the startup-sequence is run.
trixster is offline  
Old 29 April 2019, 22:53   #3
hooverphonique
ex. demoscener "Bigmama"

 
Join Date: Jun 2012
Location: Fyn / Denmark
Posts: 985
I think the 3.1.4 roms have 060 support already baked in..
hooverphonique is offline  
Old 29 April 2019, 22:58   #4
blatboy
Registered User

blatboy's Avatar
 
Join Date: Mar 2017
Location: NYC/USA
Posts: 51
So I should just be able to pop in the 3.4.1 ROMS and be good to go?

a-MAZE-ing
blatboy is offline  
Old 29 April 2019, 23:00   #5
trixster
Guru Meditating

 
Join Date: Jun 2014
Location: England
Posts: 1,449
yes, good to go, assuming you bought the 3.1.4 roms for an A3000 and not one of the other sets.
trixster is offline  
Old 29 April 2019, 23:03   #6
blatboy
Registered User

blatboy's Avatar
 
Join Date: Mar 2017
Location: NYC/USA
Posts: 51
Yup. I should be all clear there.

Woo Hoo! Looking forward to this.
blatboy is offline  
Old 29 April 2019, 23:25   #7
gdonner
Ancient Amiga User

gdonner's Avatar
 
Join Date: Mar 2018
Location: Elkhart / United States
Posts: 68
You will of course still need a 68060.library though; the one from Thomas Richter's MMULibs.lha archive should work just fine.

That, and the mmu.library (from the same archive) copied to LIBS: should be able to handle any '060-related software AFAIK.

Thanks to Anthony Hoffman's fine work, I'm gearing up to drop my recapped, polarity-fixed, and 3.2-upgraded A3640 into my A3000. My Amiga 4000 gets the new A3660. I just can't take much more of a 16MHz 68030--usable, but just barely. lol I'm too spoiled with speed these days.

Last edited by gdonner; 08 May 2019 at 02:45.
gdonner is offline  
Old 29 April 2019, 23:30   #8
blatboy
Registered User

blatboy's Avatar
 
Join Date: Mar 2017
Location: NYC/USA
Posts: 51
I won't need to burn that on the ROM though... just putting it in the LIBs folder should suffice, yes?
blatboy is offline  
Old 29 April 2019, 23:46   #9
trixster
Guru Meditating

 
Join Date: Jun 2014
Location: England
Posts: 1,449
68060.library and 680x0.library in LIBS:

Mmu.library can go in LIBS: too but it is worthwhile reading the mmu docs thoroughly first
trixster is offline  
Old 30 April 2019, 00:04   #10
blatboy
Registered User

blatboy's Avatar
 
Join Date: Mar 2017
Location: NYC/USA
Posts: 51
Got it. Thanks!
blatboy is offline  
Old 08 May 2019, 02:49   #11
gdonner
Ancient Amiga User

gdonner's Avatar
 
Join Date: Mar 2018
Location: Elkhart / United States
Posts: 68
@trixster: My understanding is that, with 3.1.4 in ROM, you don't need the 680x0.library; just copy the 68060.library and mmu.library to LIBS: and you're good to go.

3.1.4 automatically checks for your CPU, and loads 68060.library directly, without the need for any "dummy"-style 68040.library or 680x0.library file(s)--now a thing of the past.

Might also be worth write- and delete-protecting those two library files just in case.
gdonner is offline  
Old 08 May 2019, 07:30   #12
Jope
-
Jope's Avatar
 
Join Date: Jul 2003
Location: Helsinki / Finland
Age: 39
Posts: 7,398
As long as you have the 3.1.4 software installed, then this is accurate. Setpatch is the command which has been updated to be 68060.library aware.
Jope is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Split/join ROMs (kickstart ROMs) NLS support.Other 7 10 September 2018 00:54
A4000T won't boot with A4000T ROMs, but boots with A4000D ROMs 8bitbubsy support.Hardware 13 16 December 2015 20:47
FastATA MK-III & 3.1 ROMs shuttlepilot MarketPlace 6 09 June 2014 11:12
A1200 3.0 Roms & 32mb Simm ck1200 MarketPlace 6 03 July 2010 16:18
Wanted pinouts of 3000T roms and 3000 roms Vars191 support.Hardware 1 20 November 2008 11:38

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 12:55.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.09977 seconds with 15 queries