English Amiga Board


Go Back   English Amiga Board > Requests > request.Apps

 
 
Thread Tools
Old 30 August 2006, 10:49   #1
Tony Landais
Zone Friend
 
Join Date: Mar 2003
Location: uk
Posts: 426
MCP 1.45 valid link

I try to download MCP 1.45 but the link takes me to a registeration page
and I don't speak german...
Is there anybody kind enough to place the archive in the Zone?
http://mitglied.lycos.de/dgroppe/mcp.html
Tony Landais is offline  
AdSense AdSense  
Old 30 August 2006, 10:58   #2
lopos2000
Zone Friend
lopos2000's Avatar
 
Join Date: Apr 2005
Location: Cider is best In The West
Posts: 1,238
Here is the correct link where you can download the latest MCP.
http://mitglied.lycos.de/dgroppe/mcp.html
It's says on that page that they have some problem with downloading of MCP. Be patient.
Just thought. I've got the latest version but I am not sure if I am allowed to up it into the zone.
Mmm. I'll do it anyway. I upload it right now.

Last edited by lopos2000; 30 August 2006 at 11:05.
lopos2000 is offline  
Old 30 August 2006, 15:17   #3
Bamiga2002
BlizzardPPC'less

Bamiga2002's Avatar
 
Join Date: May 2004
Location: Finland
Age: 40
Posts: 3,210
Send a message via MSN to Bamiga2002
http://mitglied.lycos.de/dgroppe/amiga.html
Bamiga2002 is offline  
Old 30 August 2006, 15:18   #4
hexaae
Registered User

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 42
Posts: 838
I still prefer MCP 1.32beta12.
MCP 1.42+ is very unstable and have a lot of bugs yet. Just give a look at the changelog...
This is my advice.
hexaae is offline  
Old 30 August 2006, 15:30   #5
mrodfr
Registered User
mrodfr's Avatar
 
Join Date: Jan 2005
Location: 62-France
Age: 50
Posts: 413
hello,

MCP 1.45 is very stable and have no bugs (maybe some because no is impossible . This is my advice.

If you have problems, you could join the beta team of MCP and betatest MCP beta versions like me.
mrodfr is offline  
Old 30 August 2006, 15:52   #6
hexaae
Registered User

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 42
Posts: 838
Quote:
Originally Posted by mrodfr
hello,

MCP 1.45 is very stable and have no bugs (maybe some because no is impossible . This is my advice.

If you have problems, you could join the beta team of MCP and betatest MCP beta versions like me.
Well, I'm an MCP2001 betatester too and have access to the betas and Changelog history file. Look at recent fixes. Not to be polemic but based on the recent changes in MCP 24-Jul-2006 15:37 I doubt it's very reliable. As an internal my advice is to use MCP 1.32b12. If you want to use MCP1.45 that's ok but don't be surprised if you'll have strange crashes and instabilities then.
MCP is a great project keep going but still needs fixes IMHO.
It probably also depends on every users' config...
hexaae is offline  
Old 30 August 2006, 16:49   #7
Tony Landais
Zone Friend
 
Join Date: Mar 2003
Location: uk
Posts: 426
Well I only use MCP for the shortcuts, auto assign and auto mount and still it's very unstable
that s why I only activate it when I really need those features
Tony Landais is offline  
Old 30 August 2006, 18:57   #8
mrodfr
Registered User
mrodfr's Avatar
 
Join Date: Jan 2005
Location: 62-France
Age: 50
Posts: 413
hello,

here, MCP 1.45 (or 1.44,1.43,...) are verry good and same often with beta version.

of course, testing mcp and beta versions during years give problems with mcp sometime but It's the work I would like to done for MCP.

there is often same kind of answers with MCP but all is just not work, unstable or have problems but thats all. thats maybe the reason that there is 3-4 betatesters for MCP and I don't remember the last mail hexaae send to the ML MCP beta

if you want stable MCP, help MCP beta team and the author of MCP by betatesting MCP.


My amiga was unstable some time before and I also sometime said that It's this program or this patch untill I just change to a new tower (dbox) and now my amiga pratically never crash without changed something about workbench and patchs. maybe not having overclock help to have a stable system like here.


tony landais: with just 3 feature with MCP give your amiga unstable and even Verry unstable ?? don't think that came from MCP. maybe some program stack in your amiga was too slow. I'm using the best stacksnoop to control the stack on my amiga. there is also program like stackattack to give security a bout stack during amiga boot.
mrodfr is offline  
Old 31 August 2006, 00:19   #9
hexaae
Registered User

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 42
Posts: 838
Don't worry, my sys is probably the most stable Amiga ever seen. I take really care of it with essential tools like SaferPatches etc. I test almost anything with MuForce and I'm a very experienced user.
Sadly MCP 1.42+ is buggy for functions like PowerSaving, NewClock, Reqtools patching, some patternmatching not 100% working and others bugs here and there, that's why I prefer old stable version.
Yes, I should be more active in MCP bug-reporting but I'm now betatesting a lot of other thing and sadly I have not other time. I reported some bugs in the past but the author sadly continued to add new features (with unavoidable other bugs) instead of first fixing all old bugs, so...
I still use MCP everyday and I hope it can be improved in the future!
hexaae is offline  
Old 31 August 2006, 07:53   #10
mrodfr
Registered User
mrodfr's Avatar
 
Join Date: Jan 2005
Location: 62-France
Age: 50
Posts: 413
hello,

It's sure that hits or bugs reported to mcp author aren't corrected immediately and sometime need some days or weeks because the author had his own life and work and is verry busy.

1. powersaving doesn't work well for aga and cgx and no code for P96. there is one with aga and one with cgx as betatesters and hard to found where is problems with powersaving.


2. for reqtools on mcp145 version beta B:

- MCP: ReqtoolsPatch: ASL to RT have destroyed Register a5 if*no TAGS given.


3. newclock: for all betatesters: newclock work well (aga,p96,cgx).


i'm curious to know others programs you betatests actually (as me and you like betatestings ????
mrodfr is offline  
Old 31 August 2006, 09:57   #11
hexaae
Registered User

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 42
Posts: 838
You can see me in credits for a lot of programs, even the old Term... FBlit, SystemPatch, amrss, some amigazeux prductions, SFS filesystem, old Vaporware products, PhotFolio 2.x (best thumb viewer), IBrowse 2.4 (!) etc.

BTW, if you use OS3.x+ don't forget to dload essential patches. Look for "OS39 update" on Aminet for example.

Sadly I reported the bugs more than once, 1 YEAR ago. I've asked the author why he continued to add new (+ new bugs) features before having all known bugs fixed but he said simply "I like and I need them". This is not a good pathway to follow for the serious dev of a program IMHO so I was disappointed and almost left the project...
Moreover, without offence to him who's doing a very complicated work, but some trivial bugs like "Ooops, routine A pointed to wrong address/subroutine of another patch..." makes me think MCP1.32b12+ won't ever be very reliable anymore in the future! Just my opinion

Ciao!

Last edited by hexaae; 31 August 2006 at 10:10.
hexaae is offline  
Old 31 August 2006, 10:43   #12
AMIGAZ
Amiga-Mad
AMIGAZ's Avatar
 
Join Date: Oct 2004
Location: Sweden
Age: 41
Posts: 1,286
Send a message via ICQ to AMIGAZ
Where can I find the latest stable MCP we are talking about here?
I'm using the 1.45 which I snatched from the AmiKit package which hasn't bugged out on me yet
AMIGAZ is offline  
Old 31 August 2006, 11:06   #13
Tony Landais
Zone Friend
 
Join Date: Mar 2003
Location: uk
Posts: 426
@ Hexaae

What patches do you recommend for OS3.9
I try to limit to minimum my patches list and only boot with

OxyPatcher 3.13
Setpatch + rom update 44.38
IDEFix97 119.14
Powericon 1.06
MagicMenu 2.35
KingCon 1.8

+ some OS3.9 updates from amikit
Workbench.library 45.131
icon.library 45.4
rexxsyslib.library 44.2
...
Tony Landais is offline  
Old 31 August 2006, 11:41   #14
AMIGAZ
Amiga-Mad
AMIGAZ's Avatar
 
Join Date: Oct 2004
Location: Sweden
Age: 41
Posts: 1,286
Send a message via ICQ to AMIGAZ
noticed one thing with MCP 1.45 with almost all MCP stuff turned off...the last icon in AmiDock is always gone (lol)
AMIGAZ is offline  
Old 31 August 2006, 12:45   #15
hexaae
Registered User

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 42
Posts: 838
Quote:
Originally Posted by Tony Landais
@ Hexaae

What patches do you recommend for OS3.9
I try to limit to minimum my patches list and only boot with

OxyPatcher 3.13
Setpatch + rom update 44.38
IDEFix97 119.14
Powericon 1.06
MagicMenu 2.35
KingCon 1.8

+ some OS3.9 updates from amikit
Workbench.library 45.131
icon.library 45.4
rexxsyslib.library 44.2
...
...very important is also settings.mui (for MUI 3.8) patch in the OS39_update_patches archive.
You MUST have right after Setpatch in your SSeq 'SaferPatches' (the best of its kind), see Aminet.
The rest of your cfg looks good.
I see you have no gfx patches like FBlit so I assume you have a gfx card and won't need them (maybe just FText?).

I personally use another config though. I use Blizkick 1.24 and avoid Setpatch's ROM rekicking... and I have the MuLib package installed, so I use MuRedox (OXY/CyberPatcher clone for MuLib system) and 68060.library 40.18 (12-Nov-01) (c) 1999-2001 The MMU.lib development group, THOR...

My SSeq beginning:
C:BK * MODULE LocalFast scsi.device shell bootmenu ram-handler FileSystem.resource L:FastFileSystem PatchMath020 DosResetCard NoClick NewAlert RomFixes FusionReserve PowerWindows RebootFix EXTRESBUF=101200 QUIET

C:SetPatch QUIET
C:SaferPatches >NIL: INSTALL REMEMBER
;C:PoolMem INSTALL KEEPSORTED >NIL:
C:Cpu060 >NIL: STB
;SYS:MuTools/MuRedox >NIL:
;Run >NIL: SYS:MuTools/MuForce FILE=RAM:MuForce.log STACKLINES=20 DISPC DISRANGE=16
;Run >NIL: S:Batchfiles/Boot
NewAllocMem
FasterForbid
SYS:MuTools/MuFastZero >NIL: ON
Nixon:Prog/3.1_SWToolkit3/SegTracker
;Run <>NIL: LowFrag

...and then no other relevant patches (except things to speed-up AGA, and MCP 1.32b12). Rather clean system and I avoid bad hacks, just stable and safe patches when needed.

Last edited by hexaae; 31 August 2006 at 20:14.
hexaae is offline  
Old 31 August 2006, 16:31   #16
Tony Landais
Zone Friend
 
Join Date: Mar 2003
Location: uk
Posts: 426
Very interesting
I tried the mulib once but I didn t know all you could do with it
I give it a "serious" go to see how my system behaves

Any idea how to optimise the use of my picasso IV?
I have picasso96 but don't know much about PVS or PSI
Sometimes AGA applications (AIBB, TFX...) make my VGA workbench messy
I wonder how this is possible since GFX card memory and chip memory are 2 different things...
Tony Landais is offline  
Old 31 August 2006, 20:11   #17
hexaae
Registered User

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 42
Posts: 838
Quote:
Originally Posted by Tony Landais
Very interesting
I tried the mulib once but I didn t know all you could do with it
I give it a "serious" go to see how my system behaves

Any idea how to optimise the use of my picasso IV?
I have picasso96 but don't know much about PVS or PSI
Sometimes AGA applications (AIBB, TFX...) make my VGA workbench messy
I wonder how this is possible since GFX card memory and chip memory are 2 different things...
Sorry, see my signature (enable EAB to show signatures). I have AGA only. You should promote those screens probably.
hexaae is offline  
Old 31 August 2006, 22:52   #18
Tony Landais
Zone Friend
 
Join Date: Mar 2003
Location: uk
Posts: 426
@Hexaae
Your configuration is very good.
My OS is a little bit faster especially with MuRedox (about 5 to 10% faster than Oxypatcher and no bloody reboot to patch the system).
Many thanks for sharing your configuration
Tony Landais is offline  
Old 01 September 2006, 00:01   #19
AMIGAZ
Amiga-Mad
AMIGAZ's Avatar
 
Join Date: Oct 2004
Location: Sweden
Age: 41
Posts: 1,286
Send a message via ICQ to AMIGAZ
Quote:
Originally Posted by AMIGAZ
noticed one thing with MCP 1.45 with almost all MCP stuff turned off...the last icon in AmiDock is always gone (lol)
^bump
AMIGAZ is offline  
Old 01 September 2006, 07:10   #20
mrodfr
Registered User
mrodfr's Avatar
 
Join Date: Jan 2005
Location: 62-France
Age: 50
Posts: 413
hello,

I just would like to say that I'm little unhappy to see hexaae killed MCP 145 with too much speed and said good things just for the last version of alien design.

there is also users with mcp145 and work well with 80-90% of features to ON like me.

I just would like to see users play with 145 version and if problems decrease version after.

the authors of MCP had old mails with bugs found and try to add new features also at the same time just to make also funny things on MCP. he is not at home often because his job and try allways to continue to support MCP 68x also.

recently, for v1.44, he have corrected screenblanker time and hotkeys and the use again of garshneblanker and thats great. actually, he try to support multimedia keys for PC keyboard and at the same time correct bugs on reqtools patch and snap line and others things and all on assembly 68x only !!!.

It's also sad to see hexaae who know some problems he said with MCP don't support MCP untill bugs he know will be corrected, even if the author correct the bugs not immediately or days after because he had busy life also.

I'm also happy to see hexaae support amiga like he made with testing all the programs. with more guys like him, amiga users life will be more better.
mrodfr is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
MCP problems Basquemactee1 support.Apps 22 21 August 2016 22:23
Kickstart not valid Mr B project.WHDLoad 14 05 April 2011 12:18
mcp - visualprefs loth77 support.Apps 7 16 September 2010 22:51
Can .s be a valid extension for uploads please. redblade project.EAB 14 18 March 2010 13:10
MCP troubles..? Error support.WinUAE 11 22 January 2004 09:57

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 04:59.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.09846 seconds with 13 queries