English Amiga Board


Go Back   English Amiga Board > Support > support.Apps

 
 
Thread Tools
Old 10 July 2015, 01:58   #1
eva
Registered User

eva's Avatar
 
Join Date: Oct 2014
Location: Constanta / Romania
Posts: 202
[SOLVED] Geek Gadgets

Hello!

I am looking for a Geek Gadgets CD that has a GCC version of 2.95 at least. The gcc of the Amiga Gadgets in the zone is at 2.7. I am looking for the full ADE or a more recent snapshot than 1997 (which is the one in the zone). Or perhaps has any idea on what FTP server, or where to get it from? Alas, back2theroots is dead and the other sites link to dead mirrors...

Thanks!

Last edited by eva; 10 July 2015 at 15:41.
eva is offline  
Old 10 July 2015, 08:58   #2
thomas
Registered User
thomas's Avatar
 
Join Date: Jan 2002
Location: Germany
Posts: 5,681
http://aminet.net/package/dev/gcc/ADE
thomas is offline  
Old 10 July 2015, 15:41   #3
eva
Registered User

eva's Avatar
 
Join Date: Oct 2014
Location: Constanta / Romania
Posts: 202
Quote:
Originally Posted by thomas View Post
Thanks. That will do. Some things are missing such as X11 (emacs, etc...) but I've found a more complete archive on some FTP server:

Code:
lan.oxfordinspire.co.uk
which seems to contain updates till 10 February 1999 and also with gcc 2.95 and optionally gcc 3.X

I guess I will extract them on top of each other, ending with the ADE from AmiNET that you posted.
eva is offline  
Old 10 July 2015, 23:01   #4
eva
Registered User

eva's Avatar
 
Join Date: Oct 2014
Location: Constanta / Romania
Posts: 202
is there a reason why I am always getting Program failed (error: #8000000B) when trying to run utilities like "make"? I also got similar from other utilities... I do have an FPU. MaxTransfer is also set properly to 0x1fe00... I am using just the referenced ADE distribution from AmiNET.

Last edited by eva; 10 July 2015 at 23:06.
eva is offline  
Old 11 July 2015, 23:04   #5
eva
Registered User

eva's Avatar
 
Join Date: Oct 2014
Location: Constanta / Romania
Posts: 202
Ok, solved the issue above with the "#8000000B" that would occur on every tool from ADE / GG. It was due to the ixemul / ixnet libraries. Apparently, Genesis / AmiTCP did not complain at all and everything worked fine but it seems that they weren't entirely right. I just replaced them and it is working smooth now.
eva is offline  
Old 12 July 2015, 05:32   #6
matthey
Banned
 
Join Date: Jan 2010
Location: Kansas
Posts: 1,284
Quote:
Originally Posted by eva View Post
Ok, solved the issue above with the "#8000000B" that would occur on every tool from ADE / GG. It was due to the ixemul / ixnet libraries. Apparently, Genesis / AmiTCP did not complain at all and everything worked fine but it seems that they weren't entirely right. I just replaced them and it is working smooth now.
There are versions of make which don't use ixemul. There are also versions of make which are newer and are sometimes required for compiling more modern programs. GCC 2.95.3 and its tools are old even if it is good. Using ixemul is a kludge which may add to problems. Good luck.
matthey is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
What gadgets from the 80's are going to become Antiques? Paul_s Nostalgia & memories 70 25 February 2014 08:00
Hello from a 30 something Geek... Snowy Member Introductions 8 30 November 2011 10:05
Geek Gadgets, GCC and Ada uridium Coders. General 2 22 November 2011 20:54
geek gadgets / ade? hippie2000 Coders. General 9 23 December 2007 00:46
geek gadgets 2 CDRom Slayer Coders. General 0 12 March 2005 13:08

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 16:00.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.06482 seconds with 13 queries