English Amiga Board


Go Back   English Amiga Board > Other Projects > project.WHDLoad

 
 
Thread Tools
Old 25 February 2010, 00:11   #1
Mantas
 
Posts: n/a
Dos-error #212 devs:kickstarts/kick34005.a500

Hi all

Ok so I got myself an accelerator card with 8MB so I can run games using WHDload. Previously I used to get an error about not enough memory but this has been resolved (I think) with the new card.

However, now I keep getting the error Dos-error #212 (object is not of required type) on readingdevs:kickstarts/kick34005.a500

I have got these files in this location..WORKBENCH\DEVS\KICKSTARTS

kick34005.a500
kick34005.a500.rtb
kick34005.a500.pat

(the last 2 I got off aminet skick346.lha)

I've done loads of searching for this and as far as I can tell, the files are in the correct location.
I have also tried many different kickstart ROMS for the A500 but they all give me the same error.

The way I'm doing it as follows...
Download the files from Aminet, WHDload or HOL.
Unzip them on PC and then copy them over to my flash drive using WINUAE.
Run the game and then do this... and then
It's a lovely machine but god is it infuriatingly difficult to use for noobs.

Any help would be appreciated.

Thank you
 
Old 25 February 2010, 00:19   #2
prowler
Global Moderator

prowler's Avatar
 
Join Date: Aug 2008
Location: Sidcup, England
Posts: 10,300
Quote:
Originally Posted by Mantas View Post
The way I'm doing it as follows...
Download the files from Aminet, WHDload or HOL.
Unzip them on PC and then copy them over to my flash drive using WINUAE.
Run the game and then do this... and then
Hi Mantas,

You need to decompress the files on your Amiga to preserve the file attributes. That is what is causing your DOS Error. (Without the correct attribute, the file is seen as the wrong type.)
prowler is offline  
Old 25 February 2010, 00:22   #3
Mantas
 
Posts: n/a
Hi Prowler. How do I go about that? The files I have downloaded are in .ZIP format and when I unzip them they look like this...Kickstart v1.3 rev 34.5 (1987)(Commodore)(A500-A1000-A2000-CDTV)[!].rom

What I do then is rename it to kick34005.a500
 
Old 25 February 2010, 00:29   #4
prowler
Global Moderator

prowler's Avatar
 
Join Date: Aug 2008
Location: Sidcup, England
Posts: 10,300
Quote:
Originally Posted by Mantas View Post
Hi Prowler. How do I go about that? The files I have downloaded are in .ZIP format and when I unzip them they look like this...Kickstart v1.3 rev 34.5 (1987)(Commodore)(A500-A1000-A2000-CDTV)[!].rom
You must copy the compressed Zip files over to your Amiga and then extract them with an Amiga unzipping utility. This will preserve the file attributes.

I am a little surprised that the archives are in Zip format. I would have expected them to be in Lha format if they had been downloaded directly from Aminet. Perhaps you should search for new archives from there before starting again. Just use the Aminet search facility.

Quote:
Originally Posted by Mantas View Post
What I do then is rename it to kick34005.a500
That step is fine.
prowler is offline  
Old 25 February 2010, 00:32   #5
Mantas
 
Posts: n/a
Errr, I didn't get the kickstart file from Aminet, I just got them off torrents. They the same files I use on WINUAE and they work fine on that.
 
Old 25 February 2010, 00:41   #6
prowler
Global Moderator

prowler's Avatar
 
Join Date: Aug 2008
Location: Sidcup, England
Posts: 10,300
The kickstart file itself is not the problem. It is the file attributes associated with that file.

To correct it, open a command line shell (from your system folder), and type
cd devs:kickstarts
protect kick3405.a500 +rwed
endcli

That should fix it!
prowler is offline  
Old 25 February 2010, 01:10   #7
Mantas
 
Posts: n/a
Dude, you are the MAN!!!
That does work. One thing I noticed though, another reason why maybe wasn't working is because the kick34005.a500 file was in a drawer. Once I took it out and copied it to the root of devs:kickstarts it worked.
Either way, you have been a great help.

Now I can play Defender of the Crown without the annoying disk swapping :-)
 
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
WHDLoad: Devs:Kickstarts/kick40068.A1200 Error c0dehunter support.WinUAE 16 25 July 2016 00:34
Putting Kickstarts in the DEVS: folder Nostalgeek New to Emulation or Amiga scene 16 18 November 2008 15:54
"DOS-Error #205 (object not found) on reading "devs:kickstarts/kick 40068.a4000" Brutal_dentist New to Emulation or Amiga scene 10 04 April 2005 00:12
"DOS-Error #205 (object not found) on reading "devs:kickstarts/kick 40068.a4000" Unregistered New to Emulation or Amiga scene 1 22 December 2004 10:48

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 06:02.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.06236 seconds with 13 queries