English Amiga Board


Go Back   English Amiga Board > Coders > Coders. System

 
 
Thread Tools
Old 10 November 2018, 18:29   #2921
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,376
No, nothing like that happens on my system, neither on OS 3.9+3.1.4, nor on the same with AfA and my icon.library activated. Check your Envarc:datatypes/exe.prefs. On my system it's an empty file (0 bytes). Check your system for possible patches like MCP or scan all for "def_system" strings.
Attached Thumbnails
Click image for larger version

Name:	Workbench.png
Views:	19
Size:	8.3 KB
ID:	60763   Click image for larger version

Name:	OS314.png
Views:	20
Size:	114.2 KB
ID:	60764   Click image for larger version

Name:	AfA+myIconLib.png
Views:	23
Size:	125.4 KB
ID:	60765  
PeterK is offline  
Old 10 November 2018, 19:16   #2922
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 3,756
- Envarc:datatypes/exe.prefs-> I have no file named exe.prefs

- MCP Startup-sequence Disable
- MCP Prefs Disable
- Datatypes Prefs Disable

After renaming everything and restarting the system "def_wxw.info" it is always requested (see screenshot)

This happens on all of my AFA-OS systems including AfAWB1.4.
Probably something is missing from your AfA-OS!

Last edited by AMIGASYSTEM; Yesterday at 09:51.
AMIGASYSTEM is offline  
Old 10 November 2018, 19:41   #2923
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,376
An Aminet search for "def_exe" finds these tools:

http://aminet.net/package/dev/basic/AmiBlitz3
http://aminet.net/package/dev/c/APPSource
http://aminet.net/package/dev/e/powerd
http://aminet.net/package/dev/lang/SecalDemo

Anything installed ?
PeterK is offline  
Old 10 November 2018, 19:50   #2924
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 3,756
No ever used, now I try to install AfA-OS 4.8 on an OS3.9 Standard
AMIGASYSTEM is offline  
Old 10 November 2018, 19:58   #2925
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,376
There is no string "def_exe" in any file of the complete OS 3.9 CD or in AfA_OS 4.8.

Why don't you scan your system for this string?

Ok, it's still possible that some program could call GetIconTagList() with the tags 'deficon by name "exe"', that would also load ENV:Sys/def_exe.info, but usually the name of the tool is not "exe".

Do you have MultiView_AfA installed ?

Last edited by PeterK; 10 November 2018 at 20:15.
PeterK is offline  
Old 10 November 2018, 21:02   #2926
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 3,756
Quote:
Why don't you scan your system for this string?
Already done

Quote:
Do you have MultiView_AfA installed ?
No never used moved to archive

Testeted OS3.9 BB4 + AfA-OS 4.8 and it is not required def_exe.info (see screnshot)

Surely there will be some application that does this, sooner or later I will find it '

Important that now the icon.library works flawlessly on Afa-OS, now I can see well the icons OS4 / DualPNG from dopus4, now also OS4 recognizes all the icons AfA-OS

Last edited by AMIGASYSTEM; Yesterday at 09:51.
AMIGASYSTEM is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
ClassicWB Full and icon.library 46.4 Retroplay project.ClassicWB 8 05 August 2018 14:57
WB library conflict/versions Akira support.Apps 3 22 July 2010 19:47
PNG Icon to Color Icon Converter? Leandro Jardim request.Apps 1 24 May 2010 05:39
What's the latest version of icon.library for OS3.9? NovaCoder support.Apps 3 30 June 2009 16:43
Requesting icon.library v44+... nikvest request.Other 2 16 September 2007 02:58

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 11:12.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.17540 seconds with 15 queries