English Amiga Board


Go Back   English Amiga Board > Support > support.Other

 
 
Thread Tools
Old 11 December 2020, 12:46   #101
Rotzloeffel
Registered User
 
Join Date: Oct 2012
Location: Wolfach / Germany
Posts: 80
For the Records..... actual state.

CV64/3D Dragging works in all resolutions and Depth now. Oversized screens working and Scrolling works smoothly. Last issue with 320*240 in 8 and 16 bit solved…. Driver Needs some last "love" now.

CybervisionPPC/BVisionPPC switching to a native Amiga-screen works now with a patch, which kills the Pseudo-screenmode-feature of these cards in startup-sequence (like bppcfix from Frank Wille) also needs some further love

hope Thomas releases these two soon
Rotzloeffel is offline  
Old 15 December 2020, 17:14   #102
Thomas Richter
Registered User
 
Join Date: Jan 2019
Location: Germany
Posts: 968
It's not up to me to make releases. It seems Jens was in a pre-lockdown busy-mode. Let it be as it is, the 3.0.1 of P96 is now available for immediate download.

The list of changes is as follows:

- The S3Virge driver did not fully support screen dragging since the
driver used the S3 "stream processor" to generate the picture.
Unfortunately, the stream processor does not support screen splitting.
The new driver redirects the video output to the VGA engine as soon
as the user starts dragging, and re-enables the stream processor as
soon as a screen takes the entire monitor space.
- The rtg.library detects now the case that P5 patches to the display
info database were removed, and then no longer forces the
"FakeNative" option.
- The SetRGB32() functions and related functions to alter the palette
were not callable from supervisor state, in an attempt to avoid
calling into exec semaphores if the call comes from an interrupt.
Unfortunately, this broke Shapeshifter who makes all calls from
supervisor mode, though not from interrupts. The code is now a bit
more careful to test for interrupt calls and disregard only those
where semaphore calls are not safe.
- The 3DLabsPermedia2 driver was not installed along with the
CVisionPPC driver. This was fixed in the installer script.
- If the GRANTDIRECTACCESS tooltype of the 3DLabsPermedia2 monitor
driver is set, the driver now only offers support for the subset
of the available modes that can coexist without triggering an
aperture switch. This may help for 3D software that requires
direct access to the video RAM.
- The Cirrus5434 driver did not set the BIF_ILACEHALFSPRITEY as it
should, thus scaled the sprite offset wrongly in interlace modes.
- The S3Virge driver did not support double scan modes correctly as
its stream processor seems not to operate correctly for such
modes.
- ModifySprite() did not work correctly if the ViewPort argument was
set to NULL. In such a case, the function did not update the sprite
image correctly, breaking the MouseBlanker commodity.
- If the P-IV requires board memory for the flicker fixer, this throws
now other screens off-board to ensure that there is sufficient memory
available for the native screen(s).
- Fixed a possible race condition when allocation a new bitmap, the
compatibility check for the current RGB mode was not properly protected
by the board lock.
- If P96 detects that no alien code patched the display info database,
the CVisionPPC forced mode promotion is disabled. That is, if an
additional tool removes the P5 patches from the system, native screen
modes become functional again.
Thomas Richter is offline  
Old 17 December 2020, 16:12   #103
Thomas Richter
Registered User
 
Join Date: Jan 2019
Location: Germany
Posts: 968
Another ping on this. I also updated the developer documentation - no, the interface has not changed, I just hoped I improved its description. You may want to nag Jens about putting it online.
Thomas Richter is offline  
Old 17 December 2020, 20:49   #104
nogginthenog
Amigan

 
Join Date: Feb 2012
Location: London
Posts: 1,051
Something odd here. After running the setup S3ViRGE.chip is not updated.

Code:
version libs:Picasso96/S3ViRGE.chip full file   
S3ViRGE.chip 7.529 (13/04/20)
Code:
version ram:Picasso96Install/Libs/Picasso96/S3ViRGE.chip full file
S3ViRGE.chip 7.59 (04/12/20)
If I manually copy the file screen dragging works.

libs:Picasso96/S3ViRGE.chip has a date of 13/04 if that helps.
nogginthenog is offline  
Old 20 December 2020, 15:44   #105
Rotzloeffel
Registered User
 
Join Date: Oct 2012
Location: Wolfach / Germany
Posts: 80
Quote:
Originally Posted by nogginthenog View Post
Something odd here. After running the setup S3ViRGE.chip is not updated.

Code:
version libs:Picasso96/S3ViRGE.chip full file   
S3ViRGE.chip 7.529 (13/04/20)
Code:
version ram:Picasso96Install/Libs/Picasso96/S3ViRGE.chip full file
S3ViRGE.chip 7.59 (04/12/20)
If I manually copy the file screen dragging works.

libs:Picasso96/S3ViRGE.chip has a date of 13/04 if that helps.

Seems to be a Bug in the installer! checked today with cybervisionPPC on a clean system and it did not copy the .chip at all !


Thangs for Reporting this!


Harald
Rotzloeffel is offline  
Old 20 December 2020, 17:42   #106
Thomas Richter
Registered User
 
Join Date: Jan 2019
Location: Germany
Posts: 968
This bug is long fixed in the distribution version, Harald. You have the beta version.
Thomas Richter is offline  
Old 21 December 2020, 09:01   #107
Rotzloeffel
Registered User
 
Join Date: Oct 2012
Location: Wolfach / Germany
Posts: 80
Thanks Thomas
Rotzloeffel is offline  
Old 21 December 2020, 13:16   #108
Thomas Richter
Registered User
 
Join Date: Jan 2019
Location: Germany
Posts: 968
Quote:
Originally Posted by nogginthenog View Post
Something odd here. After running the setup S3ViRGE.chip is not updated.

I wouldn't really know why. Make sure that when you update and select the update installation, you select the right option as what to update. "Drivers" is not what you want because this means the "AdPro" and related drivers for particular software. You want the first option, "Graphic card drivers", and you probably need to select the right graphics card. You also need to reboot after installation to load the new libraries.
Thomas Richter is offline  
Old 21 December 2020, 19:05   #109
nogginthenog
Amigan

 
Join Date: Feb 2012
Location: London
Posts: 1,051
I made a copy of the original S3ViRGE.chip before I manually updated it. So I copied this to S3ViRGE.chip.

Before:

Code:
list SYS:Libs/Picasso96/S3ViRGE#?
S3ViRGE.chip.old           17724 ----rw-d Thursday  18:38:24
S3ViRGE.chip               17724 ----rw-d Today     16:48:36
Reboot

Upgrade P96
- Choose Update an Installed version.
- All options are selected
- CyberVision64/3D checked
- Keep old settings
- Don't install the printer patch

After:

Code:
list SYS:Libs/Picasso96/S3ViRGE#?
Directory "Boot:Libs/Picasso96" on Monday 21-Dec-20
S3ViRGE.chip.old           17724 ----rw-d Thursday  18:38:24
S3ViRGE.chip               17724 ----rw-d Today     16:48:36
Reboot. No change.

My installer is this if it helps.
Code:
Picasso96_3.0.1.lha   501963 ----rwed Tuesday   18:51:56
This is the file from the installer:
Code:
S3ViRGE.chip               18060 ----rw-d 04-Dec-20 17:26:48
nogginthenog is offline  
Old 21 December 2020, 21:30   #110
Thomas Richter
Registered User
 
Join Date: Jan 2019
Location: Germany
Posts: 968
What's the output of "ShowConfig" on your system?

Thanks,
Thomas
Thomas Richter is offline  
Old 22 December 2020, 13:44   #111
nogginthenog
Amigan

 
Join Date: Feb 2012
Location: London
Posts: 1,051
Code:
PROCESSOR:	CPU 68060/68882fpu/68060mmu
CUSTOM CHIPS:	AA PAL Alice (id=$0023), AA Lisa (id=$00F8)
VERS:	Kickstart version 46.143, Exec version 46.45, Disk version 45.194
RAM:	Node type $A, Attributes $505 (FAST), at $8000000-$FFFFFFF (128.0 meg)
	Node type $A, Attributes $505 (FAST), at $7000000-$7FFFFFF (16.0 meg)
	Node type $A, Attributes $703 (CHIP), at $4000-$1FFFFF (~2.0 meg)
BOARDS:
 Phase 5 Digital Products CyberStorm:   Prod=8512/25($2140/$19) (@$EA0000 128K)
 individual Computers X-Surf 100 Rev.3 Z-II/Z-III Ethernet:   Prod=4626/100($1212/$64)
     (@$40000000, size 64meg, subsize 64K)
 Phase 5 Digital Products CyberVision 64/3D:   Prod=8512/67($2140/$43)
     (@$50000000, size 256meg, subsize same)
nogginthenog is offline  
Old 22 December 2020, 23:17   #112
Thomas Richter
Registered User
 
Join Date: Jan 2019
Location: Germany
Posts: 968
Quote:
Originally Posted by nogginthenog View Post
I made a copy of the original S3ViRGE.chip before I manually updated it. So I copied this to S3ViRGE.chip.

What happens if you install in expert mode?
Thomas Richter is offline  
Old 23 December 2020, 15:55   #113
nogginthenog
Amigan

 
Join Date: Feb 2012
Location: London
Posts: 1,051
That works!
nogginthenog is offline  
Old 23 December 2020, 16:03   #114
DamienD
disengaged
DamienD's Avatar
 
Join Date: Aug 2005
Location: London / Sydney
Age: 44
Posts: 19,591
Quote:
Originally Posted by Thomas Richter View Post
What happens if you install in expert mode?
Quote:
Originally Posted by nogginthenog View Post
That works!
I would have thought that everybody who installs Amiga software selects "Expert" mode; so that you can see / change all options
DamienD is offline  
Old 27 January 2021, 13:55   #115
Thomas Richter
Registered User
 
Join Date: Jan 2019
Location: Germany
Posts: 968
The 3.0.2 release of P96 is now available for registered customers. The following changed:

- Added a new flag to indicate that the sprite resolution is halfed
horizontally on double-clocked rates. Thie Cirrus GD5434 is a victim
double-clocking, and hence had a wrongly positioned mouse pointer
in double clocked modes.
- Computation of the total required video RAM for enabling the screen
dragging was not correct, and did not take alignment requirements
of screens into account. This was fixed now.
- The Z-III configuration of the CyberVision3D was not in the database
of the installer script and thus failed to install the required
components.
- The S3Virge.chip driver was still delivered with a major version of 7,
though the major version should have been 42.
- Apparently, the legacy VGA engine of the S3 Virge chip has problems
pipelining its data while the blitter is accessing the video RAM. The
new driver therefore only enables the blitter if the stream processor
is enabled as well, which happens for non-double-clocked,
non-double-scan video modes and if no screen dragging is in process.
- The rtg.library did not accept a LoadModule'd version of the graphics
library as original and thus recognized it as "patched" by the P5
CVisionPPC driver, disabling the native modes.
- The 3DLabsPermedia2 driver is now more careful reseting the chip which
could create (physical) bus errors while the chip is still busy
performing the reset.
- Due to a missing bracket, the 3DLabsPermedia2 driver was still not
installed along with the CVisionPPC card driver.

Have fun,

Thomas
Thomas Richter is offline  
Old 27 January 2021, 17:08   #116
Thomas Richter
Registered User
 
Join Date: Jan 2019
Location: Germany
Posts: 968
To the mods: Maybe it would be of advantage to have this thread in a separate topic: Support/Software maybe?
Thomas Richter is offline  
Old 27 January 2021, 19:47   #117
nogginthenog
Amigan

 
Join Date: Feb 2012
Location: London
Posts: 1,051
Thanks Thomas, your work is very appreciated here!

I can confirm CVision3D.card & S3ViRGE.chip were updated by the installer in intermediate mode.
Everything seems to be working well.

I'm not a fan of the screen dragging but it's been so long I can't even remember how CGFX works (I would have been using a low res VGA monitor back then).

I agree with ThoR, we need a separate topic/area.
nogginthenog is offline  
Old 28 January 2021, 21:59   #118
lilalurl
Global Moderator
lilalurl's Avatar
 
Join Date: Aug 2001
Location: France
Posts: 3,289
Send a message via ICQ to lilalurl
Quote:
Originally Posted by Thomas Richter View Post
To the mods: Maybe it would be of advantage to have this thread in a separate topic: Support/Software maybe?
Since it has turned into a support thread, it could indeed be done. Support.Other would fit I guess.
Would it need a thread split (please point to the post where it should be started from) or should the whole thread be moved?
lilalurl is offline  
Old 28 January 2021, 22:51   #119
Thomas Richter
Registered User
 
Join Date: Jan 2019
Location: Germany
Posts: 968
Everything from #123 (start of 3.0.0) would be adequate. Thanks!
Thomas Richter is offline  
Old 28 January 2021, 23:55   #120
lilalurl
Global Moderator
lilalurl's Avatar
 
Join Date: Aug 2001
Location: France
Posts: 3,289
Send a message via ICQ to lilalurl
Done. Thread titled as seemed adequate to me, but you might something else to suggest so feel free and I'll edit accordingly.
lilalurl is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
P96: What's the right way to do X? Warty Coders. General 2 21 December 2020 01:00
Providing 2 fire button support / cd32 joypad support amigapd request.Other 0 13 July 2015 18:20
Portaudio support (was: WinUAE support for ASIO drivers) Akira support.WinUAE 57 28 March 2009 22:15
Classic WB P96 Anubis project.ClassicWB 5 08 May 2006 15:30
amiga-news.de: Collected software-news Paul News 0 14 November 2004 16:50

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 23:49.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.11030 seconds with 16 queries