English Amiga Board


Go Back   English Amiga Board > Support > support.FS-UAE

 
 
Thread Tools
Old 30 April 2013, 19:31   #1
Marskilla
Registered User
Marskilla's Avatar
 
Join Date: Sep 2012
Location: Nantes - France
Posts: 114
FS-UAE 2.2.2 can't reach configuration file

I noticed a bug (I think).

Under Windows, if fs-uae is ran with a configuration file as a parameter , and if the configuration file is located in a path containing special parameters, fs-uae cannot reach it.

For example :

Code:
fs-uae.exe "C:\users\abcédé\my documents\config.fs-uae"
does not work.
Marskilla is offline  
Old 30 April 2013, 20:29   #2
FrodeSolheim
FS-UAE Developer

FrodeSolheim's Avatar
 
Join Date: Dec 2011
Location: Førde, Norway
Age: 39
Posts: 3,693
Hi, I've tested and can confirm the problem (it also occurs when "doubleclicking" on a .fs-uae file to launch it in FS-UAE if the path contains non-ASCII characters. The issue is that FS-UAE, as it is written, expects the path in UTF-8 (which is fine for config files, but not for command line arguments on Windows).

I'll post an update when I have developed a fix for the issue.
FrodeSolheim is offline  
Old 01 May 2013, 09:48   #3
Marskilla
Registered User
Marskilla's Avatar
 
Join Date: Sep 2012
Location: Nantes - France
Posts: 114
Quote:
Originally Posted by Marskilla View Post
(...)the configuration file is located in a path containing special parameters(...)
I meant special characters, but hopefully you got it right.
Marskilla is offline  
Old 30 May 2013, 22:44   #4
FrodeSolheim
FS-UAE Developer

FrodeSolheim's Avatar
 
Join Date: Dec 2011
Location: Førde, Norway
Age: 39
Posts: 3,693
Hi, please try the beta version of the upcoming 2.2.3 version. This version includes a fix which should allow paths with non-ASCII characters to be opened as program parameter on Windows:

http://fs-uae.net/stable/2.2.3b1/
FrodeSolheim is offline  
Old 08 June 2013, 09:56   #5
FrodeSolheim
FS-UAE Developer

FrodeSolheim's Avatar
 
Join Date: Dec 2011
Location: Førde, Norway
Age: 39
Posts: 3,693
Hi, did you have time to test if the new version works for you yet?
FrodeSolheim is offline  
Old 22 June 2013, 14:58   #6
Marskilla
Registered User
Marskilla's Avatar
 
Join Date: Sep 2012
Location: Nantes - France
Posts: 114
Quote:
Originally Posted by FrodeSolheim View Post
Hi, did you have time to test if the new version works for you yet?
Hi. Sorry, I was monitoring the website waiting for a new version.
I Just found it here.

I just tested v 2.2.3b1.

I created a "C:\e\config.fs-uae" file and dragged the file on fs-uae.exe.

It worked

I renamed the "C:\e" path into "C:\é" and dragged the configuration file on fs-uae and it didn't work.

Sorry.
Marskilla is offline  
Old 22 June 2013, 21:21   #7
FrodeSolheim
FS-UAE Developer

FrodeSolheim's Avatar
 
Join Date: Dec 2011
Location: Førde, Norway
Age: 39
Posts: 3,693
Hi, since the warning about missing config disappeared, I thought I was done, but the testing was obviously a bit sloppy - on closer inspection there was a bit missing (the config didn't actually load )

Can you test this one? http://fs-uae.net/stable/2.2.3b2/
FrodeSolheim is offline  
Old 25 June 2013, 11:16   #8
Marskilla
Registered User
Marskilla's Avatar
 
Join Date: Sep 2012
Location: Nantes - France
Posts: 114
Yay ! It Works. (v2.2.3b2)
Marskilla is offline  
Old 25 June 2013, 21:13   #9
FrodeSolheim
FS-UAE Developer

FrodeSolheim's Avatar
 
Join Date: Dec 2011
Location: Førde, Norway
Age: 39
Posts: 3,693
Thanks for testing and reporting back, will publish 2.2.3 now (no changes from 2.2.3b2).
FrodeSolheim is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS-UAE: Configuration gilgamesh support.FS-UAE 6 24 April 2012 11:31
uae-configuration Foul support.WinUAE 2 15 April 2012 21:11
error parsing global configuration file line 16 DDNI project.WHDLoad 7 21 March 2011 13:09
associate disk image(s) to configuration file Toni Wilen request.UAE Wishlist 32 21 October 2009 08:22
uae-configuration Anubis support.WinUAE 1 15 August 2008 15:14

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 18:05.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.07331 seconds with 15 queries