English Amiga Board


Go Back   English Amiga Board > Support > support.FS-UAE

 
 
Thread Tools
Old 03 August 2014, 21:27   #1
toxicshadow
Registered User

 
Join Date: Jul 2014
Location: a
Posts: 11
Alien Breed : TA (CD32) stuck in boot?

Hi all,

Could someone test the CD32 version of Alien Breed : Tower Assault with the latest version of FS-UAE.

When I try to launch it I get the usual boot screen followed by the screen going black for a while. At this point I would expect the game to start loading but instead the screen goes grey and starts the boot process all over again. This repeats indefinitely.

I swear I have had it working in the past (quite a way in the past) so I am just trying to rule the emulator out first before I mess with my config.

Thanks.
toxicshadow is offline  
Old 03 August 2014, 22:51   #2
FrodeSolheim
FS-UAE Developer

FrodeSolheim's Avatar
 
Join Date: Dec 2011
Location: Førde, Norway
Age: 37
Posts: 3,427
Hmm... I get a reboot loop here too (using 2.5.6dev, please state what version you were using!). Increasing chip memory to 4MB gets it a bit further - to the game selection screen - but starting Tower Assault fails with several "not enough memory available errors".

If someone could test with the latest WinUAE 2.8.2beta, that would be great too!
FrodeSolheim is offline  
Old 03 August 2014, 23:00   #3
toxicshadow
Registered User

 
Join Date: Jul 2014
Location: a
Posts: 11
Good to know I wasn't doing anything wrong.

At the time of testing I was using version 2.5.5dev.

Sounds like a nasty memory leak somewhere along the lines.

Thanks for testing.
toxicshadow is offline  
Old 03 August 2014, 23:08   #4
toxicshadow
Registered User

 
Join Date: Jul 2014
Location: a
Posts: 11
Forgot to mention that I am using Ubuntu 14.04.

Increasing the memory to 8MB allows the game to be played. (not tested long enough to see if it crashes over time)
toxicshadow is offline  
Old 04 August 2014, 19:02   #5
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,017
Insert CD only after CD32 boot screen appears. There are few games that don't work if booted with CD inserted.
Toni Wilen is offline  
Old 04 August 2014, 21:57   #6
FrodeSolheim
FS-UAE Developer

FrodeSolheim's Avatar
 
Join Date: Dec 2011
Location: Førde, Norway
Age: 37
Posts: 3,427
Quote:
Originally Posted by Toni Wilen View Post
Insert CD only after CD32 boot screen appears. There are few games that don't work if booted with CD inserted.
Confirmed working in FS-UAE (thanks ). Note added to game database entry. OAGD.net / FS-UAE needs to support a delayed CD insert setting for games such as this.
FrodeSolheim is offline  
Old 05 August 2014, 15:43   #7
TEOL
Registered User
 
Join Date: Jul 2009
Location: Middlesex, England
Posts: 138
So basiclly to fix this problem on the latest beta max out the RAM to play CD's?

Edit: I tried that on the AMIGA PD Compilation and have to call BS on that one it didn't work a dime getting a CD to work. I still get a looping bios on the ISO so I think it's got more to do with the ISO mode being broke in both WINUAE and FS-UAE in this revision.

I can't downgrade to the last dev revision where it was working now as this new non CD working one took over the file download of it. lol.
TEOL is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Alien Breed 3D, stuck on level 8, Test Area Gamma HardStep support.Games 11 26 June 2011 15:20
Working WinUAE config for Alien Breed and Alien Breed II takeobass support.WinUAE 2 22 July 2008 15:48
Alien Breed CD32 animations NPI support.Games 8 26 December 2006 13:26
Alien Breed 3D on Winuae cd32 mode ??? synchro support.Games 2 10 June 2004 13:49
Looking for alien breed 3D on CD32? ravepants request.Old Rare Games 0 19 October 2003 15:15

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 12:44.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.06665 seconds with 15 queries