English Amiga Board


Go Back   English Amiga Board > Coders > Coders. Language > Coders. C/C++

 
 
Thread Tools
Old 15 December 2017, 18:26   #101
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,121
the edgar/mapeditor binaries do a version check, so you need to use the ppc-amigaos 1.27 files.
but start it from a shell/cli, so you will get some messages from the edgar/mapeditor binary.
Code:
game/
game/edgar   <--- 68k-wip from zone
game/edgar.pak  <--- file from aminet ppc-ammigaos version 1.27
game/mapeditor <--- 68k-wip from zone
just check the messages after you start the game from shell/cli.
in the start-intro sequence you can use space and return keys

once you quit the game you will see the FPS value.

Last edited by emufan; 15 December 2017 at 18:33.
emufan is offline  
AdSense AdSense  
Old 15 December 2017, 23:11   #102
xboxown
Registered User
 
Join Date: Dec 2012
Location: Vancouver/Canada
Posts: 251
K. When I return home I will try this out again and run it from CLI. But what do you advice if it happens again, it opens and quits instantly?
xboxown is offline  
Old 16 December 2017, 02:31   #103
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,121
Quote:
Originally Posted by xboxown View Post
K. When I return home I will try this out again and run it from CLI. But what do you advice if it happens again, it opens and quits instantly?
just did a test and it doesnt work as it did yesterday.
it cannot find certain dfata files ....

well, a solution is to use the uncompressed gamefile folders from the source code ( Source code (zip) --> edgar-1.27.zip ) .
Code:
game/
game/edgar   <--- 68k-wip from zone
game/edgar.pak  <--- file from aminet ppc-ammigaos version 1.27
game/mapeditor <--- 68k-wip from zone
game/data/ ...
game/font/...
game/gfx/...
game/locale/...
game/music/...
game/sounds/...
really weird :/
emufan is offline  
Old 16 December 2017, 03:16   #104
xboxown
Registered User
 
Join Date: Dec 2012
Location: Vancouver/Canada
Posts: 251
-ENORMOUS GRIN- You know what that means, right? When you release it to aminet it is going to be 90 MB original from the PPC version in addition to the data file which means the .lha file will be something along the line of 110 MB+ and more!!

BWAHAHAHAHAHAHAHAHAHAHAHAHAHAH YES! YES! YEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEES!!!!!!!!!!!!!!!!!!!!!!!!!

- wipes mouth - I am salivating at that thought and salivating at trying it out...mmmmmmmmmm! Delicious!

I wish new release of Amiga games be like 300+ MB worth in aminet...mmmmmmmmm!
xboxown is offline  
Old 16 December 2017, 07:18   #105
xboxown
Registered User
 
Join Date: Dec 2012
Location: Vancouver/Canada
Posts: 251
BUGS TO REPORT

A) Guru wen in the config file attempting to flag full screen to be true. It goes full screen then black screen, then guru and reboot.

B) In window screen the colors are all screwed up and the picture is tilted.

---
/ /
/ /
/ /
/ /
---

The font is mushed and unreadable in addition of the fact that the fonts can't be read.

https://image.ibb.co/gm8kUm/screesnhot.png

The screenshot toke directly from my Amiga via sgrab program.

Last edited by xboxown; 16 December 2017 at 07:26.
xboxown is offline  
Old 19 December 2017, 01:47   #106
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,121
sorry for delay, just missed it.
I get the same unplayable result. sdl 1.2.15 from github doesnt even work at all,
while the one from arti (1.2.15 - some earlier build i guess) - gives at least,
some gfx output, even unplayable.

fullscreen is a bit weird - on some apps/games/emus it does work, while other do not work.
I tried to change some flags for the screen mode , but cannot see what makes it work or not.

does edgar, what you have right now, gives some playable FPS result?
game should list the FPS when you quit it, start from shell, try to enter the game, then just quit using game-window close gadget
emufan is offline  
Old 19 December 2017, 03:24   #107
xboxown
Registered User
 
Join Date: Dec 2012
Location: Vancouver/Canada
Posts: 251
Quote:
Originally Posted by emufan View Post
sorry for delay, just missed it.
I get the same unplayable result. sdl 1.2.15 from github doesnt even work at all,
while the one from arti (1.2.15 - some earlier build i guess) - gives at least,
some gfx output, even unplayable.

fullscreen is a bit weird - on some apps/games/emus it does work, while other do not work.
I tried to change some flags for the screen mode , but cannot see what makes it work or not.

does edgar, what you have right now, gives some playable FPS result?
game should list the FPS when you quit it, start from shell, try to enter the game, then just quit using game-window close gadget
I know for now your main focus is the fps result. Today I will for sure post the result for you, but from here at work I can tell you it is 30% faster and that was with my slower core (as I am beta testing different core speeds and versions). If I can get my core back to it's original speed I can tell you from now without even testing that it would run an easy 30 fps if not 40 fps, just like that. In windows mode with the slow core it is already reaaaallly fast...so picture faster core and in full screen.

I know maze of galius that arti ported is using old sdl so it is crawling to a halt speed and need serious core boost to become playable...but edgar with the new sdl that grelbfarlk provided have truly speed many things up.

While I am at it..when we are done with edgar and got the bug fixes how difficult would it be to take current code of ffplay from aminet and just recompile it..you don't even need to do any core changes or modify anything..just click the < compile button and let it compile it with the new sdl?

I am only asking because yesterday at core x10 it was playing slow but faster than the older faster core due to improvements and enhancements each new core release. If you could recompile it with the new SDL and with a faster core ffplay maybe the new vlc player for amiga 68k as the speed would boost by 30% easy allowing me to watch mp4 and mpg movie at the equal speed as a normal PC and it does have already integrated GUI system which allows me to pause, fast forward, rewind, stop, playlist with a click of a mouse button where as RIVA doesn't have a GUI and doesn't allow to fast forward and rewind at will.

As soon as I arrive home in an hour I will post the result of the fps.
xboxown is offline  
Old 19 December 2017, 04:40   #108
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italia)
Posts: 2,276
On AFA OS works well !


Attached Thumbnails
Click image for larger version

Name:	DGen.jpg
Views:	756
Size:	143.1 KB
ID:	55884  
AMIGASYSTEM is offline  
Old 19 December 2017, 04:55   #109
xboxown
Registered User
 
Join Date: Dec 2012
Location: Vancouver/Canada
Posts: 251
Quote:
Originally Posted by emufan View Post
sorry for delay, just missed it.
I get the same unplayable result. sdl 1.2.15 from github doesnt even work at all,
while the one from arti (1.2.15 - some earlier build i guess) - gives at least,
some gfx output, even unplayable.

fullscreen is a bit weird - on some apps/games/emus it does work, while other do not work.
I tried to change some flags for the screen mode , but cannot see what makes it work or not.

does edgar, what you have right now, gives some playable FPS result?
game should list the FPS when you quit it, start from shell, try to enter the game, then just quit using game-window close gadget
This is the information you are seeking:

edgar
Locale is
Opening locale///LC_MESSAGES/edgar.mo
Failed to open locale///LC_MESSAGES/edgar.mo
Numeric is C
atof(2.75) is 2.750000
Found 2 joysticks. Opening Joystick #0: Port 2 Amiga Joystick/Joypad
Joystick has 3 buttons
Joystick has 2 axes
DEV Version
127 frames in 7808 milliseconds (16.27 fps)
Exiting
xboxown is offline  
Old 19 December 2017, 19:39   #110
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,121
@AMIGASYSTEM: thanks for feedback

@xboxown: thanks. 16 FPS is not so bad I guess for this kind of game, i think.
30 - 40 sounds promissing

this ffmpeg pack? - no source files included, no makefile or patches, if there are any required - not sure, if I can do it :/
emufan is offline  
Old 19 December 2017, 19:50   #111
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italia)
Posts: 2,276
with "edgar" i have color problems and slanted screen

Last edited by AMIGASYSTEM; 22 December 2017 at 09:36.
AMIGASYSTEM is offline  
Old 19 December 2017, 19:53   #112
xboxown
Registered User
 
Join Date: Dec 2012
Location: Vancouver/Canada
Posts: 251
Quote:
Originally Posted by AMIGASYSTEM View Post
with "edgar" i have color problems and slanted screen
'

Exactly...that is the problem I am facing too if you notice in my earlier post I have pasted screenshot.
xboxown is offline  
Old 19 December 2017, 20:45   #113
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,121
yes, thats the problem. using sdl 1.12.15 build by arti, which works with other things,
but results in graphics failures.

zone: edgar-68k_sdl.1.12.15-github-WIP.lha
this does crash with winuae - just try.
emufan is offline  
Old 19 December 2017, 21:11   #114
xboxown
Registered User
 
Join Date: Dec 2012
Location: Vancouver/Canada
Posts: 251
Is that an SDL bug that can't be fixed except by updating SDL?
xboxown is offline  
Old 19 December 2017, 22:41   #115
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,121
Quote:
Originally Posted by xboxown View Post
Is that an SDL bug that can't be fixed except by updating SDL?
I have no clue.
I only replace libSDL by arti with the one build from github. so it's related to the SDL.
but there are some dependencies - lib- png jpeg z ssdl_image and some more, which may behave somehow differently with the 2 libSDL versions i try. :/

Last edited by emufan; 20 December 2017 at 02:19.
emufan is offline  
Old 20 December 2017, 02:19   #116
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,121
zoned: edgar-68k_v1.27-sdl_1.2.15.github-WIP.lha

this does work, I missed some flags of the SDL_INIT process. so it does now work with
sdl 1.2.15 from github. edgar/src/init.c:
Code:
////	flags = SDL_HWPALETTE|SDL_DOUBLEBUF|SDL_HWSURFACE;
		flags = SDL_DOUBLEBUF;
just these two *HW* flags made it non working :/
well, maybe we could use SW flags, not sure if it makes a diff, but colors/gfx are now ok

sound is not working, was there sound with the older aminet version of edgar?
I get a lot of "sound not found ..." in the console.

#1) all those missing soundfiles are ogg files, without extension.
when buidling it does link with -lSDL_mixer -lvorbisfile -lvorbis -logg -lmad ... so I guess ogg is supported.
but dunno exactly.

#2) I've change the DATA_PATh again, to make the edgar.pak working.
so it's possible you have to copy all the gfx/sound/music ... folders into the data folder.
makes the release maybe 500MB by now - I have no clue what it really needs/reads

so start from console and watch the error messages:
edgar.pak --> data/edgar.pak
gfx/ --> data/gfx/
and so on.

#3)
download again: I build a libSDL with AMMX support, but this gave some trouble.
updated archives includes *_AMMX binaries. just report if there is a speed/FPS difference to non-AMMX one.

Last edited by emufan; 20 December 2017 at 03:20.
emufan is offline  
Old 20 December 2017, 05:46   #117
xboxown
Registered User
 
Join Date: Dec 2012
Location: Vancouver/Canada
Posts: 251
SSweeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeet!!

It is literally doing 26.34 fps on the non-MMX version!!!

The ammx version have the same graphics glitch. Can you fix it?
xboxown is offline  
Old 20 December 2017, 15:05   #118
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,121
Quote:
Originally Posted by xboxown View Post
SSweeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeet!!

It is literally doing 26.34 fps on the non-MMX version!!!

The ammx version have the same graphics glitch. Can you fix it?
that`s not so bad. I will try to build a valid libSDL-ammx version

#0) not sure, the libSDL-AMMX does really work, makes use of the AMMX extension.
the binaries at least do work within winuae and do not crash.

#1) zone: edgar-68k_v1.27-sdl_1.2.15.AMMX-WIP.lha
the *_ammx version does now have playable gfx. just try and report FPS of both versions

#2) zone: dgen-68k-noFPU_AMMX-WIP.lha
added a AMMX build. not much hope of playable FPS, but maybe it does make a diff.
bottleneck is the emulation of the m68000 within dgen, we already have one, so this
is redundant, but out of my abilities to make it native.

Last edited by emufan; 20 December 2017 at 16:38.
emufan is offline  
Old 20 December 2017, 20:32   #119
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italia)
Posts: 2,276
Arrow

Ok emufan Edgar now it works well

How to change the language?


Last edited by AMIGASYSTEM; 22 December 2017 at 09:36.
AMIGASYSTEM is offline  
Old 20 December 2017, 20:47   #120
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,121
Quote:
Originally Posted by AMIGASYSTEM View Post
Ok emufan Edgar now it works well

How to change the language?
ok, good news
do you get any sound/music?


#1) try this: you need to create a folder and copy your language file into it:
makedir locale/LC_MESSAGES/
copy locale/it.mo locale/LC_MESSAGES/edgar.mo
emufan is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
porting an app written in C powrslave Coders. C/C++ 1 13 March 2017 05:44
Porting an Amiga game to PC CYBER_SLUNK Coders. General 4 31 January 2017 20:14
Porting Photoshop to Amiga KONEY Coders. General 25 30 December 2016 00:49
porting vlc ? turrican3 request.Apps 4 25 June 2011 22:27
Help porting Mindscape's Legend Queller request.Other 6 30 October 2010 13:07

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 00:01.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Page generated in 0.37725 seconds with 13 queries