English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 05 June 2017, 15:31   #1
idrougge
Registered User
 
Join Date: Sep 2007
Location: Stockholm
Posts: 3,929
Help flashing D-Link DWL-650 PCMCIA WLAN card

I just bought a D-Link DWL-650 PCMCIA wifi card. It is Prism 2-based, and works with prism2.device, but refuses to connect to WPA2 networks, which is to be expected.

Seeing as the connector is black instead of white, I have some hope that it can be updated to WPA2 support, but so far I have found few hints on the net. I have successfully updated both Netgear and Orinoco cards, but the D-Link looks like a tougher nut to crack.

Any hints?
idrougge is offline  
Old 30 June 2017, 21:34   #2
ncafferkey
Registered User

 
Join Date: Sep 2013
Location: Ireland
Posts: 35
The flashing procedure should be similar to the Netgear card. This page gives some details (it's referenced in the driver manual). Which tools did you use for the Netgear?

BTW, I'm curious about the Orinoco: they are Hermes chipset cards that do WPA by downloading firmware each time they're used, not by reflashing.
ncafferkey is offline  
Old 01 July 2017, 00:10   #3
idrougge
Registered User
 
Join Date: Sep 2007
Location: Stockholm
Posts: 3,929
About the Orinoco, I meant upgrading them from Silver to Gold.

For the Netgear, I think I used a version of the WinUpdate tool made for the MA401.
idrougge is offline  
Old 01 July 2017, 04:38   #4
ncafferkey
Registered User

 
Join Date: Sep 2013
Location: Ireland
Posts: 35
Ah, I see.

Which Windows driver are you using? From the page I linked: "Winupdate can be picky about the version of drivers installed. The driver for Linksys WPC11 v2.5 should OK." If it helps, I can check which driver I used for the cards I've flashed.
ncafferkey is offline  
Old 01 July 2017, 11:37   #5
idrougge
Registered User
 
Join Date: Sep 2007
Location: Stockholm
Posts: 3,929
Yeah, that would help. Getting hold of those drivers isn't as easy as when that page was first made.
idrougge is offline  
Old 01 July 2017, 13:20   #6
utri007
mä vaan
 
Join Date: Nov 2001
Location: Finland
Posts: 954
I tried that guide. I have D-Link DWL-520 wich is also a PRISM2 based card. I couldn't get correct driver installed to update card under Windows.

So I'm interested if you succeed.
utri007 is offline  
Old 03 July 2017, 04:33   #7
ncafferkey
Registered User

 
Join Date: Sep 2013
Location: Ireland
Posts: 35
I booted up the old PC that I've used in the past to reflash Prism cards. I had previously removed all Prism cards from the system, so it's a bit unclear which drivers I used. When I re-installed a Netgear MA311, the drivers available for selection included MA311 and MA301, but not the Linksys WPC11 or D-Link DWL-520 (which I also have). AFAICT I used the MA301 driver to flash my PCMCIA cards while inserting them into the MA301 bridge, and the MA311 driver to flash numerous MA311 PCI cards.

What specific problems did you guys encounter? Which versions of Windows and which drivers are you using? I thought the WinUpdate tool was generic: I'm not aware of versions specific to any manufacturer.

@utri007: do you mean you couldn't get the WPC11 driver installed?
ncafferkey is offline  
Old 04 July 2017, 19:23   #8
Nobby_UK
Registered User
Nobby_UK's Avatar
 
Join Date: Jul 2013
Location: Liverpool
Posts: 1,253
Grabs from my Flashing my D-Link DWL-650:

with help from 'Sir Lucas'
Attached Thumbnails
Click image for larger version

Name:	Image3.png
Views:	104
Size:	9.2 KB
ID:	53657   Click image for larger version

Name:	Image4.png
Views:	73
Size:	9.3 KB
ID:	53658  
Nobby_UK is offline  
Old 04 July 2017, 21:36   #9
Sir_Lucas
Registered User

Sir_Lucas's Avatar
 
Join Date: Dec 2008
Location: Norwich, UK
Posts: 648
@ncafferkey
Orinoco cards don't need any update, same as Thomson Speedtouch 110. They only work with WEP and WPA/TKIP. I'm pretty sure you know that
Linksys has got it's own versions of WinUpdate. However, the best one is the one from your link.

@Nobby_UK
Thanks for your kind words. As far as I remember it was nearly 3 years ago.
I hope the card still works all right.

@utri007
Just like Neil says, Linksys driver should be fine. The other option is to find correct drivers for your D-Link card, which worked in the case of Nobby_UK.
Sir_Lucas is offline  
Old 28 March 2020, 21:14   #10
mrfrank
Registered User

 
Join Date: Mar 2020
Location: Uxbridge
Posts: 1
Hi, I have seen this thread and I am trying to understand if there are any hw versions of the Dlink DWL-650 pcmcia wlan card that may not work with an amiga 1200.
Also, I cannot find a clear forum or source explaining where to find the firmware to enable wpa2 for this card and if there is any hw limitation on certain versions of this card. I found one on ebay which shows V.P1 after the serial number from the photos.

Anybody that may shed some light?
@Sir_Lucas


Thx.

Last edited by mrfrank; 28 March 2020 at 21:31. Reason: Tagging somebody
mrfrank is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help needed with PCMCIA WLAN card KONEY support.Hardware 23 26 April 2017 08:05
A600: CF in IDE, SRAM card in PCMCIA... how to add a 'to PC transfer card'? Photon support.Hardware 9 15 January 2011 18:17
AmiTCP 3.0b2 + D-Link PCMCIA Problems! D4Ni3L3 support.Other 3 08 November 2008 13:03
Hey, another little BBS (650 Mb) jaxx21 Nostalgia & memories 12 27 March 2008 17:24
PCMCIA Squirrel + PCMCIA Network Card tootoid support.Hardware 1 18 April 2007 12:13

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 02:55.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.07390 seconds with 16 queries