English Amiga Board


Go Back   English Amiga Board > Support > support.FS-UAE

 
 
Thread Tools
Old 22 June 2013, 17:54   #1
discomike
 
Posts: n/a
Controller list isn't initialized in FS-UAE Launcher (Windows)

Hello

When I start FS-UAE.exe directly it finds my wireless 360 controller. When I use the launcher, the controller is not in the list of joystick options.

From the launcher log file I see this snippet which appears rellavent.

Code:
finding connected joysticks
FSUAE.start_with_args: [u'--list-joysticks']
current dir (cwd):  C:\Users\Mike\AppData\Local\FS-UAE\launcher
using fs-uae executable: ../FS-UAE
[u'../FS-UAE.exe', u'--list-joysticks']
exception while listing joysticks
Traceback (most recent call last):
  File "fs_uae_launcher\DeviceManager.pyc", line 100, in init_fsuae
  File "fs_uae_launcher\FSUAE.pyc", line 38, in start_with_args
  File "subprocess.pyc", line 672, in __init__
  File "subprocess.pyc", line 787, in _get_handles
  File "subprocess.pyc", line 826, in _make_inheritable
WindowsError: [Error 6] The handle is invalid
I thought this may be of interest. Fingers crossed the launcher works with my controller soon.
 
Old 22 June 2013, 20:31   #2
FrodeSolheim
FS-UAE Developer

FrodeSolheim's Avatar
 
Join Date: Dec 2011
Location: Førde, Norway
Age: 39
Posts: 3,634
Hi discomike, yes, that is indeed the relevant bit. It is not possible to say exactly what's the problem though, since it is not certain what (file) handle causes the problem when starting FS-UAE. It could still be useful to see your entire log (if for no other reason, it will as least document the version you use).

I'm sure we'll make it work. An interesting question for now is why does it work for other people, but not for you. Do you run FS-UAE Launcher in a "non-standard way" somehow? From the console, or something else?

I'll move these posts out into a separate thread btw, so make sure to subscribe to that new thread to get notifications on this issue
FrodeSolheim is offline  
Old 24 June 2013, 21:42   #3
discomike
 
Posts: n/a
Looks like you're on to something.

From the console, it exhibts the above behaviour. but when running from the start menu, it seems to work fine. So from now on i'll just start it from the start menu.

I've atached complete logs for both scenarios just incase it provides any insight.

Thanks for your suggestion.
Attached Files
File Type: txt Launcher.log.console.txt (8.9 KB, 100 views)
File Type: txt Launcher.log.start_menu.txt (9.1 KB, 104 views)
 
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS-UAE Launcher FrodeSolheim support.FS-UAE 414 20 September 2015 22:39
FS-UAE Launcher crashes while scanning for files Dic_Ray support.FS-UAE 16 04 February 2014 00:59
FS-UAE Launcher portable? toprak support.FS-UAE 5 11 December 2012 18:17
[FS-UAE] Amiga Game Database for FS-UAE Launcher nexusle support.FS-UAE 31 24 August 2012 21:24
UAE launcher for game or demo Frazor support.WinUAE 4 28 March 2003 17:04

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 14:55.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.06131 seconds with 14 queries