English Amiga Board


Go Back   English Amiga Board > Coders > Coders. Language > Coders. C/C++

 
 
Thread Tools
Old 08 April 2020, 02:55   #1
Pharaun Mizzrym
Registered User

 
Join Date: Mar 2020
Location: Ontario, Canada
Posts: 2
Trying to get ACE showcase examples to work

I have been able to compile Bebbo's amiga-gcc (https://github.com/bebbo/amiga-gcc) with Cygwin, then compiled ACE (https://github.com/AmigaPorts/ACE) and finally was going through the ACE tutorials.


But when I try to run the Viewports example, all I get is a grey screen and I am unable to ESC out of the program.


My OS is Windows 10 and I am running the examples in WinUAE v4.3.0, with a 020 CPU, 24-bit addressing, No FPU, Full ECS, NTSC, KS 3.1, 1MB Chip, 1MB Slow, 2MB Z2 Fast.


The game.log stop just after the view is loaded and does not run the game loop.


Has anybody use ACE and encountered this issue? Is there some info on how to setup debugging using WinUAE?


Any .. pointers.. are appreciated!


Thanks,


Bryan
Pharaun Mizzrym is offline  
Old 08 April 2020, 03:04   #2
Samurai_Crow
Total Chaos forever!

Samurai_Crow's Avatar
 
Join Date: Aug 2007
Location: Ft. Collins, CO USA
Age: 45
Posts: 1,418
Send a message via Yahoo to Samurai_Crow
It bangs hardware so check PAL mode if your monitor supports it. The author is Polish, I think, so American scan rates may not be implemented yet.

Last edited by Samurai_Crow; 08 April 2020 at 05:04.
Samurai_Crow is offline  
Old 08 April 2020, 08:51   #3
KaiN
Registered User

 
Join Date: Sep 2018
Location: Poland
Posts: 10
Hi, I'm an ACE author.

Yeah, now I checked and I see that's a NTSC problem. I'll try to work around it. In the meantime you'll have to switch to PAL or try to hack a solution for yourself.

On the side note, I rarely read these forums and I've looked here so quickly because a little bird told me you have a problem here. So if you want quick replies, don't hesitate to create an issue on project page - no matter how trivial/silly/whatever the matter is. It's just better for me as a project maintainer to respond to ppl in one place. I've created one for you: https://github.com/AmigaPorts/ACE/issues/112
KaiN is offline  
Old 08 April 2020, 16:48   #4
Pharaun Mizzrym
Registered User

 
Join Date: Mar 2020
Location: Ontario, Canada
Posts: 2
Thank-you Samurai_Crow and KaiN for your replies!


I changed my WinUAE to PAL and was able to run both the showcase and viewport tutorial examples!



I have also subscribed to the thread you created on ACE's github page KaiN and will make sure to create new issues about ACE on your project page.
Pharaun Mizzrym is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
How To Get Games To Work In ACE (Atari 800 Emulator) CU_AMiGA support.Apps 5 18 January 2018 06:36
Games and examples with source available TurboCrash Coders. Blitz Basic 3 06 January 2016 17:50
Best Game You'd Show Your Friend If you Could Only Chose One To Showcase an Amiga! Ultron Retrogaming General Discussion 26 11 June 2013 18:18
Boot block examples? h0ffman Coders. General 3 04 March 2011 16:44
Plasma examples anyone? jobro Coders. General 5 27 November 2005 17:25

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 11:21.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.06517 seconds with 15 queries