English Amiga Board


Go Back   English Amiga Board > Support > support.OtherUAE

 
 
Thread Tools
Old 06 January 2009, 16:34   #1
netsurge
Registered User
 
Join Date: Feb 2008
Location: Toronto
Posts: 10
kx light and telnet

Just wondering if anyone else has run into this before. I have installed the latest kx light on a computer and moved my BBS over to it running OS 3.1. When the telnetd.device loads and the BBS tries to use it as a modem i get a "Couldn't bind name to initial socket (13)" error.

This works in WinUAE without a problem. I have tried to comb the root installation of kx light to see if I can open up port 23 and bind it to e-uae, but without inetd installed and running I can't figure out how to.

Thanks.
netsurge is offline  
Old 06 January 2009, 18:28   #2
hit
Registered User
 
Join Date: Jun 2008
Location: planet earth
Posts: 1,115
i've of no real help i guess, since i never used kxlight - just found out, its amigaforever related

well, the message usually means, another instance is already using the resource, in this case port23. kxlight seems knoppix based, so i guess there is a xinetd (/etc/xinetd.d/). perhaps the system starts up some service at port 23 by default, kind of remote administration or the like, so e-uae isnt able to bind to the port/socket.
can you change the telnet port from within the amiga emulation?
or there is a way to have a open console on the linux system, so you can look for some services. 'netstat -tulpen' will list those listening daemons.

just some ideas, maybe its somewhat helpful.
hit is offline  
Old 06 January 2009, 23:43   #3
netsurge
Registered User
 
Join Date: Feb 2008
Location: Toronto
Posts: 10
I have run through netstat and there is nothing binding to that port, actually kx light is knoppix based but is an incredibly stripped down version, there is nothing really installed. No Inetd or XNetd either.
netsurge is offline  
Old 06 January 2009, 23:57   #4
hit
Registered User
 
Join Date: Jun 2008
Location: planet earth
Posts: 1,115
hmm. too bad. does the error message comes from the amiga application?
i've no clue at the moment.
hit is offline  
Old 07 January 2009, 00:30   #5
netsurge
Registered User
 
Join Date: Feb 2008
Location: Toronto
Posts: 10
Yes, the error comes from telnetd.device
netsurge is offline  
Old 09 January 2009, 03:49   #6
netsurge
Registered User
 
Join Date: Feb 2008
Location: Toronto
Posts: 10
I figured it out. All i had to do was set the setuid bit on the e-uae executable so that it was able to bind to the lower ports.

kx light is very limited. No sshd, no nothing. I ended up remastering the distro and adding things like a light web server (nginx), and sshd, and an ftpd.

My system is now up and running smoothly in e-uae. Anyone who is interested can fire up a telnet client and head on over to miserybbs.com.

Over the next few weeks i'll be getting the http done and mirroring all of the files I have on the ftp server.
netsurge is offline  
Old 09 January 2009, 23:38   #7
hit
Registered User
 
Join Date: Jun 2008
Location: planet earth
Posts: 1,115
ui, permission issue. good to hear its working now. maybe i'll take a look later. thanks for reporting the solution
hit is offline  
Old 17 January 2009, 01:54   #8
netsurge
Registered User
 
Join Date: Feb 2008
Location: Toronto
Posts: 10
Quote:
Originally Posted by hit View Post
ui, permission issue. good to hear its working now. maybe i'll take a look later. thanks for reporting the solution
Ya. I ended up remastering the kx light distro which is knoppix based. The system comes bare bones. No ftp, no ssh, cron, not even alternate time zone files.

I ended up remasting koppix and only installed what I wanted like nginx (a light weight http server), ftpd, cron, ssh, and the timezone file I needed. Other than that it's still quite bare bones, but runs very stable.
netsurge is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Troubleshooting /X BBS with Telnet illy5603 support.Apps 5 22 September 2011 23:40
Telnet with Winuae Mangar support.WinUAE 8 20 January 2010 18:30
CLI Telnet server gmiaow support.Apps 6 23 October 2008 14:27
Amiga CNET BBS on E-UAE /Telnet Rashivanto support.OtherUAE 4 11 July 2008 18:28
Active Telnet BBSes? DaZZaBoY Nostalgia & memories 11 05 March 2006 18:00

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 02:46.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.06496 seconds with 13 queries