English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 06 November 2018, 17:49   #81
HanSolo
Registered User

 
Join Date: Aug 2014
Location: Gdynia/Poland
Posts: 162
WinaUAE 64 beta 9 contain virus according to windows defender . Is it a false alarm ?
HanSolo is offline  
Old 06 November 2018, 17:54   #82
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,129
Yes, it happens every few betas.
Toni Wilen is online now  
Old 08 November 2018, 09:26   #83
Rotareneg
Registered User

 
Join Date: Sep 2017
Location: Kansas, USA
Posts: 64
In beta 8 and 9, sprite 0 is missing after loading a save state. Quick and easy demo is to load Workbench with the A500 quickstart config, and then then quicksave with shift-end-numpad1 and load with end-numpad1. The mouse cursor will be missing after the save state load.

I also tested it with Leander and the player sprite would disappear but other sprites remained. It's not just a visual glitch, the invisible player no longer interacts with hostile sprites (they can't hurt the player and the player can't hurt them: no sprite collision happening.)
Rotareneg is offline  
Old 08 November 2018, 18:25   #84
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,129
Quote:
Originally Posted by Rotareneg View Post
In beta 8 and 9, sprite 0 is missing after loading a save state. Quick and easy demo is to load Workbench with the A500 quickstart config, and then then quicksave with shift-end-numpad1 and load with end-numpad1. The mouse cursor will be missing after the save state load.

I also tested it with Leander and the player sprite would disappear but other sprites remained. It's not just a visual glitch, the invisible player no longer interacts with hostile sprites (they can't hurt the player and the player can't hurt them: no sprite collision happening.)
For some reason I didn't notice this previously (I usually always test few old statefiles to confirm nothing gets too badly broken)

Should be fixed now.
Toni Wilen is online now  
Old 17 November 2018, 18:15   #85
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,129
http://www.winuae.net/files/b/winuae_4100b10.7z
http://www.winuae.net/files/b/winuae64_4100b10.7z

It looks like nothing major has not been found recently so official release will be in 1-3 weeks.

Beta 10:

- Fixed invisible sprites after statefile load (at least when not in AGA mode). (b8).
- Reading CIA interrupt register exactly when CIA interrupt is going to activate may have caused stuck PORTS interrupt until CIAxICR was read again, which would also return unexpectedly no interrupts active in this situation.
- 68020+ more compatible state files didn't restore CPU mid-instruction properly, caused restore Amiga side crash if state was created during mid-instruction that has side-effects (like -(an) or (an)+ addressing mode) (introduced in 4.0 betas)
- 64-bit version didn't support rar unpacking without archiveaccess.dll, probably because 64-bit unrar.dll didn't exist when it was implemented.
- Window corners are now drag'n'drop hot spots for different floppy drives. (top/left=0, top/right=1, bottom/left=2, bottom/right=3).
- 68030 MMU MOVEM <ea>,<regs> access fault retry was unreliable in some situations.
Toni Wilen is online now  
Old 18 November 2018, 12:04   #86
Mclane
Old fart!

Mclane's Avatar
 
Join Date: Apr 2002
Location: Northolt, West London
Age: 57
Posts: 577
Love the drag n drop hot spots..Thank you Toni...
Mclane is offline  
Old 24 November 2018, 21:00   #87
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,129
http://www.winuae.net/files/b/winuae_4100b11.7z
http://www.winuae.net/files/b/winuae64_4100b11.7z

Beta 11: (Hopefully final 68030 MMU updates, 1-2 weeks to go)

- Debugger assembler didn't assemble Scc and TRAPcc. CLR didn't show memory contents if EA was not register.
- Debugger disassembler does not create useless output anymore when disassembling 68020+ addressing modes. If CPU is <68020 but full extension bit is set: disassemble as 68000 but append "(68020+)" to output.
- SPTI mode CD read buffer overflow fix. (Probably only when playing CD audio)
- 68030 MMU + more compatible bus error handling was very broken. (MMU updates in previous betas broke it)
- 68030 MMU bus error exception/unaligned access emulation partial rewrite. Odd long access uses byte+word+byte access sequence (not 4xbyte). MOVEM and normal data accesses use same data buffer variable now, confusing special cases removed. Unaligned accesses that cross MMU page boundary retries are now compatible with new retry logic (b8).
- 68030 MMU + prefetch mode fix when prefetch crossed MMU pages and neither page was mapped as valid. (Amix illegal instruction error in early boot)
- 68030 MMU + prefetch + data cache mode fixed. (also broke in b8)
Toni Wilen is online now  
Old 26 November 2018, 20:35   #88
White
Registered User
 
Join Date: Sep 2016
Location: italy
Posts: 401
Hi Toni, sorry
I tried to install the 3.9 + b & b 1-2 +PPC
and also the 3.9 + b & b 1-2-3-4 +PPC
to use shogoMAD with picasso IV
but the colors are distorted, this is not important to me

But I got a video crash with windows 7 64bit
winuae is back at the desktop with half the screen after the crash
I use a 750Ti GTX video card with the latest nvidia 416.94 drivers
this same problem happened on other days with other driver versions

I leave the logs and the config file if it can be useful
thanks as always for your work
Attached Files
File Type: dmp winuae_x64_4.1.0_b11_2018.11.26_18.53.44.dmp (248.5 KB, 17 views)
File Type: dmp winuae_x64_4.1.0_b11_2018.11.26_18.58.06.dmp (249.1 KB, 17 views)
File Type: uae WARP-3.9+PPC3.uae (12.0 KB, 16 views)
White is offline  
Old 26 November 2018, 20:38   #89
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,129
Required info missing: does it also happen with previous official version? (It probably does..)

EDIT: does it stop happening if you untick multithread RTG?
Toni Wilen is online now  
Old 26 November 2018, 20:57   #90
White
Registered User
 
Join Date: Sep 2016
Location: italy
Posts: 401
The crash seems sporadic and random with the latest official version and also the beta
also deselecting the RTG multithread
In some cases windows 7 64bit tends to slow down a lot
White is offline  
Old 01 December 2018, 23:39   #91
thomas
Registered User
thomas's Avatar
 
Join Date: Jan 2002
Location: Germany
Posts: 5,739
Quote:
Originally Posted by Toni Wilen View Post
Beta 2:

- If config had KS ROM path/file that didn't exist, path was replaced with useless <original path>../system/rom/kick.rom path.

Does not work. It still shows F:\UAEHD\WinUAE\../System/rom/kick.rom after loading config.
thomas is offline  
Old 02 December 2018, 09:22   #92
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,129
Works for me (path does not change) which wins "does not work" reports.

EDIT: Previously config path variable was also used as temporary variable which left last (failed) rom file open attempt path in config variable, now it is only copied when file opens so this can't happen anymore. Unless there is some other situation somewhere else. Are you sure the path isn't actually valid?

Last edited by Toni Wilen; 02 December 2018 at 09:35.
Toni Wilen is online now  
Old 02 December 2018, 11:50   #93
thomas
Registered User
thomas's Avatar
 
Join Date: Jan 2002
Location: Germany
Posts: 5,739
Quote:
Originally Posted by Toni Wilen View Post
Are you sure the path isn't actually valid?
Yes, I am.

Does it make a difference if config file is from a very old WinUAE version? (see attachment)
Or if the config file is in a sub-directory of WinUAE\Configurations?
Or if WinUAE finds a ROM file with the same name in a new location (see winuaebootlog.txt attached)
Note: although the log says it found another file with the same name (which is indeed the file it should use), it still complains that it cannot load system ROM and uses the ROM replacement.
Attached Files
File Type: uae OS39XL.UAE (18.2 KB, 14 views)
File Type: txt winuaebootlog.txt (18.0 KB, 12 views)
thomas is offline  
Old 02 December 2018, 13:05   #94
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,129
I get "..\ROMs\kick.a1200.46" (which does not exist). Do you have default.uae and if you do, does anything change if you temporarily remove it?
Toni Wilen is online now  
Old 02 December 2018, 13:36   #95
thomas
Registered User
thomas's Avatar
 
Join Date: Jan 2002
Location: Germany
Posts: 5,739
No, no default.uae

I had winuae.ini. Deleted it and created a new one. Now I get .\../System/rom/kick.rom


Edit: I made a new empty directory on the desktop with only the files needed:

Configurations\Install\os39xl.uae
Roms\kick31_a4000.rom
winuae.ini
winuae64.exe

When I run it the first time with an empty winuae.ini I get .\../System/rom/kick.rom.
When I run winuae again, I get C:\Users\Thomas\Desktop\WinUAE\../System/rom/kick.rom.

Last edited by thomas; 02 December 2018 at 13:45.
thomas is offline  
Old 02 December 2018, 14:25   #96
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,129
Last ROM file name "guess" didn't set ROM path. ("ROM <path1> not found, using <path2>")

winuae.7z should fix it.
Toni Wilen is online now  
Old 02 December 2018, 15:29   #97
thomas
Registered User
thomas's Avatar
 
Join Date: Jan 2002
Location: Germany
Posts: 5,739
Quote:
Originally Posted by Toni Wilen View Post
winuae.7z should fix it.
Confirmed. If it recognises the file name, it uses the same ROM in its new location. If it does not find the file at all, it shows the path from the configuration. Perfect.
thomas is offline  
Old 02 December 2018, 18:38   #98
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,129
http://www.winuae.net/files/b/winuae_4100b12.7z
http://www.winuae.net/files/b/winuae64_4100b12.7z

Beta 12: (final date: next week)

- If tablet.library was ticked and config was loaded to system without tablet, it was not possible to untick it.
- If original path stored in statefile is not valid anymore, fix attempts (testing if it exists in current dir etc..) may have returned non-existing path in certain situations even if valid path was available.
- More 68030 MMU bus error retry fixes. (Remaining Previous NextOS crashes fixed)
- MMU's internal table read/write accesses should be always done in supervisor mode. (Not much effect on Amiga but other platforms usually have memory regions that are supervisor only)
- Magic mouse Windows cursor to Amiga mouse sync fixed. (Broken long time ago, still not fully working in every filter combination)
- When config file rom path pointed to non-existing file, autodetect of rom path is attempted. If last autodetect phase detected it, rom path was not updated.
Toni Wilen is online now  
Old 02 December 2018, 21:15   #99
ross
Sum, ergo Cogito

ross's Avatar
 
Join Date: Mar 2017
Location: Crossing the Rubicon
Age: 48
Posts: 1,367
Beta12:
Direct3D11 failed to initialize, falling back to Direct3D9.
Direct3D9 failed to initialize, falling back to DirectDraw.


Every config.
No problem before.
ross is online now  
Old 02 December 2018, 21:32   #100
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,129
Quote:
Originally Posted by ross View Post
Beta12:
Direct3D11 failed to initialize, falling back to Direct3D9.
Direct3D9 failed to initialize, falling back to DirectDraw.


Every config.
No problem before.
There is nothing graphics related in b12. Did you test b11? Did you reboot?
Toni Wilen is online now  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
WinUAE 3.6.1 beta series Toni Wilen support.WinUAE 166 07 March 2018 23:48
WinUAE 3.5.0 beta series (was 3.4.1) Toni Wilen support.WinUAE 177 15 June 2017 00:31
WinUAE 3.0.0 beta series (was 2.8.2/2.9.0) Toni Wilen support.WinUAE 1012 15 December 2014 14:41
WinUAE 2.7.0 beta series Toni Wilen support.WinUAE 326 04 December 2013 00:37
WinUAE 2.6.0 beta series Toni Wilen support.WinUAE 271 14 May 2013 17:51

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 18:10.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.09300 seconds with 14 queries