English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 25 June 2014, 22:43   #61
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,120
Quote:
Pandemonium (Demo) by Sepultura
(Forgot to report this earlier today). A1200 confirmed, possibly it is missing some data because it accesses disk drive (even if there is no disk in drive and main exe was loaded from HD!) before starfield appears.
Toni Wilen is online now  
Old 26 June 2014, 00:00   #62
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,130
64k Intro (64k Intro) by Technology -> http://janeway.exotica.org.uk/release.php?id=4555 (A1200 basic)(pics 1 & 2)

Herb! (64k Intro) by Polka Brothers -> http://janeway.exotica.org.uk/release.php?id=10875 (A1200 basic)(pics 3 & 4) ... after pic3 quick glitche happens pic4!

Intro (64k Intro) by University Of Drinking -> http://janeway.exotica.org.uk/release.php?id=20946 (A1200 basic)(pic.5) ... some glitches !

Opal Se Futec (64k Intro) by Exile -> http://janeway.exotica.org.uk/release.php?id=10636 (A1200 basic)(pic.6) ... when it starts, after a while, screen is shifted !?

Raggy (64k Intro) by Eltech -> http://janeway.exotica.org.uk/release.php?id=3493 (A1200 basic)(pic.7) ... cube mesh part issue ! (CPU timing -> if CE=OFF its OK)

S(pi)d (64k Intro) by Zomo -> http://janeway.exotica.org.uk/release.php?id=15770 (A1200 basic)(pic.8) ... CPU timing -> if CE=OFF its OK
Attached Thumbnails
Click image for larger version

Name:	TECHNOLOGY-64kIntro_001.png
Views:	156
Size:	15.4 KB
ID:	40360   Click image for larger version

Name:	TECHNOLOGY-64kIntro_002.png
Views:	148
Size:	11.2 KB
ID:	40361   Click image for larger version

Name:	PB-Herb!_001.png
Views:	160
Size:	4.0 KB
ID:	40362   Click image for larger version

Name:	PB-Herb!_002.png
Views:	148
Size:	15.4 KB
ID:	40363   Click image for larger version

Name:	UoD-First_001.png
Views:	176
Size:	4.7 KB
ID:	40364  

Click image for larger version

Name:	EXILE-opalSefutec_001.png
Views:	174
Size:	4.3 KB
ID:	40365   Click image for larger version

Name:	ELTECH-Raggy_002.png
Views:	144
Size:	5.5 KB
ID:	40367   Click image for larger version

Name:	ZOMO-Speed_001.png
Views:	149
Size:	19.8 KB
ID:	40368  

Last edited by amilo3438; 26 June 2014 at 02:06.
amilo3438 is offline  
Old 26 June 2014, 14:53   #63
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,130
The End Of Ashes (64k Intro) by Technology -> http://janeway.exotica.org.uk/release.php?id=10816 (A1200 basic)(pic.1) ... some glitches on credit screen !

Beut (64k Intro) by Phase Truce -> http://janeway.exotica.org.uk/release.php?id=18554 (A1200 basic)(pic.2) ... it stops at pic2 ?!

9 (Demo) by Spoon -> http://janeway.exotica.org.uk/release.php?id=11026 (A1200 +4Mb)(pic.3) ... JFI, glitches on left screen part ?!

Aerial (Demo) by Mankind -> http://janeway.exotica.org.uk/release.php?id=10864 (A1200 basic)(pic.4 & 5) ... some glitches !
Attached Thumbnails
Click image for larger version

Name:	Technology-Ashes_001.png
Views:	137
Size:	7.7 KB
ID:	40382   Click image for larger version

Name:	grv-beut_001.png
Views:	137
Size:	5.4 KB
ID:	40383   Click image for larger version

Name:	SPOON-9_002.png
Views:	141
Size:	10.1 KB
ID:	40386   Click image for larger version

Name:	MANKIND-Aerial_001.png
Views:	184
Size:	15.0 KB
ID:	40387   Click image for larger version

Name:	MANKIND-Aerial_002.png
Views:	147
Size:	16.1 KB
ID:	40388  


Last edited by amilo3438; 26 June 2014 at 16:46.
amilo3438 is offline  
Old 26 June 2014, 16:59   #64
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,130
Alien (Demo) by Scoopex -> http://janeway.exotica.org.uk/release.php?id=10853 (A1200 basic)(pic.1, 2 ,3) ... glitches start from yesterdays test WinUAE2820b0 version !
Attached Thumbnails
Click image for larger version

Name:	SCOOPEX-Alien_001.png
Views:	177
Size:	12.9 KB
ID:	40389   Click image for larger version

Name:	SCOOPEX-Alien_003.png
Views:	163
Size:	17.8 KB
ID:	40390   Click image for larger version

Name:	SCOOPEX-Alien_004.png
Views:	142
Size:	10.4 KB
ID:	40391  
amilo3438 is offline  
Old 26 June 2014, 18:18   #65
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,120
Quote:
Originally Posted by amilo3438 View Post
64k Intro (64k Intro) by Technology -> http://janeway.exotica.org.uk/release.php?id=4555 (A1200 basic)(pics 1 & 2)
Both A1200 confirmed (random pause does happen)

Quote:
Herb! (64k Intro) by Polka Brothers -> http://janeway.exotica.org.uk/release.php?id=10875 (A1200 basic)(pics 3 & 4) ... after pic3 quick glitche happens pic4!
A1200 confirmed.

Quote:
Intro (64k Intro) by University Of Drinking -> http://janeway.exotica.org.uk/release.php?id=20946 (A1200 basic)(pic.5) ... some glitches !
100% A1200 confirmed.

Quote:
Opal Se Futec (64k Intro) by Exile -> http://janeway.exotica.org.uk/release.php?id=10636 (A1200 basic)(pic.6) ... when it starts, after a while, screen is shifted !?
A1200 confirmed. Most likely that effect only works correctly with original bootable disk version.

Quote:
Raggy (64k Intro) by Eltech -> http://janeway.exotica.org.uk/release.php?id=3493 (A1200 basic)(pic.7) ... cube mesh part issue ! (CPU timing -> if CE=OFF its OK)
Interestingly it has very similar glitch (but not identical due to CPU speed differences) with real A1200 too. Probably designed for fast ram or 68030 based systems.

Quote:
S(pi)d (64k Intro) by Zomo -> http://janeway.exotica.org.uk/release.php?id=15770 (A1200 basic)(pic.8) ... CPU timing -> if CE=OFF its OK
Finally something that does not have any glitches on real A1200...

Quote:
Alien (Demo) by Scoopex
works again.
Toni Wilen is online now  
Old 26 June 2014, 19:15   #66
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,120
Quote:
Originally Posted by amilo3438 View Post
The End Of Ashes (64k Intro) by Technology -> http://janeway.exotica.org.uk/release.php?id=10816 (A1200 basic)(pic.1) ... some glitches on credit screen !
A1200 confirmed.

Quote:
Beut (64k Intro) by Phase Truce -> http://janeway.exotica.org.uk/release.php?id=18554 (A1200 basic)(pic.2) ... it stops at pic2 ?!
Does some self-modifying code, assumes more correct cycle fetch sequences or something like that.

Quote:
9 (Demo) by Spoon -> http://janeway.exotica.org.uk/release.php?id=11026 (A1200 +4Mb)(pic.3) ... JFI, glitches on left screen part ?!
Skipped but probably normal.

Quote:
Aerial (Demo) by Mankind -> http://janeway.exotica.org.uk/release.php?id=10864 (A1200 basic)(pic.4 & 5) ... some glitches !
A1200 confirmed.
Toni Wilen is online now  
Old 26 June 2014, 19:29   #67
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,130
Amazed (Demo) by Vanity -> http://janeway.exotica.org.uk/release.php?id=10874 (A1200 basic) ... HALT1 after a while !? (archive attached as HD and start with amaze.exe)
amilo3438 is offline  
Old 26 June 2014, 21:08   #68
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,120
Quote:
Originally Posted by amilo3438 View Post
Amazed (Demo) by Vanity -> http://janeway.exotica.org.uk/release.php?id=10874 (A1200 basic) ... HALT1 after a while !? (archive attached as HD and start with amaze.exe)
A1200 confirmed. It crashes because it does blit to address zero (uninitialized variable), probably demo bug (as said in readme.txt too) and probably also works when WB environment is just right.
Toni Wilen is online now  
Old 26 June 2014, 21:20   #69
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,120
Quote:
Originally Posted by Toni Wilen View Post
Uses some strange programmed display mode that is sort of PAL compatible but also sets BEAMCON0 bits that no one has set previously ("DUAL" bit which apparently does something strange).
Some more information. "DUAL" bit actually does nothing. But there is something unexplained because HBSTRT/HBSTOP bits seem to do nothing. I set exact same programmed mode values as this demo on my real A1200. (Indy AGA MK1 -> LCD and 8833II via composite out), left or right border never blanked, not even partially and I tried lots of HBSTRT/HBSTOP values..

Vertical blanking values work as expected. (and they only work if VARVBEN bit is set). Nothing seems to enable horizontal blanking. I tried all BEAMCON0 bits, nothing happened with horizontal blanking.

Horizontal and vertical sync values also work as expected too.

Demo sets quite large value to HBSTOP ($80) and it still shows complete horizontal screen which confirms that HBSTRT/HBSTOP are ignored which can't be right because it would not work very well with programmed display mode monitor drivers or Linux AGA console/X-Window screens..

Something must be missing..
Toni Wilen is online now  
Old 26 June 2014, 21:24   #70
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,130
Quote:
Originally Posted by Toni Wilen View Post
Interestingly it has very similar glitch (but not identical due to CPU speed differences) with real A1200 too. Probably designed for fast ram or 68030 based systems.
Raggy (64k Intro) by Eltech (cube mesh part issue !)

With A1200 +4MB it is same problem, but if freq. is set to f.e. 8x then it works fine.

Also interestingly, on rotation part if CPU68020=pic.1 but if CPU68030=pic.2 !? (p.s. also if CPU68040=pic2!)
Attached Thumbnails
Click image for larger version

Name:	ELTECH-Raggy_003.png
Views:	166
Size:	28.1 KB
ID:	40392   Click image for larger version

Name:	ELTECH-Raggy_004.png
Views:	151
Size:	16.6 KB
ID:	40393  

Last edited by amilo3438; 26 June 2014 at 21:51.
amilo3438 is offline  
Old 26 June 2014, 22:01   #71
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,130
Quote:
Originally Posted by Toni Wilen View Post
Does some self-modifying code, assumes more correct cycle fetch sequences or something like that.
Beut (64k Intro) by Phase Truce (it stops at pic2)

Interestingly, it works on WinUAE2010 (now will try to found a version where it starts be broken)

EDIT: WinUAE2200 (2010-06-28) last version where still works -> broken from WinUAE2300 (2010-09-24) !!!

Last edited by amilo3438; 26 June 2014 at 23:25.
amilo3438 is offline  
Old 27 June 2014, 13:16   #72
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,130
Blue (Demo) by The Interceptors -> http://janeway.exotica.org.uk/release.php?id=16265 (A1200 basic)(pic.1) ... strange graphics ! (on the link it looks different!)

Contactro (Demo) by Illusion (new) -> http://janeway.exotica.org.uk/release.php?id=10951 (A1200 basic)(pic.2) ... white dots appear and screen seems a bit squeezed if compared to one on link !?

Cosmic Glide (Demo) by C-lous -> http://janeway.exotica.org.uk/release.php?id=4057 (A1200 basic)(pic.3) ... (if CE=OFF or 4Mb it doesnt happen !?)

Cybernetic (Demo) by The Black Lotus -> http://janeway.exotica.org.uk/release.php?id=10786 (A1200 basic)(pic.4) ... pic4 differs from one on the link !? (sorry, it is last part of demo)(how to run; attach file as HD and type: "CD cybernetic" and "cybernetic.exe") -> if is started from WB environment its Ok pic.5!
Attached Thumbnails
Click image for larger version

Name:	TheInt-Blue_001.png
Views:	144
Size:	17.1 KB
ID:	40396   Click image for larger version

Name:	ILLUSION-CONTACTRO_001.png
Views:	141
Size:	9.9 KB
ID:	40397   Click image for larger version

Name:	C_LOUS-Cosmicglide_001.png
Views:	138
Size:	23.4 KB
ID:	40398   Click image for larger version

Name:	TBL-Cybernetic.png
Views:	130
Size:	14.9 KB
ID:	40399   Click image for larger version

Name:	003.png
Views:	162
Size:	20.8 KB
ID:	40400  


Last edited by amilo3438; 27 June 2014 at 16:48.
amilo3438 is offline  
Old 27 June 2014, 21:41   #73
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,120
Quote:
Contactro (Demo) by Illusion (new)
Quote:
Jtxrules (Intro) by Illusion (new)
Weird programmed mode used by both demos work now. (Note that display isn't centered, CRT display confirmed)

Missing piece was programmable horizontal blanking register enable bit which is BPLCON3 bit 0 (EXTBLKEN). Both demos set bogus hblank values but enable bit is not set.
Toni Wilen is online now  
Old 28 June 2014, 00:03   #74
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,130
Quote:
Originally Posted by Toni Wilen View Post
Weird programmed mode used by both demos work now. (Note that display isn't centered, CRT display confirmed)

Missing piece was programmable horizontal blanking register enable bit which is BPLCON3 bit 0 (EXTBLKEN). Both demos set bogus hblank values but enable bit is not set.
Very nice. (yes, but also in emu display can be centered with centering horizontal=ON )
amilo3438 is offline  
Old 28 June 2014, 00:28   #75
Snake79
Registered User

 
Join Date: Feb 2014
Location: Poland
Posts: 181
It's AGA Demos thread so... check this out: http://www.pouet.net/prod.php?which=62977 Not with a problem to report, but... The Black Lotus is back after 8 years with new Demo (released at Revision 2014) and Demo is working fine! with QS A4000 and Motherboard Fast at max DL: https://www.scene.org/file.php?file=...l.zip&fileinfo Keep up a good work!
Snake79 is offline  
Old 28 June 2014, 00:47   #76
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,130
@Snake79

One note: It is not an AGA Demos thread ... than it is opened for reporting AGA Demo problems only !

Yes, I know for this demo ... already tested it a few weeks ago.

p.s.
Also, thanks on good wishes.
amilo3438 is offline  
Old 28 June 2014, 00:52   #77
Snake79
Registered User

 
Join Date: Feb 2014
Location: Poland
Posts: 181
Quote:
Originally Posted by amilo3438 View Post
@Snake79

One note: It is not an AGA Demos thread ... than it is opened for reporting AGA Demo problems only !

Yes, I know for this demo ... already tested it a few weeks ago.

p.s.
Also, thanks on good wishes.
I was amazed by the demo, so i have had to report it sorry
Snake79 is offline  
Old 28 June 2014, 13:06   #78
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,130
Demo (Demo) by Argon & Aardvark -> http://janeway.exotica.org.uk/release.php?id=28742 (A1200/4000 68030)(pic.1) ... JFI -> demo requires 68030 CPU !

Dive (Demo) by Complex -> http://janeway.exotica.org.uk/release.php?id=15418 (A1200 basic)(no pic) ... some quick glitch at start (attach as HD, start with ship.exe)

Embryo (Demo) by Balance -> http://janeway.exotica.org.uk/release.php?id=10926 (A1200 basic)(pic.2) ... glitches after 1st text part (attach as HD, start with "setpatch"; "assign embryo: dh0:"; "embryo.exe")

Fear (Demo) by Mystic -> http://janeway.exotica.org.uk/release.php?id=5033 (A1200 basic)(pic.3) ... Note:files attached as 2xHD; volume names "Fear1" and "Fear2" !

Interlude (Demo) by The Lowlifes -> http://janeway.exotica.org.uk/release.php?id=16747 (A1200 basic)(pic.4) ... dots ?!

J.A.M. (Demo) by Ward -> http://janeway.exotica.org.uk/release.php?id=10992 (A1200 4MB)(pic.5) ... JFI, glitches on logo rotation ! (if CE=OFF its Ok)

K-Rauta (Demo) by Insane -> http://janeway.exotica.org.uk/release.php?id=10850 (A1200 basic)(no pic) ... on some places glitches after changing to new screen ... and also on some rotation parts!

Lech (Demo) by Freezers -> http://janeway.exotica.org.uk/release.php?id=10721 (A1200 basic)(pic.6,7) ... when part ends (pic.6) it happens a glitch (pic.7) !
Attached Thumbnails
Click image for larger version

Name:	Aardvark-Demo_001.png
Views:	138
Size:	10.0 KB
ID:	40402   Click image for larger version

Name:	BALANCE-Embryo.png
Views:	136
Size:	27.4 KB
ID:	40403   Click image for larger version

Name:	MYSTIC-FearA.png
Views:	133
Size:	20.7 KB
ID:	40404   Click image for larger version

Name:	TLL-Interlude_001.png
Views:	164
Size:	4.5 KB
ID:	40405   Click image for larger version

Name:	WARD-Jam_001.png
Views:	141
Size:	11.2 KB
ID:	40406  

Click image for larger version

Name:	Freezers-Lech_001.png
Views:	146
Size:	35.3 KB
ID:	40407   Click image for larger version

Name:	Freezers-Lech_002.png
Views:	173
Size:	36.0 KB
ID:	40408  

Last edited by amilo3438; 28 June 2014 at 20:36.
amilo3438 is offline  
Old 30 June 2014, 20:47   #79
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,130
ComaDose (40k Intro) by Passion -> http://janeway.exotica.org.uk/release.php?id=11008 (A1200 basic)(pic.1,2,3) ... when part (pic.1) ends (pic.2) it quick shows/appears a strange screen (pic.3) !

Lazy (40k Intro) by Fake -> http://janeway.exotica.org.uk/release.php?id=18710 (A1200 basic)(pic.4) ... lower part of screen! (when CE=OFF then is fine ... and also if 4Mb Fast)

Party Intro (40k Intro) by In-sect -> http://janeway.exotica.org.uk/release.php?id=11010 (A1200 basic)(pic.5) ... on face guard shading part strange red dots appear!

Rose (40k Intro) by Chryseis & Hoodlum -> http://janeway.exotica.org.uk/release.php?id=10694 (A1200 basic)(no pic) ... on cube part sometimes glitches! (perhaps CPU speed issue)

Symptom (40k Intro) by Freezers -> http://janeway.exotica.org.uk/release.php?id=18704 (A1200 basic)(pic.6) ... glitches! (when CE=OFF then is fine) ... but it glitches also on 4Mb Fast!
Attached Thumbnails
Click image for larger version

Name:	Passion-ComaDose_001.png
Views:	133
Size:	16.2 KB
ID:	40415   Click image for larger version

Name:	Passion-ComaDose_002.png
Views:	161
Size:	4.5 KB
ID:	40416   Click image for larger version

Name:	Passion-ComaDose_003.png
Views:	131
Size:	33.9 KB
ID:	40417   Click image for larger version

Name:	Fake-Lazy_001.png
Views:	134
Size:	48.3 KB
ID:	40418   Click image for larger version

Name:	Insect-40KB_003.png
Views:	126
Size:	5.2 KB
ID:	40419  

Click image for larger version

Name:	Freezers-Symptom_001.png
Views:	128
Size:	24.6 KB
ID:	40420  

Last edited by amilo3438; 30 June 2014 at 23:04.
amilo3438 is offline  
Old 30 June 2014, 22:58   #80
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,120
Quote:
Originally Posted by amilo3438 View Post
Demo (Demo) by Argon & Aardvark -> http://janeway.exotica.org.uk/release.php?id=28742 (A1200/4000 68030)(pic.1) ... JFI -> demo requires 68030 CPU !
Can't test.

Quote:
Dive (Demo) by Complex -> http://janeway.exotica.org.uk/release.php?id=15418 (A1200 basic)(no pic) ... some quick glitch at start (attach as HD, start with ship.exe)
Does not happen, probably CPU as usual.

Quote:
Embryo (Demo) by Balance -> http://janeway.exotica.org.uk/release.php?id=10926 (A1200 basic)(pic.2) ... glitches after 1st text part (attach as HD, start with "setpatch"; "assign embryo: dh0:"; "embryo.exe")
A1200 without fast RAM and HD: not enough RAM (UAE directory filesystem uses very little memory compared to real HD controller). I am not interested in lowering buffers etc..

Quote:
Fear (Demo) by Mystic -> http://janeway.exotica.org.uk/release.php?id=5033 (A1200 basic)(pic.3) ... Note:files attached as 2xHD; volume names "Fear1" and "Fear2" !
Does not seem to work if unpacked to some directory on HD + assigns. Or needs more RAM. (Reason why I don't really like demos that don't fit on a floppy disk)

Quote:
Interlude (Demo) by The Lowlifes -> http://janeway.exotica.org.uk/release.php?id=16747 (A1200 basic)(pic.4) ... dots ?!
A1200 confirmed.

Quote:
J.A.M. (Demo) by Ward -> http://janeway.exotica.org.uk/release.php?id=10992 (A1200 4MB)(pic.5) ... JFI, glitches on logo rotation ! (if CE=OFF its Ok)
No comment. No RAM.

Quote:
K-Rauta (Demo) by Insane -> http://janeway.exotica.org.uk/release.php?id=10850 (A1200 basic)(no pic) ... on some places glitches after changing to new screen ... and also on some rotation parts!
All glitches A1200 confirmed.

Quote:
Lech (Demo) by Freezers -> http://janeway.exotica.org.uk/release.php?id=10721 (A1200 basic)(pic.6,7) ... when part ends (pic.6) it happens a glitch (pic.7) !
(This also needs all available chip RAM, needs transfer to disk and rebooting without CF card inserted.. Boring.)

Not A1200 confirmed. But vector object means 99.999% CPU..
Toni Wilen is online now  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
The Best AGA Demos Djay request.Demos 18 17 June 2018 16:15
Problematic Demos. amilo3438 support.WinUAE 779 05 June 2017 16:33
slowdown since 2700b8 (from Problematic Demos) amilo3438 support.WinUAE 28 22 November 2013 00:50
Best AGA Demos Spritex1 request.Demos 11 11 April 2013 05:12
Kefrens AGA demos? Akira request.Demos 9 16 July 2002 19:43

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 15:59.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.11107 seconds with 14 queries