English Amiga Board Amiga Lore


Go Back   English Amiga Board > Other Projects > project.Amiga Game Factory

 
 
Thread Tools
Old 18 June 2013, 13:16   #41
NovaCoder
Registered User
NovaCoder's Avatar
 
Join Date: Sep 2007
Location: Melbourne/Australia
Posts: 3,433
Ok I've just uploaded this to AmiNet.

I couldn't get it to run as fast as I was aiming for. The render pipeline in Descent Rebirth is not built to run quickly on low end systems, I've done some improvements but I think it would take me ages to get it running at a good speed so I'm calling it a day with this port.

I've also uploaded my full source code to AmiNet so maybe someone else can make it faster.


[ Show youtube player ]


This port is now an example of how to use my AGA SDL which has been the real winner here

Last edited by NovaCoder; 21 June 2013 at 01:19.
NovaCoder is offline  
AdSense AdSense  
Old 21 June 2013, 14:53   #42
Reido
Registered User

 
Join Date: Feb 2013
Location: Dublin/Ireland
Posts: 228
Brilliant can't wait to try. Looks a totally playable speed too, great work and thanks.
Reido is offline  
Old 03 November 2013, 14:16   #43
NovaCoder
Registered User
NovaCoder's Avatar
 
Join Date: Sep 2007
Location: Melbourne/Australia
Posts: 3,433
I was always a bit disappointed with the speed of this port so I've just released an update to AmiNet (V0.57.3.003).

New features:
  • Replaced SDL sound engine with an ASM 16 Channel Mixer (borrowed from AmiWolf)
  • Updated the render loop
  • Added basic RTG support
  • Fixed lots of little bugs

It's now a lot nicer to play on my 060 and also seems less buggy than before (touch wood).....it's still not exactly fast though

I'll try and do a upload a video when I get the chance.
NovaCoder is offline  
Old 05 November 2013, 00:16   #44
NovaCoder
Registered User
NovaCoder's Avatar
 
Join Date: Sep 2007
Location: Melbourne/Australia
Posts: 3,433
[ Show youtube player ]


Will upload to AmiNet tomorrow....
NovaCoder is offline  
Old 05 November 2013, 11:08   #45
Reido
Registered User

 
Join Date: Feb 2013
Location: Dublin/Ireland
Posts: 228
Thanks Nova looks great! My Apollo is away being upgraded so will soon have my 1260/80mhz 64mb super card to play your awesome ports on can't wait!!
Reido is offline  
Old 20 January 2014, 20:01   #46
Foxman
Registered User
 
Join Date: Dec 2009
Location: Germany
Posts: 115
Hi Nova,

i have tried it with Descebt 1 Files but after the briefing when you see the info about the class1 drone, the game crashes every time.
Any knowledge about this problem?

Last edited by Foxman; 20 January 2014 at 20:21.
Foxman is offline  
Old 20 January 2014, 23:38   #47
NovaCoder
Registered User
NovaCoder's Avatar
 
Join Date: Sep 2007
Location: Melbourne/Australia
Posts: 3,433
Quote:
Originally Posted by Foxman View Post
Hi Nova,

i have tried it with Descebt 1 Files but after the briefing when you see the info about the class1 drone, the game crashes every time.
Any knowledge about this problem?
Strange it should work ok, does it create a file called 'ERROR.TXT' in the game folder?

To be honest, I wouldn't bother to play this port yet because it's still a little slow. I'll try and find the time to tune it up a bit more one of these days
NovaCoder is offline  
Old 05 July 2017, 06:25   #48
IvanEBC
Registered User

 
Join Date: Jun 2016
Location: Adelaide
Posts: 336
Quote:
Originally Posted by Foxman View Post
Hi Nova,

i have tried it with Descebt 1 Files but after the briefing when you see the info about the class1 drone, the game crashes every time.
Any knowledge about this problem?
No idea if this will net me any help being an old thread, but thought i'd ask .... did you work out how to stop it doing that as i get the same issue.

A4000/060
Loads up, go through a briefing, then crashes

Maybe you can recall how you got it working.. if you did get it working?

Thanks.
IvanEBC is offline  
Old 15 July 2017, 01:09   #49
NovaCoder
Registered User
NovaCoder's Avatar
 
Join Date: Sep 2007
Location: Melbourne/Australia
Posts: 3,433
Quote:
Originally Posted by IvanEBC View Post
No idea if this will net me any help being an old thread, but thought i'd ask .... did you work out how to stop it doing that as i get the same issue.

A4000/060
Loads up, go through a briefing, then crashes

Maybe you can recall how you got it working.. if you did get it working?

Thanks.
This was never one of my best ports but it should at least run

Have you tried skipping the briefing?

Are you using the shareware or full game files? It's possible that it only works properly with the full game data files (I never tried it with the shareware data)

Last edited by NovaCoder; 21 July 2017 at 06:30.
NovaCoder is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
[ongoing] DosBox AGA (v0.74) NovaCoder project.Amiga Game Factory 95 04 July 2016 22:45
My A1200 rebirth! fatboy Retrogaming General Discussion 5 17 June 2013 20:18
Rebirth of the C64? Amiga next? Oscar Castillo Nostalgia & memories 11 02 September 2010 13:48
Pirates! Rebirth on AMIGA too Haystack Amiga scene 2 19 June 2003 01:13
Descent dido support.Games 19 23 July 2002 19:58

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 00:44.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.15968 seconds with 13 queries