English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 27 August 2016, 05:42   #1
tygre
Returning fan!

tygre's Avatar
 
Join Date: Jan 2011
Location: Montréal, QC, Canada
Posts: 857
Crash of WinUAE v2.8.1.0 when testing NetSurf

Dear all, dear Toni,

I am just reporting this crash just in case because I know that it happens on an outdated version of WinUAE

I am using AmigaForever 2014 to test NetSurf (trying to get JavaScript support to work...) and it is running WinUAE v2.8.1.0. With one particular version of NetSurf (it is about 7Mb, so I won't post it here but can share it by Dropbox or something if needed), WinUAE crashes and a window Arabuusimiehet opens with:

Code:
  D0 0000FFFE   D1 0000000F   D2 00000000   D3 0000000F
  D4 00180000   D5 00000018   D6 00000001   D7 000000FF
  A0 10A2C934   A1 10083070   A2 38029644   A3 0000041A
  A4 0000000F   A5 0000000E   A6 1092EA08   A7 1092EA00
USP  1092EA00 ISP  100022A8 SFC  00000000 DFC  00000000
CACR 00000009 VBR  00000000 CAAR 00000000 MSP  00000000
T=00 S=0 M=0 X=0 N=0 Z=0 V=0 C=0 IMASK=0 STP=0
FP0: 154624 FP1: 1 FP2: 0 FP3: 0
FP4: 0 FP5: 0 FP6: 0 FP7: 0
FPSR: 4000228 FPCR: 00000090 FPIAR: 109780b2 N=0 Z=1 I=0 NAN=0
38029644 0000 0000                OR.B #$ff,D0
Thanks and take care!
tygre is offline  
Old 27 August 2016, 08:59   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 45
Posts: 24,632
Usual application bug: emulated CPU tried to execute code from non-existing memory location. Some versions accidentally enabled built-in debugger in this situation.
Toni Wilen is offline  
Old 27 August 2016, 16:03   #3
tygre
Returning fan!

tygre's Avatar
 
Join Date: Jan 2011
Location: Montréal, QC, Canada
Posts: 857
Thanks Toni!
tygre is offline  
Old 27 August 2016, 18:52   #4
Diz_57
Registered User
 
Join Date: Dec 2010
Location: Lancashire / England
Posts: 62
Just replace the winuae in your af installation with a newer one
Diz_57 is offline  
Old 28 August 2016, 02:34   #5
tygre
Returning fan!

tygre's Avatar
 
Join Date: Jan 2011
Location: Montréal, QC, Canada
Posts: 857
Will do, thanks!
tygre is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
WinUAE 3.2.2 Crash SubV support.WinUAE 3 11 January 2016 21:44
WinUAE 2.8.1 Crash Saghalie support.WinUAE 1 06 November 2014 09:12
Experimental/testing builds of WinUAE 2.7.0 with VS 2013 mark_k support.WinUAE 18 09 September 2014 23:26
Winuae 2.0.1 crash Heula support.WinUAE 7 03 January 2010 11:43
another WinUAE 1.5.1 crash jharrison support.WinUAE 4 04 September 2008 17:53

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 14:03.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.06538 seconds with 13 queries