English Amiga Board Amiga Lore


Go Back   English Amiga Board > abime.net - Hosted Projects > project.ClassicWB

 
 
Thread Tools
Old 19 May 2013, 03:12   #1
Neil79
Registered User
Neil79's Avatar
 
Join Date: Jul 2012
Location: Kent
Age: 37
Posts: 2,454
Will ClassicWB be updated?

I noticed through my experience that a number of devices/software are out of date in ClassicWB even ClassicWBADVSP

Namely Fat95 is version 3.11 but 3.8 is available

The audio devices with AHI that need to be overwritten/installed are also much much newer.

Not sure what else is out of date as i'm doing bits at a time
Neil79 is offline  
AdSense AdSense  
Old 19 May 2013, 03:29   #2
luy32
Registered User
 
Join Date: Apr 2012
Location: Ohrid / Macedonia
Age: 44
Posts: 23
Send a message via Skype™ to luy32
Quote:
Originally Posted by Neil79 View Post
Namely Fat95 is version 3.11 but 3.8 is available

hmmmm.....

it is not a decimal it is version.revision
ver3. rev11 is higher than ver3.rev8
luy32 is offline  
Old 19 May 2013, 11:36   #3
mfilos
Paranoid Amigoid

mfilos's Avatar
 
Join Date: Mar 2008
Location: Athens/Greece
Age: 38
Posts: 1,576
Send a message via Skype™ to mfilos
AHI on CWB editions is 4.0. In fact latest version 6.0 is slower so i think this is the reason that Bloodwych put this version compared to the latest.
mfilos is offline  
Old 19 May 2013, 13:07   #4
Bloodwych
Moderator

Bloodwych's Avatar
 
Join Date: Jun 2001
Location: I'm behind you!
Posts: 3,763
mfilos is on the money - I only update to versions I know work the best or I have fully tested myself.

Sometimes the most recent version is not the best, or if you jump straight to a more recent version it ends up having bugs or is slower on classic Amigas. Newer versions are not tested as extensively on older Workbench and Amiga setups as older versions, so you have to be careful.

The newer Scalos is an exapmple of that, as are some of the MUI files.

The packs do need an update - WHDLoad is now v17.1 and PeterK's icon pack would be a nice addition for example. Not sure when I'll get time to update them however, soon I hope. In the mean time the packs are pretty easy to update and customize yourself so it's not such a big issue.

It is worth checking for newer versions if something is not working correctly or you need a newer version of a file to run a program but upgrading everything to latest versions just for the sake of it can lead to problems - so test each change!
Bloodwych is offline  
Old 19 May 2013, 17:58   #5
Neil79
Registered User
Neil79's Avatar
 
Join Date: Jul 2012
Location: Kent
Age: 37
Posts: 2,454
Thanks Bloodwych, sounds about right

How easy is it to update to the latest WHDLOAD? Simply downloading and running the install file via the classicwb os?

If you ever get the time to update the classicWB versions to the latest that only work well, it would be a huge bonus
Neil79 is offline  
Old 19 May 2013, 18:55   #6
Turran
Registered User

Turran's Avatar
 
Join Date: May 2012
Location: Stockholm / Sweden
Age: 43
Posts: 804
Quote:
Originally Posted by Neil79 View Post
How easy is it to update to the latest WHDLOAD? Simply downloading and running the install file via the classicwb os?
Yes. Just run through the installation.

Check4GB is older as well. If you update in the future, add it to your list =)
Turran is offline  
Old 19 May 2013, 19:07   #7
Neil79
Registered User
Neil79's Avatar
 
Join Date: Jul 2012
Location: Kent
Age: 37
Posts: 2,454
Nice!

Have just updated WHDLOAD, was **** easy!

Thanks
Neil79 is offline  
Old 19 May 2013, 19:09   #8
duga
Registered User
 
Join Date: Nov 2010
Location: Sweden
Posts: 321
ClassAct doesn't work on A600 (68000 + 2 MB chip + 4 MB fast + ROM 3.1) on latest ClassicWB. Ramlib crashes.
duga is offline  
Old 20 May 2013, 07:05   #9
NovaCoder
Registered User
NovaCoder's Avatar
 
Join Date: Sep 2007
Location: Melbourne/Australia
Posts: 3,433
Quote:
Originally Posted by mfilos View Post
AHI on CWB editions is 4.0. In fact latest version 6.0 is slower so i think this is the reason that Bloodwych put this version compared to the latest.
Yep v4.18 is the latest version of AHI you want installed on the real thing. AHI v6 has more accurate sound playback at the cost of precious CPU cycles.
NovaCoder is offline  
Old 23 June 2013, 16:05   #10
Bloodwych
Moderator

Bloodwych's Avatar
 
Join Date: Jun 2001
Location: I'm behind you!
Posts: 3,763
Quote:
Originally Posted by duga View Post
ClassAct doesn't work on A600 (68000 + 2 MB chip + 4 MB fast + ROM 3.1) on latest ClassicWB. Ramlib crashes.
Hi, sorry for the late response. You need to download the classact2demo file from Aminet, then manually copy across the layout.gadget file 68000 version. I must have left a 020 version in there and the installer for classact will not replace newer files, hence the crash.

This version was converted across from the 020 LITE and I removed classact as it wasn't required for the default install, so never noticed that a Classact 020 layout.gadget file was left in the drawer. This will be fixed by the next version.

Last edited by Bloodwych; 23 June 2013 at 17:03.
Bloodwych is offline  
Old 24 June 2013, 14:57   #11
markie32
 
Posts: n/a
Patiently waiting the next cwb update
 
Old 02 September 2013, 20:38   #12
Retro-Nerd
Missile Command Champion

Retro-Nerd's Avatar
 
Join Date: Aug 2005
Location: Germany
Age: 45
Posts: 10,628
The download section needs a link update. Currently there is shown the v26 version, but it's actually v27 on the server.

Quote:
download.abime.net/classicwb/ClassicWB_LITE_v26.zip
You have to change the "6" to "7" atm to download the packs.
Retro-Nerd is offline  
Old 02 September 2013, 20:54   #13
Bloodwych
Moderator

Bloodwych's Avatar
 
Join Date: Jun 2001
Location: I'm behind you!
Posts: 3,763
Yeah, something strange has happeded to the website. A few pics weren't displaying, then I had to upload the site again. Must have uploaded an old version of the site. woops.
Bloodwych is offline  
Old 02 September 2013, 20:57   #14
Retrofan
Ruler of the Universe

Retrofan's Avatar
 
Join Date: Mar 2010
Location: Lanzarote/Spain
Posts: 5,582
Send a message via Skype™ to Retrofan
How goes the update of the CWBAdv versions? I really want to try it
Retrofan is offline  
Old 02 September 2013, 21:12   #15
Bloodwych
Moderator

Bloodwych's Avatar
 
Join Date: Jun 2001
Location: I'm behind you!
Posts: 3,763
Ok, fixed the website - didn't take long to notice, only uploaded the old version by accident yesterday. Thanks for letting me know Retro-Nerd.

Retrofan, me fellow pre-installed pack buddy - I've updated all the packs up to the ADV version - GAAE, 68K, LITE (inc the WB 1.3 themes) and FULL are done, but really struggling to find the time to sit down and finish them to be honest. I keep chipping away an hour or so each weekend.
Bloodwych is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
amiblitz3 still updated turrican3 Amiga scene 4 09 June 2013 18:43
Which OS - ClassicWB 3.1 ADVSP or ClassicWB 3.9? MrGimper support.Hardware 7 06 October 2010 11:10
Multiboot ClassicWB/3.1 and ClassicWB/OS3.9 MrGimper support.Hardware 4 16 September 2010 19:42
EasyNet Updated amigakit.com Amiga scene 6 22 June 2008 01:10
EasyADF Updated! amigakit.com Amiga scene 0 09 March 2008 16:03

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 18:18.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.17929 seconds with 12 queries