English Amiga Board


Go Back   English Amiga Board > Support > support.Apps

 
 
Thread Tools
Old 28 July 2018, 04:29   #1
hardgb
HARDGB

 
Join Date: Jan 2016
Location: Fortaleza / Brasil
Posts: 12
Maximize IDE speed

I need to maximize the IDE speed of my A1200.
But I'd like to start doing this without the need for hardware.
I do not know what commands I can use. I did some research and discovered speedyIDE. Does anyone know how to make it work with RemApollo. My settings: Amiga A1200 more Apollo 1260.
My startup-sequence.

Code:
;ClassicWB Startup-Sequence
;--------------------------
;OS39

;Start OS3.9 Checks

DRAP
If WARN
RemApollo MAC QUIET
EndIf

IF EXISTS C:SquirrelSCSI
    C:SquirrelSCSI
EndIF
Set SCSIUpdate 1
IF EXISTS C:IDEFix
    C:IDEFix
    Set SCSIUpdate 0
EndIF
IF EXISTS SYS:Expansion/XSurfIDE
    Set SCSIUpdate 0
EndIF
IF EXISTS SYS:Prefs/Env-Archive/NOSCSIUPDATE
    Set SCSIUpdate 0
EndIf
IF $SCSIUpdate EQ 1
   SetPatch SKIPROMUPDATES "exec.library" QUIET
Else
   SetPatch SKIPROMUPDATES "scsi.device,exec.library" QUIET
   ;C:SetPatch QUIET
;ELSE
   ;C:SetPatch SKIPROMUPDATES "scsi.device" QUIET
EndIF
Unset SCSIUpdate
;End OS3.9 Checks

C:GetMouseInput LOCAL

IF $MouseInput EQ 1
  Unset MouseInput
  C:Assign >NIL: ENV: RAM:
  C:Assign >NIL: T: RAM:
  C:Execute S:Maxmem-Sequence
  EndCLI >NIL:
EndIF

IF $MouseInput EQ 2
  Unset MouseInput
  C:Execute S:Bootmenu-Sequence
  EndCLI >NIL:
EndIF

Unset MouseInput

IF EXISTS C:StackAttack
  C:StackAttack
EndIF

C:Version >NIL:
FailAt 21

IF EXISTS SYS:WBstartupD
  C:Rename >NIL: SYS:WBStartup SYS:WBStartupM
  C:Rename >NIL: SYS:WBStartupD SYS:WBStartup
EndIF

Resident >NIL: C:IconX PURE
Resident >NIL: C:WBRun PURE
Resident >NIL: C:Assign PURE
Resident >NIL: C:Execute PURE
Resident >NIL: C:SetEnv PURE REPLACE

IF EXISTS L:env-handler
  C:MakeDir RAM:T RAM:Clipboards
  L:env-handler
ELSE
  C:MakeDir RAM:T RAM:Clipboards RAM:ENV RAM:ENV/Sys
  C:Copy >NIL: ENVARC: RAM:ENV ALL NOREQ
  Assign >NIL: ENV: RAM:ENV
EndIF

IF EXISTS C:PatchRAM
  C:PatchRAM
EndIF

IF EXISTS C:TagLiFE
  C:TagLiFE
EndIF

Assign >NIL: T: RAM:T
Assign >NIL: CLIPS: RAM:Clipboards
Assign >NIL: REXX: S:
Assign >NIL: PRINTERS: DEVS:Printers
Assign >NIL: KEYMAPS: DEVS:Keymaps
Assign >NIL: LOCALE: SYS:Locale
Assign >NIL: LIBS: SYS:Classes ADD
Assign >NIL: HELP: LOCALE:Help DEFER

C:CPU60 B >NIL:
RUN >NIL: CopyMem060

IF EXISTS C:BlazeWCP
  C:BlazeWCP
EndIF

IF EXISTS SYS:System/FBlit/FBlit
  SYS:System/FBlit/FBlit
  SYS:System/FBlit/FText
EndIF

BindDrivers
C:Mount >NIL: DEVS:DOSDrivers/~(#?.info)

C:LoadMonDrvs

SetEnv Language "english"
SetEnv Workbench $Workbench
SetEnv Kickstart $Kickstart
UnSet Workbench
UnSet Kickstart

IF EXISTS C:CyberBugFix
  C:CyberBugFix
EndIF

IF EXISTS C:IconBeFast
  C:IconBeFast 0
EndIF

C:AddDataTypes REFRESH QUIET
IF EXISTS SYS:System/VPrefs/VisualPrefs
  Run > NIL: SYS:System/VPrefs/VisualPrefs
EndIF
C:IPrefs
SYS:System/FPalette/FPPrefs
C:ConClip

Path >NIL: RAM: C: SYS:Utilities SYS:Rexxc SYS:System S: SYS:Prefs SYS:WBStartup SYS:Tools SYS:Tools/Commodities

SYS:System/REXXMast >NIL:

IF EXISTS S:User-Startup
  Execute S:User-Startup
EndIF

Resident Execute REMOVE
Resident Assign REMOVE

IF EXISTS C:StackAttack
  C:StackAttack AUTO
EndIF

C:LoadWB

EndCLI >NIL:
hardgb is offline  
Old 28 July 2018, 13:37   #2
daxb
Registered User
 
Join Date: Oct 2009
Location: Germany
Posts: 2,097
Ahh... don't ask the same question in two threads, please. See other thread for my answer.
daxb is offline  
Old 28 July 2018, 19:35   #3
hardgb
HARDGB

 
Join Date: Jan 2016
Location: Fortaleza / Brasil
Posts: 12
Forgive me, that will not happen again.
hardgb is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Coding challenge: Maximize-contiguous-chipmem bootblock Photon Coders. System 30 01 August 2017 14:41
how to maximize memory jotd support.Other 3 27 November 2015 23:41
Is suggested to use both IDE peripherals on internal IDE channel of the 1200? guybrush support.Hardware 2 24 July 2015 11:52
Benching and optimizing CF-IDE speed Photon support.Hardware 12 15 July 2009 02:48
SCSI-IDE bridge + IDE to CF adapter - How can I make a backup? Tuffy New to Emulation or Amiga scene 2 02 April 2008 22:14

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 14:53.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.10509 seconds with 15 queries