English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.FS-UAE

 
 
Thread Tools
Old 30 December 2016, 14:08   #1161
Solskogen
Registered User
 
Join Date: Nov 2016
Location: Skien / Norway
Posts: 9
Small bug in FS-UAE Launcher 2.9.1dev.
It won't show the listed configurations (but the configs are saved into ~/FS-UAE/Configurations. It just won't up in the list.
Solskogen is offline  
AdSense AdSense  
Old 30 December 2016, 17:22   #1162
FrodeSolheim
FS-UAE Developer

FrodeSolheim's Avatar
 
Join Date: Dec 2011
Location: Førde, Norway
Age: 35
Posts: 3,301
Quote:
Originally Posted by Solskogen View Post
Small bug in FS-UAE Launcher 2.9.1dev.
It won't show the listed configurations (but the configs are saved into ~/FS-UAE/Configurations. It just won't up in the list.
Confirmed. Stupid bug, fixed in GIT. Will release 2.9.2dev soon
FrodeSolheim is offline  
Old 31 December 2016, 18:32   #1163
FrodeSolheim
FS-UAE Developer

FrodeSolheim's Avatar
 
Join Date: Dec 2011
Location: Førde, Norway
Age: 35
Posts: 3,301
A new development version has been released. Changes in FS-UAE 2.9.2dev:
  • New boolean option warp_mode (warp_mode = 1 to start in warp mode).
  • Try ralphschmidt-cyberstorm-ppc-4471.rom if cyberstormppc.rom is not found.
  • Imported updated translations from crowdin.com.
Changes in FS-UAE Launcher 2.9.2dev:
  • Try ralphschmidt-cyberstorm-ppc-4471.rom if cyberstormppc.rom is not found.
  • Also look for ralphschmidt-cyberstorm-ppc-4471.rom in Amiga Forever dir.
  • Fix file name when saving controller configs on macOS.
  • Fix configurations not showing up since 2.9.1dev.
  • Indicate unpublished variants in variants list.
  • When enabling “unpublished” entries, list unpublished variants last.
  • Imported updated translations from crowdin.com.
HAPPY NEW YEAR!
FrodeSolheim is offline  
Old 04 January 2017, 23:30   #1164
Marmotta
Registered User

 
Join Date: Aug 2014
Location: Italy
Posts: 28
On Osx AmigaOs4.1F work correctly (without UAE extensions) if I apply Update 1, AmigaOs stop working... hang on start flashing screen without massages.
Marmotta is offline  
Old 05 January 2017, 01:40   #1165
esc
Registered User
 
Join Date: Jan 2010
Location: Palo Alto, California, USA
Posts: 264
How did you update it? You have to download the update archive to disk, uncompress it to disk, and run the update software there. The Amiga software updater tries unarchiving the lha to ram: and runs out of space.
esc is offline  
Old 05 January 2017, 01:48   #1166
Marmotta
Registered User

 
Join Date: Aug 2014
Location: Italy
Posts: 28
Quote:
Originally Posted by esc View Post
How did you update it? You have to download the update archive to disk, uncompress it to disk, and run the update software there. The Amiga software updater tries unarchiving the lha to ram: and runs out of space.
I follow this (correct) steps! But I have one news... my hardfile is corrupt and is not readable is not a fs-uae problem, but I not know the cause
Marmotta is offline  
Old 15 January 2017, 13:39   #1167
Romanujan
Registered User
 
Join Date: Dec 2007
Location: Szczecin/Poland
Posts: 135
I have stability problems with filesystem emulation. Steps to reproduce the crash:

1. Prepare a filesystem with tens of thousands files - like OS 3.9 + AISS + GeekGadgets + NDK 3.9 + etc.
2. Try to compress everything using LHA (this was my original use case) or just take util/cli/MakeList from AmiNet (http://aminet.net/package/util/cli/MakeList) and try to generate file list for such a file system (crashes faster).

FS-UAE segfaults every time for me, on a random file. It doesn't look like Amiga-side problem, as copying all the files to RAM disk and doing the operation on files stored there works correctly (I have tried ram-handler 44.23 with Thomas Richter patch and AmberRAM from AmiNet - both work).

Logs and backtrace in the attachment.
Attached Files
File Type: 7z crash.tar.7z (14.5 KB, 3 views)
Romanujan is offline  
Old 15 January 2017, 14:51   #1168
jbl007
Registered User
 
Join Date: Mar 2013
Location: Leipzig/Germany
Posts: 309
Quote:
Originally Posted by FrodeSolheim View Post
  • Fix decoding on non-ascii %-escaped file names on directory HDs.
It does not crash anymore. But i'm still having issues with filenames containing the % char. For example:
Code:
%30
10%full
100%c0mplete
50% junk
it is at 20%.txt
Attached Thumbnails
Click image for larger version

Name:	percent.png
Views:	17
Size:	972 Bytes
ID:	51708  
jbl007 is offline  
Old 15 January 2017, 15:26   #1169
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 41
Posts: 18,333
Quote:
Originally Posted by Romanujan View Post
I have stability problems with filesystem emulation. Steps to reproduce the crash:
Not enough stack? UAE filesystem needs much more stack than most other "normal" filesystems.
Toni Wilen is online now  
Old 15 January 2017, 15:50   #1170
Romanujan
Registered User
 
Join Date: Dec 2007
Location: Szczecin/Poland
Posts: 135
@jbl007 - this is from 2.9.1; I have 2.9.3 (I didn't tell my configuration as the logs contains everything). Initially I also though I might have problem with some filename and tried to isolate it - but without success. At certain point smaller portions of data were all compressed correctly.

I think my problem is caused by large amount of certain operations within short time, damaging the emulator process memory. I can copy all the files from the filesystem to RAM disk, and it works OK. It seems to me that LHA (contrary to the Copy command) starts by indexing all the files, which triggers the crash.

@Toni - I have StackAttack 49152 in my Startup-Sequence. Besides, error inside the emulated environment shouldn't cause the emulator to crash... from the backtrace and the source code I can see the glibc aborted the program during free(...) call, probably after detecting memory corruption.

Last edited by Romanujan; 15 January 2017 at 16:09.
Romanujan is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS-UAE 1.3 Development Series FrodeSolheim support.FS-UAE 376 28 October 2012 18:42
FS-UAE 1.1 Development Series FrodeSolheim support.FS-UAE 214 06 May 2012 14:53
FS-UAE 1.0 Stable Series FrodeSolheim support.FS-UAE 62 01 May 2012 01:15
FS-UAE 1.1 Development Series - Autoscaling problem weiju support.FS-UAE 4 06 April 2012 07:11
E-UAE Development pjhutch support.OtherUAE 1 06 October 2008 03:26

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 21:12.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.18619 seconds with 13 queries