English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.FS-UAE

 
 
Thread Tools
Old 30 December 2016, 13:08   #1161
Solskogen
Registered User
 
Join Date: Nov 2016
Location: Skien / Norway
Posts: 9
Small bug in FS-UAE Launcher 2.9.1dev.
It won't show the listed configurations (but the configs are saved into ~/FS-UAE/Configurations. It just won't up in the list.
Solskogen is offline  
AdSense AdSense  
Old 30 December 2016, 16:22   #1162
FrodeSolheim
FS-UAE Developer

FrodeSolheim's Avatar
 
Join Date: Dec 2011
Location: Førde, Norway
Age: 36
Posts: 3,368
Quote:
Originally Posted by Solskogen View Post
Small bug in FS-UAE Launcher 2.9.1dev.
It won't show the listed configurations (but the configs are saved into ~/FS-UAE/Configurations. It just won't up in the list.
Confirmed. Stupid bug, fixed in GIT. Will release 2.9.2dev soon
FrodeSolheim is offline  
Old 31 December 2016, 17:32   #1163
FrodeSolheim
FS-UAE Developer

FrodeSolheim's Avatar
 
Join Date: Dec 2011
Location: Førde, Norway
Age: 36
Posts: 3,368
A new development version has been released. Changes in FS-UAE 2.9.2dev:
  • New boolean option warp_mode (warp_mode = 1 to start in warp mode).
  • Try ralphschmidt-cyberstorm-ppc-4471.rom if cyberstormppc.rom is not found.
  • Imported updated translations from crowdin.com.
Changes in FS-UAE Launcher 2.9.2dev:
  • Try ralphschmidt-cyberstorm-ppc-4471.rom if cyberstormppc.rom is not found.
  • Also look for ralphschmidt-cyberstorm-ppc-4471.rom in Amiga Forever dir.
  • Fix file name when saving controller configs on macOS.
  • Fix configurations not showing up since 2.9.1dev.
  • Indicate unpublished variants in variants list.
  • When enabling “unpublished” entries, list unpublished variants last.
  • Imported updated translations from crowdin.com.
HAPPY NEW YEAR!
FrodeSolheim is offline  
Old 04 January 2017, 22:30   #1164
Marmotta
Registered User

 
Join Date: Aug 2014
Location: Italy
Posts: 29
On Osx AmigaOs4.1F work correctly (without UAE extensions) if I apply Update 1, AmigaOs stop working... hang on start flashing screen without massages.
Marmotta is offline  
Old 05 January 2017, 00:40   #1165
esc
Registered User
 
Join Date: Jan 2010
Location: Palo Alto, California, USA
Posts: 372
How did you update it? You have to download the update archive to disk, uncompress it to disk, and run the update software there. The Amiga software updater tries unarchiving the lha to ram: and runs out of space.
esc is offline  
Old 05 January 2017, 00:48   #1166
Marmotta
Registered User

 
Join Date: Aug 2014
Location: Italy
Posts: 29
Quote:
Originally Posted by esc View Post
How did you update it? You have to download the update archive to disk, uncompress it to disk, and run the update software there. The Amiga software updater tries unarchiving the lha to ram: and runs out of space.
I follow this (correct) steps! But I have one news... my hardfile is corrupt and is not readable is not a fs-uae problem, but I not know the cause
Marmotta is offline  
Old 15 January 2017, 12:39   #1167
Romanujan
Registered User
 
Join Date: Dec 2007
Location: Szczecin/Poland
Posts: 174
I have stability problems with filesystem emulation. Steps to reproduce the crash:

1. Prepare a filesystem with tens of thousands files - like OS 3.9 + AISS + GeekGadgets + NDK 3.9 + etc.
2. Try to compress everything using LHA (this was my original use case) or just take util/cli/MakeList from AmiNet (http://aminet.net/package/util/cli/MakeList) and try to generate file list for such a file system (crashes faster).

FS-UAE segfaults every time for me, on a random file. It doesn't look like Amiga-side problem, as copying all the files to RAM disk and doing the operation on files stored there works correctly (I have tried ram-handler 44.23 with Thomas Richter patch and AmberRAM from AmiNet - both work).

Logs and backtrace in the attachment.
Attached Files
File Type: 7z crash.tar.7z (14.5 KB, 40 views)
Romanujan is offline  
Old 15 January 2017, 13:51   #1168
jbl007
Registered User
 
Join Date: Mar 2013
Location: Leipzig/Germany
Posts: 339
Quote:
Originally Posted by FrodeSolheim View Post
  • Fix decoding on non-ascii %-escaped file names on directory HDs.
It does not crash anymore. But i'm still having issues with filenames containing the % char. For example:
Code:
%30
10%full
100%c0mplete
50% junk
it is at 20%.txt
Attached Thumbnails
Click image for larger version

Name:	percent.png
Views:	73
Size:	972 Bytes
ID:	51708  
jbl007 is offline  
Old 15 January 2017, 14:26   #1169
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,561
Quote:
Originally Posted by Romanujan View Post
I have stability problems with filesystem emulation. Steps to reproduce the crash:
Not enough stack? UAE filesystem needs much more stack than most other "normal" filesystems.
Toni Wilen is offline  
Old 15 January 2017, 14:50   #1170
Romanujan
Registered User
 
Join Date: Dec 2007
Location: Szczecin/Poland
Posts: 174
@jbl007 - this is from 2.9.1; I have 2.9.3 (I didn't tell my configuration as the logs contains everything). Initially I also though I might have problem with some filename and tried to isolate it - but without success. At certain point smaller portions of data were all compressed correctly.

I think my problem is caused by large amount of certain operations within short time, damaging the emulator process memory. I can copy all the files from the filesystem to RAM disk, and it works OK. It seems to me that LHA (contrary to the Copy command) starts by indexing all the files, which triggers the crash.

@Toni - I have StackAttack 49152 in my Startup-Sequence. Besides, error inside the emulated environment shouldn't cause the emulator to crash... from the backtrace and the source code I can see the glibc aborted the program during free(...) call, probably after detecting memory corruption.

Last edited by Romanujan; 15 January 2017 at 15:09.
Romanujan is offline  
Old 24 January 2017, 21:41   #1171
km-l
Registered User

 
Join Date: Sep 2014
Location: Gdansk/Poland
Posts: 1
Hi.
In CDTV mode I can not use a floppy disk drive.
km-l is offline  
Old 26 January 2017, 20:14   #1172
mia
Registered User

 
Join Date: Jan 2017
Location: UK
Posts: 2
Hi,

I'm using 2.9.3dev and I'm having an issue running AMOS from an RTG workbench. When switching to the AMOS screen; FS-UAE crashes - the debugger states:

Exception thrown at 0x000000000049A788 in fs-uae.exe: 0xC0000005: Access violation writing location 0x000000000E1A4E20.

There is no problem launching AMOS from an AGA workbench, which I'm doing now. And I've only tried with AMOS Professional 2.0.
mia is offline  
Old 03 February 2017, 22:02   #1173
yesplease
Registered User

yesplease's Avatar
 
Join Date: May 2012
Location: germany
Posts: 144
Hi frode,

I can not move the amiga mouse anymore.

Issue is on Mac 10.12.3 launcher version is 2.9.2 and also 2.9.3

I reverted back to version 2.7.3 where I can move the amiga mouse pointer again.

Did I miss something ? Some migration script for mouses ?

EDIT: Oh I found it. It was an old mouse setting in the "Erweiterte Einstellungen". I deleted it and now mouse works also on 2.9.2/3

Last edited by yesplease; 03 February 2017 at 22:12.
yesplease is offline  
Old 10 February 2017, 19:14   #1174
FrodeSolheim
FS-UAE Developer

FrodeSolheim's Avatar
 
Join Date: Dec 2011
Location: Førde, Norway
Age: 36
Posts: 3,368
A new development version has been released. Changes in FS-UAE Launcher 2.9.4dev:
  • Try to use config from game database when launching with a WHDLoad archive.
  • New startup argument –no-auto-detect-game to disable the above feature.
  • Save directory based on archive name when launching with an archive.
  • Fixed a bug where rating icons could disappear from variants list.
  • New option whdload_preload, defaults to 1 (change in behavior).
  • More language flags for the status bar.
  • New option to toggle close buttons in dialogs.
  • New reset to defaults button on settings pages (GUI does not update yet).
Changes in FS-UAE Arcade 2.9.4dev:
  • New option arcade_initial_favorites to start with favorites filter.
  • New startup argument –favorites to show the favorites list directly.
  • Show game lists in FS-UAE Arcade (favorites, etc).
  • New option arcade_theme (=blue/red).
  • Fixed aspect correction toggle button.
You need to re-run the file scanner (and game scanner) when updating to this version.
Regarding the favorites functionality, there is no UI to add/remove favorites in the the Launcher/Arcade yet. But you can filter by favorites. For now, favorite games can be added/removed at https://openretro.org/user/favorites and the launcher will sync down this list when updating the game database.
FrodeSolheim is offline  
Old 19 February 2017, 23:28   #1175
R-TEAM
Registered User

 
Join Date: Mar 2014
Location: Germany
Posts: 45
Hi,

2.9.4dev running nice (Win64) ....
But i have problems with NetPlay ...
Start the NetPlay server on PC1 (my PC) ....
With this line : C:\Users\xxx\AppData\Local\FS-UAE\fs-uae-launcher.exe --app=fs-uae-netplay-server --players=2 --port=25100
Conect to it with launch the launcher on the PC1 and i get "connectet - wait to start" screen ..
Then an friend connect over INet to the server .... connect o.k. ... port is forwarded ..
Then the Emu start ...
But then it fails with "connection error 4"
Every Time we try ....

Regards
R-TEAM is offline  
Old 04 March 2017, 16:09   #1176
R-TEAM
Registered User

 
Join Date: Mar 2014
Location: Germany
Posts: 45
Hi,

have to correct me, the Netplay fail with connection error 8
on different trys with diskfiles and whdload zipped files ...

Regards
R-TEAM is offline  
Old 04 March 2017, 21:07   #1177
R-TEAM
Registered User

 
Join Date: Mar 2014
Location: Germany
Posts: 45
Hi, (again )

problem solved ... firewall problem on one end ...
NetPlay runs now nice ....

Regards
R-TEAM is offline  
Old 11 March 2017, 09:18   #1178
lazlow
Registered User

 
Join Date: Feb 2017
Location: Koln
Posts: 5
Hello,

I am running fs-uae-launcher 2.9.4dev on arch linux.
My problem is that (in games like Chaos Engine, Sensible Soccer), the down+right+fire and up+left+fire does not work, only the left+down+fire and up+right+fire.
Is it a configuration problem (I am quite new to fsuae) or a bug?

Thanks!
lazlow is offline  
Old 18 March 2017, 16:48   #1179
Goingdown
Registered User
Goingdown's Avatar
 
Join Date: Dec 2012
Location: Finland
Posts: 138
I recently installed OpenSUSE tumbleweed on one of my computers. It seems that FS-UAE devel opensuse tumbleweed repo is not up to date - fs-uae is version 2.9.4 but Launcher and Arcade are still version 2.9.2.

EDIT. After some investigation, it seems that all OpenSUSE repos are same way providing outdated versions of Launcher and Arcade... Maybe build problem?
Goingdown is offline  
Old 19 March 2017, 23:24   #1180
FrodeSolheim
FS-UAE Developer

FrodeSolheim's Avatar
 
Join Date: Dec 2011
Location: Førde, Norway
Age: 36
Posts: 3,368
Quote:
Originally Posted by lazlow View Post
Hello,

I am running fs-uae-launcher 2.9.4dev on arch linux.
My problem is that (in games like Chaos Engine, Sensible Soccer), the down+right+fire and up+left+fire does not work, only the left+down+fire and up+right+fire.
Is it a configuration problem (I am quite new to fsuae) or a bug?

Thanks!
It could in theory be a problem with your keyboard (i.e. that it cannot recognize those combinations). If each key works fine by itself, that's the most likely explanation. See https://en.wikipedia.org/wiki/Rollover_(key) for more information. You can perhaps test it here: http://www.gigahype.com/nkey-rollover-test-page/

Quote:
Originally Posted by Goingdown View Post
I recently installed OpenSUSE tumbleweed on one of my computers. It seems that FS-UAE devel opensuse tumbleweed repo is not up to date - fs-uae is version 2.9.4 but Launcher and Arcade are still version 2.9.2.

EDIT. After some investigation, it seems that all OpenSUSE repos are same way providing outdated versions of Launcher and Arcade... Maybe build problem?
Right, there is a build error there, thanks for pointing it out.. will fix
FrodeSolheim is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS-UAE 1.3 Development Series FrodeSolheim support.FS-UAE 376 28 October 2012 17:42
FS-UAE 1.1 Development Series FrodeSolheim support.FS-UAE 214 06 May 2012 13:53
FS-UAE 1.0 Stable Series FrodeSolheim support.FS-UAE 62 01 May 2012 00:15
FS-UAE 1.1 Development Series - Autoscaling problem weiju support.FS-UAE 4 06 April 2012 06:11
E-UAE Development pjhutch support.OtherUAE 1 06 October 2008 02:26

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 04:10.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.35096 seconds with 15 queries