English Amiga Board


Go Back   English Amiga Board > News

 
 
Thread Tools
Old 05 April 2019, 03:17   #381
tygre
Returning fan!

tygre's Avatar
 
Join Date: Jan 2011
Location: Montréal, QC, Canada
Posts: 649
Hi Englyst!

Quote:
Originally Posted by Englyst View Post
I've just tested the latest AmiModRadio on my A1200 running WB 3.1.4. Roadshow as TCP/IP stack, 68030 with 128 MB RAM. And it does exactly the same as my A2000 Vampire with CoffinOS. Takes 10 minutes before the interface comes up. And can't find any mods using the standard Aminet/mods source. After that the program stops responding I just have to accept that the program doesn't like me! Bugger...
Thank you so much for testing further but sorry that it doesn't work better Right now, I'm thinking that it could be the way AmiModRadio interacts with the bsdsocket.library, which would be not compatible with Roadshow...

Has anyone else used AmiModRadio with Roadshow? Any problem?

Quote:
Originally Posted by Englyst View Post
If I ever find the reason and fix it, I'll let you know how I solved it.
Thanks a lot again for testing and your patience
Best!
tygre is offline  
Old 17 April 2019, 01:26   #382
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,004
Hi tygre, in the preferences panel you can move the name of the skins to the right side, this is because every time to be able to read and choose you need to widen the entire GUI.
Attached Thumbnails
Click image for larger version

Name:	AmiModRadio.jpg
Views:	70
Size:	211.6 KB
ID:	62824  

Last edited by AMIGASYSTEM; 17 April 2019 at 23:59.
AMIGASYSTEM is offline  
Old 21 April 2019, 09:12   #383
designer77
designer77

 
Join Date: Apr 2019
Location: Poland
Posts: 32
hippo the best player
designer77 is offline  
Old 05 June 2019, 23:43   #384
Predseda
Puttymoon inhabitant
Predseda's Avatar
 
Join Date: Mar 2007
Location: The City of Townsville
Age: 41
Posts: 5,363
Neither http nor https download link from the first post work

EDIT: there is a space in URL after the word "latest".
Predseda is offline  
Old 05 June 2019, 23:49   #385
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,004
Download AmiModRadio v0.9994
Download AmiModRadio v0.9994
Download AmiModRadio v0.9994
AMIGASYSTEM is offline  
Old 19 June 2019, 22:05   #386
Predseda
Puttymoon inhabitant
Predseda's Avatar
 
Join Date: Mar 2007
Location: The City of Townsville
Age: 41
Posts: 5,363
Thank you. Downloaded and managed to run, but if I want to play mods, I am getting "Could not really find anything to play" message. My Amiga is online through Miami.

In log there is many messages "could not find known Arexx port of a player", so I probably have to set something somewhere. I Amigaguide docu I see in requieremnts: "A Arexx command-and-control system to gently ask a player to play the modules". Thats probably what is missing.

My favourite player is Eagle.

Could you help me?

EDIT: EaglePlayer must be running first?

Last edited by Predseda; 19 June 2019 at 22:22.
Predseda is offline  
Old 20 June 2019, 05:18   #387
tygre
Returning fan!

tygre's Avatar
 
Join Date: Jan 2011
Location: Montréal, QC, Canada
Posts: 649
Hi Predseda!

Quote:
Originally Posted by Predseda View Post
Thank you. Downloaded and managed to run, but if I want to play mods, I am getting "Could not really find anything to play" message. My Amiga is online through Miami.

In log there is many messages "could not find known Arexx port of a player", so I probably have to set something somewhere. I Amigaguide docu I see in requieremnts: "A Arexx command-and-control system to gently ask a player to play the modules". Thats probably what is missing.

My favourite player is Eagle.

Could you help me?

EDIT: EaglePlayer must be running first?
Sorry for the troubles: please make sure that
  1. RexxMast is running
  2. EaglePlayer (or one of the supported player) is in the path OR EaglePlater (or...) is running
Keep us posted
Cheers!
tygre is offline  
Old 20 June 2019, 09:13   #388
Predseda
Puttymoon inhabitant
Predseda's Avatar
 
Join Date: Mar 2007
Location: The City of Townsville
Age: 41
Posts: 5,363
Thank you for your advices, I will give it another try tonight.

I have a weak Amiga, Blizzard 1230-IV/50MHz and 64MB Fast, so I use the native WB resolution 640x256 / 8 cols. AmiModRadio needs a bigger resolution and more colours, otherwise it looks awful. I would really appreciate if there is a possibility of minimalistic design, like EaglePlayer has.
Attached Thumbnails
Click image for larger version

Name:	20190619_214410.jpg
Views:	50
Size:	424.2 KB
ID:	63518  
Predseda is offline  
Old 20 June 2019, 11:21   #389
daxb
Registered User
 
Join Date: Oct 2009
Location: Germany
Posts: 2,319
There are different sized images in the images directory. You need do choose the smaller ones or draw your own images or rip some from other players like SongPlayer (has a lot of different images). If AmiModRadio is responsible for changing images or MUI prefs I don't know.
daxb is offline  
Old 20 June 2019, 15:27   #390
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,004
Quote:
Originally Posted by daxb View Post
There are different sized images in the images directory. You need do choose the smaller ones or draw your own images or rip some from other players like SongPlayer (has a lot of different images). If AmiModRadio is responsible for changing images or MUI prefs I don't know.
No the different sizes are for different GUI functions, the Play, Pause, Stop etc... keys must always have "same name" and "same extension" (even if the graphic format is different JPG, PNG etc..) and above all must have the size of 40x40, a smaller image will be replicated, a larger image will be cropped.
In my opinion AmiModRadio is more suitable for modern RTG systems, in this case the GUIs will be very nice, see Skin created by me.
Attached Thumbnails
Click image for larger version

Name:	AmiModRadio.jpg
Views:	45
Size:	287.7 KB
ID:	63521  
AMIGASYSTEM is offline  
Old 20 June 2019, 17:45   #391
Predseda
Puttymoon inhabitant
Predseda's Avatar
 
Join Date: Mar 2007
Location: The City of Townsville
Age: 41
Posts: 5,363
Nice, but I just want to manage it running on my setup ;-)

40x40 is way too large.
Predseda is offline  
Old 20 June 2019, 18:10   #392
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,004
Maybe tygre will be able to modify this measure by reducing it (15x15 or 20x20), this could also speed up the GUI on less powerful systems.
AMIGASYSTEM is offline  
Old 20 June 2019, 20:38   #393
Predseda
Puttymoon inhabitant
Predseda's Avatar
 
Join Date: Mar 2007
Location: The City of Townsville
Age: 41
Posts: 5,363
It would be very useful. In a meantime I made AmiModRadio working on my Amiga!



Q: do I need to manually load each new module clicking the button? Or is there an option to automatically download / play a new one, after the previous is finished? I think this must be set on Player side? I use Eagle 1.54 and have SongEnd tagged, but it still repeats the same song until I click Fast Forward button in AmiModRadio window.

Last edited by Predseda; 21 June 2019 at 00:08.
Predseda is offline  
Old 21 June 2019, 01:18   #394
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,004
There are 2 methods to load a new module (see screenshot), one and the "Next" key and the other and the "Play" key after pressing the "Stop" key.

I have no problem to load a new module with the two methods and use HippoPlayer, in my opinion the best choice.

Last edited by AMIGASYSTEM; Yesterday at 22:12.
AMIGASYSTEM is offline  
Old 21 June 2019, 09:19   #395
Predseda
Puttymoon inhabitant
Predseda's Avatar
 
Join Date: Mar 2007
Location: The City of Townsville
Age: 41
Posts: 5,363
Yes, but I want a continuous play module after module, without the need to click for next module to play.

BTW - AmiModRadio works quite well for me with Haxor.fi and acceptable with Aminet mods (a lot of skips because all those .ReadMe files). The rest is problematic and the Polish source results me to this:

Attached Thumbnails
Click image for larger version

Name:	amimod.jpg
Views:	30
Size:	59.0 KB
ID:	63528  
Predseda is offline  
Old 21 June 2019, 10:57   #396
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,004
No this does not happen to me, the module as soon as it finishes is automatically loaded a new Module after being unpacked and sent log.

Even the Log to me is translated into Italian and quite understandable, see my video Test attached

test Play Module And reading Log
AMIGASYSTEM is offline  
Old 21 June 2019, 11:02   #397
Predseda
Puttymoon inhabitant
Predseda's Avatar
 
Join Date: Mar 2007
Location: The City of Townsville
Age: 41
Posts: 5,363
Oh, nice. Maybe it is because of player. You use Hippo, I use Eagle. But even Eagle should be able to work like this.
Predseda is offline  
Old 21 June 2019, 11:11   #398
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,004
I'm not a developer, but it may be that you don't have enough RAM, remember that archives are unpacked and run in RAM
AMIGASYSTEM is offline  
Old 21 June 2019, 11:55   #399
Predseda
Puttymoon inhabitant
Predseda's Avatar
 
Join Date: Mar 2007
Location: The City of Townsville
Age: 41
Posts: 5,363
No, it is not that case. My Amiga is equipped with 64MB fast and while running AMR, there is always 1,5 chip + 60MB fast free. Maybe Tygre will tell me more.
Predseda is offline  
Old 02 July 2019, 17:16   #400
tygre
Returning fan!

tygre's Avatar
 
Join Date: Jan 2011
Location: Montréal, QC, Canada
Posts: 649
Hi Predseda and AMIGASYSTEM!

Hope that you are doing well and my apologies for the delay in replying!

@Predseda sorry for the troubles: did you have a chance to test with HippoPlayer, in case EaglePlayer would be responsible for the strange behaviour?

Yes, I will definitely consider a "lighter" version that does not require so many colours and so much place (#103)

@AMIGASYSTEM, thank you for your help

Cheers!
tygre is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Which games are using modules? 1988 request.Modules 7 29 July 2016 20:24
A few modules Rogue request.Modules 1 31 May 2014 18:22
two modules s2325 request.Modules 4 01 May 2010 15:23
Brain Killer Aminet links changed (and a question about Aminet links) Korodny HOL data problems 0 26 November 2009 21:21
Modules.. Muerto request.Modules 2 15 December 2005 17:32

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 02:24.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.10335 seconds with 14 queries