English Amiga Board


Go Back   English Amiga Board > News

 
 
Thread Tools
Old 22 February 2019, 23:14   #1
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,238
AmiSSL Released




AmiSSL v4.3 OS3/OS4: Download

This is version 4.3 of the AmiSSL library for Amiga based operating systems and the first public open-source based release of AmiSSL. Version 4.x is a new major release which comes with full compatibility to the OpenSSL 1.1.x line which includes important security related fixes and comes with new encryption ciphers which are required nowadays to connect to modern SSL-based services (e.g. HTTPS). However, due to fundamental changes in the API between the old AmiSSLv3 and new v4 versions and the large changes between the old OpenSSL 0.9.x and the new OpenSSL 1.1.x line applications have to be recompiled with the updated AmiSSL SDK to take full advantage of the modernized OpenSSL 1.1.x API. Besides that fundamental change, AmiSSLv4 can be installed on top of a AmiSSLv3 installation while still ensuring that applications compiled for AmiSSLv3 will continue to work properly.


Important Note:

This release comes with binaries for the AmigaOS4/PPC and AmigaOS3/m68k platform only. Unfortunately, due to lack of motivated developers we couldn't provide native binaries for the MorphOS/PPC or AROS (PPC, i386, x86_64) platform in time. If you are, however, interested in seeing AmiSSL v4 being ported for these other Amiga-based platforms, please try to find motivated and talented developers who could join our team as proper maintainers for these alternative platforms. In addition, if you are a MorphOS or AROS developer yourself, feel free to send proper pull requests to see your platform supported in one of the next releases or please consider joining our team.
Attached Thumbnails
Click image for larger version

Name:	AmiSSL.jpg
Views:	1367
Size:	127.4 KB
ID:	62151  
AMIGASYSTEM is offline  
Old 26 February 2019, 18:43   #2
attila06
Zone Friend
 
Join Date: Oct 2006
Location: Nice / France
Posts: 196
Hello,

Does it change anything for the https site ?
Tried with ibrowse, always the same issue (i m not sure to understand everything )
attila06 is offline  
Old 26 February 2019, 19:40   #3
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,238
IBrowser but also AWeb and Voyager could access https site also with old AmiSSL, just do the right thing on Amiga OS, delete everything on your system and do this:

- Install AmiSSL in SYS:Internet/AmiSSL/ (or where do you want)

Add this in User-Startup:
;BEGIN AmiSSL
Assign AmiSSL: "SYS:Internet/AmiSSL"
If Exists AmiSSL:Libs
Assign LIBS: AmiSSL:Libs ADD
EndIf
Path AmiSSL: ADD
;END AmiSSL

- Created the folder "AmiSSL" in "SYS:Prefs/Env-Archive/"
- Run the command "setenv save AmiSSL/SSL_CLIENT_VERSION tls1"
- Done this will be created file "SSL_CLIENT_VERSION" in SYS:Prefs/Env-Archive/AmiSSL/
- File "SSL_CLIENT_VERSION" create inside written file "tls1"

- Verify that file "SSL_CLIENT_VERSION" was saved in SYS:Prefs/Env-Archive/AmiSSL/
- Reboot. It should work.

Last edited by AMIGASYSTEM; 09 March 2019 at 09:44.
AMIGASYSTEM is offline  
Old 26 February 2019, 20:51   #4
Foul
Registered User

Foul's Avatar
 
Join Date: Jun 2009
Location: Perigueux/France
Age: 45
Posts: 1,430
Send a message via ICQ to Foul Send a message via MSN to Foul
can't reach https too !!!

With Snoopdos, i see Aweb is looking for libs:amissl/amisslv097g.library

Would be amisslv111a.library, what's wrong ?
Foul is offline  
Old 26 February 2019, 21:26   #5
attila06
Zone Friend
 
Join Date: Oct 2006
Location: Nice / France
Posts: 196
Ok

Done, works for some site.
but if i want to connect to:
Ibrowse or to amigaimpact.org i have SSL Connect error !!!!

Amigasystem Could you try with these site please.

Thanks.
attila06 is offline  
Old 26 February 2019, 22:12   #6
indigolemon
Bit Copying Bard

indigolemon's Avatar
 
Join Date: Jan 2017
Location: Kelty, Fife, Scotland
Age: 37
Posts: 739
It only works on sites with TLS v1.0 encryption, sites using TLS v1.1 or v1.2 need to use the latest AmiSSL, so have to be compiled using it also.

iBrowse 2.4 is therefore stuck at TLS v1.0 - iBrowse version 2.5, when released, will be compiled against the newer AmiSSL so should work on all sites.
indigolemon is offline  
Old 26 February 2019, 22:17   #7
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,238
Quote:
Originally Posted by Foul View Post
can't reach https too !!!

With Snoopdos, i see Aweb is looking for libs:amissl/amisslv097g.library

Would be amisslv111a.library, what's wrong ?
Yes, you must copy amisslv097g.library in SYS:Internet/AmiSSL/Libs/AmiSSL/

amisslv097g.library is located in AmiSSL-3.6-68k.lha

Last edited by AMIGASYSTEM; 26 February 2019 at 23:47.
AMIGASYSTEM is offline  
Old 26 February 2019, 22:27   #8
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,238
Quote:
Originally Posted by attila06 View Post
Ibrowse or to amigaimpact.org i have SSL Connect error !!!!
Amigasystem Could you try with these site please.
Thanks.
As it says indigolemon not all https sites are supported, you can still easily go on amigaimpact.org with NetSurf by Arti.

Last edited by AMIGASYSTEM; 09 March 2019 at 09:44.
AMIGASYSTEM is offline  
Old 26 February 2019, 22:33   #9
attila06
Zone Friend
 
Join Date: Oct 2006
Location: Nice / France
Posts: 196
Ok, thanks i understand.

But Netsurf is slow even with a 060, hope ibrowse 2.5 will be realised ....soon

Regards.

Last edited by attila06; 26 February 2019 at 22:45.
attila06 is offline  
Old 26 February 2019, 22:44   #10
duga
Registered User
 
Join Date: Nov 2010
Location: Sweden
Posts: 373
Quote:
Originally Posted by indigolemon View Post
It only works on sites with TLS v1.0 encryption, sites using TLS v1.1 or v1.2 need to use the latest AmiSSL, so have to be compiled using it also.

iBrowse 2.4 is therefore stuck at TLS v1.0 - iBrowse version 2.5, when released, will be compiled against the newer AmiSSL so should work on all sites.
Thanks for the clarification.
duga is offline  
Old 26 February 2019, 23:08   #11
Foul
Registered User

Foul's Avatar
 
Join Date: Jun 2009
Location: Perigueux/France
Age: 45
Posts: 1,430
Send a message via ICQ to Foul Send a message via MSN to Foul
Quote:
Originally Posted by AMIGASYSTEM View Post
Yes, you must copy amisslv097g.library in SYS:Internet/AmiSSL/Libs/AmiSSL/

amisslv097g.library is located in AmiSSL-3.6-68k.lha
Yes ! it's working now
Foul is offline  
Old 26 February 2019, 23:11   #12
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,238
Quote:
Originally Posted by attila06 View Post
Ok, thanks i understand.
But Netsurf is slow even with a 060, hope ibrowse 2.5 will be realised ....soon
Regards.
All right, if you want to go upstairs on your own "amigaimpact.org" with iBrowser or aWeb, without waiting iBrowse 2.5 you can do it through "pici.picidae.net"

Last edited by AMIGASYSTEM; 22 April 2019 at 10:57.
AMIGASYSTEM is offline  
Old 26 February 2019, 23:54   #13
attila06
Zone Friend
 
Join Date: Oct 2006
Location: Nice / France
Posts: 196
Yes, you're right.

Already tested with picidae.net, it works.
awaiting ibrowse 2.5
attila06 is offline  
Old 27 February 2019, 10:16   #14
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,238
Okay, I'm happy for you.
AMIGASYSTEM is offline  
Old 27 February 2019, 12:07   #15
Seiya
Registered User

Seiya's Avatar
 
Join Date: Nov 2014
Location: Italy
Posts: 975
Quote:
Originally Posted by AMIGASYSTEM View Post
- Created the folder "AmiSSL" in "SYS:Prefs/Env-Archive/"
- Run the command "setenv save AmiSSL/SSL_CLIENT_VERSION tls1"
- Done this will be created file "SSL_CLIENT_VERSION" in SYS:Prefs/Env-Archive/AmiSSL/
- File "SSL_CLIENT_VERSION" create inside written file "tls1"

- Verify that file "SSL_CLIENT_VERSION" was saved in SYS:Prefs/Env-Archive/AmiSSL/
- Reboot. It should work.
Thank very much. now it works with this guide
Seiya is offline  
Old 27 February 2019, 12:37   #16
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,238
Ok, thank you for successfully testing it
AMIGASYSTEM is offline  
Old 27 February 2019, 13:31   #17
Jope
-
Jope's Avatar
 
Join Date: Jul 2003
Location: Helsinki / Finland
Age: 39
Posts: 7,433
So it's no longer in fashion, that you install each AmiSSL version on top of each other starting from the oldest? :-)

I guess it's faster to install the newest and manually copy the different SSL engines into amissl:libs/amissl
Jope is offline  
Old 27 February 2019, 13:39   #18
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,238
Yes, Amiga is a Stand-Alone OS, you can do everything by installing or simply copying the new one, and if necessary add what you need from the old releases as it happens with AmiSSL; i have always done so in order to better understand the Amiga System.
AMIGASYSTEM is offline  
Old 28 February 2019, 13:04   #19
savior
Registered User

savior's Avatar
 
Join Date: Jan 2019
Location: Italy
Age: 40
Posts: 70
ok all done, i hope who aweb is at moment the best browser for classic amiga, runs very fast, maybe with vampire or 040/060 the best choise is chris netsurf with truetype fonts because support modern css and html 4.01, i attemp full support at javascript not ibrowse 2.5

all best
savior is offline  
Old 04 July 2019, 22:54   #20
Angus
Amiga Games Database
Angus's Avatar
 
Join Date: Jun 2006
Location: South West England
Posts: 626
Guys, I'm confused. I have followed the instructions above (although I had to create the setenv thing manually) and I've also added a few files from earlier versions of AmiSSL. I'm using OS3.1 by the way.


I have it assigned in user-startup, and the path is:


SYS:Internet/AmiSSL



and in there, are the Libs, Certs, Private and Usercerts directories.


In that Libs there is the the AmiSSLmaster.library and another Amissl directory, which has the various library files in it - does that sound correct?


Only when I try to access a site like Gmail, AWeb tells me I need AmiSSL installed. :-/


Any clues? Thanks :-)
Angus is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
AmiSSL 4 Robbie support.Apps 53 08 December 2018 01:25
AmiSSL 4.0 Sir_Lucas News 6 09 February 2017 13:45
new AmiSSL hal9000 support.Apps 1 14 August 2016 19:23
16.6 Released alexh project.WHDLoad 6 09 June 2006 11:02
AmiSSL v2 and AWEB with OS3.9?? BarrySWE support.Apps 7 12 November 2005 03:04

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 13:27.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.11322 seconds with 16 queries