English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 11 November 2017, 12:29   #1
Sephnroth
Registered User

 
Join Date: Oct 2014
Location: England
Posts: 77
PS/2 Compliant usb mice for Jerry adaptor?

Is there any way to tell if a mouse is PS/2 compliant, or a list of mice known to work well with the Jerry adaptor?

Sadly I did not even know Tom adaptors existed when I bought my Jerry!

My jerry arrived yesterday and I have it plugged into the 1200, I had a couple of old mice hanging around that I figured would be old enough to support ps/2 but it doesn't like either of them. One the LED just constantly flashes for and the other the LED goes solid for like 2 secs, then does a few flashes, then solid for 2 secs.. repeat. But neither work.

Disappointing!
Sephnroth is offline  
Old 11 November 2017, 12:40   #2
gazj82
Registered User

gazj82's Avatar
 
Join Date: Jan 2014
Location: Cambs / UK
Posts: 349
I think if you buy a Microsoft mouse you should be ok. That is what I have hooked up to me Jerry+ adapter. Mine is just the cheapest Microsoft mouse that was at PC World.

Here we go

https://www.ebuyer.com/281935-micros...ness-4yh-00007

One of the reviews even said it comes with a PS2 adaptor so you should be good to go. It is exactly the same model as mine by the way.

Last edited by DH; 11 November 2017 at 14:13. Reason: Back to back posts
gazj82 is offline  
Old 11 November 2017, 12:56   #3
Sephnroth
Registered User

 
Join Date: Oct 2014
Location: England
Posts: 77
Quote:
Originally Posted by gazj82 View Post
Here we go

https://www.ebuyer.com/281935-micros...ness-4yh-00007

One of the reviews even said it comes with a PS2 adaptor so you should be good to go. It is exactly the same model as mine by the way.
Now that's interesting, because that is one of the mice I tested with! Infact it was the mouse that the adaptor seemed to detect but complain about (kept having a solid light for 2 secs, then flashing, then solid, etc)

On the back of the mouse it says Microsoft Basic Optical Mouse 1.0A - would you mind letting me know if yours is the same? It says it on the back at the bottom in small text.

I wish all hardware came with an error codes list, I bet solid-blink-solid is a REALLY specific error.
Sephnroth is offline  
Old 11 November 2017, 13:03   #4
gazj82
Registered User

gazj82's Avatar
 
Join Date: Jan 2014
Location: Cambs / UK
Posts: 349
That is interesting. My details on the bottom of my mouse are as follows.

Microsoft Basic Optical Mouse v2.0
USB/PS2 Compatible
5v 100mA
Model 1113

If anything you would think with mine being the newer version would be the most likely to drop PS2 support if anything.
gazj82 is offline  
Old 11 November 2017, 13:11   #5
Sephnroth
Registered User

 
Join Date: Oct 2014
Location: England
Posts: 77
Mine doesnt actually mention ps2 compatible anywhere what a weird thing. Time to hunt through more boxes to see what I can find! I've had so much trouble with the mouse on this machine I'm becoming a little exasperated.. I bought jerry after having 3 other mice just flat out fail. Tank mouse the button switches stopped operating right.. old logic3 speedmouse stopped being able to move pointer vertically despite taking apart and cleaning etc.. wife bought my a amiga compat typhoon wireless optical mouse thing which.. simply never worked and the seller would never contact us back. Thought shove it, I'm getting a jerry, I keep seeing them in youtube videos.

Now this XD

eh the problem is going deeper than thought I think... I just found a technical specifications PDF for the mouse ( http://download.microsoft.com/downlo...(SB)_0604A.pdf ) that claims the 1.0A is infact ps/2 compat. I have just plugged mouse into my PC and using it now and the mouse seems fine - there may be a problem with the amiga not related to the mouse -_-

Does the Jerry + optical mouse pull additional power from the joystick port? I'm wondering if my stock A1200 PSU is no longer enough

Last edited by DH; 11 November 2017 at 14:11. Reason: Back to back posts
Sephnroth is offline  
Old 11 November 2017, 13:45   #6
gazj82
Registered User

gazj82's Avatar
 
Join Date: Jan 2014
Location: Cambs / UK
Posts: 349
Well I am using a Stock A1200 power supply. I also have a 030 55mhz accelerator, a CF Hard drive and an external floppy drive installed. So I don't think you will have a power problem.

Is yours a Jerry+ with a joystick port also. Does the joystick port work?
gazj82 is offline  
Old 11 November 2017, 13:58   #7
Sephnroth
Registered User

 
Join Date: Oct 2014
Location: England
Posts: 77
It's not a +, just the standard jerry sadly! If it's not power and the mouse is ps/2 compat then I am kinda confused. It DOES detect it - if I pull the USB out then the LED is flashing constantly, when I plug it in I get periods of solid and then some flashes - though I dont see a pattern in the amount of flashes I get
Sephnroth is offline  
Old 11 November 2017, 14:03   #8
gazj82
Registered User

gazj82's Avatar
 
Join Date: Jan 2014
Location: Cambs / UK
Posts: 349
Well yours behaves exactly as mine does with the mouse plugged in and out of the machine.

With it plugged in, If I count between pulses it usually goes off when I get to 3.

Maybe there is something wrong with your actual mouse / joystick port?

It might explain why you have so much bad luck with mice, it might not be the mice at all.

If you have any 2 player games you could see if a joystick works in the same port.

You maybe should check inside the machine and make sure the socket is plugged into the motherboard properly. The mouse point is not directly mounted on the board like the joystick for some reason on A1200's

Last edited by DH; 11 November 2017 at 14:12. Reason: Back to back posts
gazj82 is offline  
Old 11 November 2017, 14:12   #9
Sephnroth
Registered User

 
Join Date: Oct 2014
Location: England
Posts: 77
okay, I will report back in a little bit. Yesterday I gave the final coat of paint to an custom amiga case I was working on so this is a good excuse to dismantle the 1200 completely, make sure everything is clean, have a good inspection and put into new case when I'm done.

Time to get a cup of tea!
Sephnroth is offline  
Old 11 November 2017, 14:21   #10
gazj82
Registered User

gazj82's Avatar
 
Join Date: Jan 2014
Location: Cambs / UK
Posts: 349
Quote:
Originally Posted by Sephnroth View Post
okay, I will report back in a little bit. Yesterday I gave the final coat of paint to an custom amiga case I was working on so this is a good excuse to dismantle the 1200 completely, make sure everything is clean, have a good inspection and put into new case when I'm done.

Time to get a cup of tea!
It's always time to get a cup of tea!
gazj82 is offline  
Old 11 November 2017, 18:30   #11
Sephnroth
Registered User

 
Join Date: Oct 2014
Location: England
Posts: 77
Well! It's been a pleasant enough day giving the old girl a good clean, sorting out a few niggles and transplanting her to the custom case I made.

Sadly the two major things I wanted to achieve I've so far still failed at

1) see if i could get the floppy drive working (hasnt since I bought it - did not expect it to but wanted to have a go after some youtube fixes I saw!)

2) get the Jerry working. It still, after everything, does not like my mice I can see no issues whatsoever on the board. I even got a magnifier out and followed the traces from the ports on the bottom to see if any breaks but not that I spotted.

Maybe my mouse is duff in some way relating to it's ps/2 compat but not the USB (works fine in pc usb port) - I really do not know :/ Need to find more mice to test.

If anyone has any other ideas I'm all ears!

Still, WELL happy with the new case - when my phenomena SE keycaps from the kickstarter arrive it will look schwingggggggggggg

Attached Thumbnails
Click image for larger version

Name:	daves case.jpg
Views:	373
Size:	264.9 KB
ID:	55372  
Sephnroth is offline  
Old 12 November 2017, 00:06   #12
gazj82
Registered User

gazj82's Avatar
 
Join Date: Jan 2014
Location: Cambs / UK
Posts: 349
See this thread on Lemon Amiga

http://www.lemonamiga.com/forum/view...4eeda69829e3eb

It refers to the Amiga 2000 and I don't know how much is relevent to the A1200. But the symptons are the same as yours, no floppy or mouse.


Case looks awesome by the way.

Last edited by gazj82; 12 November 2017 at 00:18.
gazj82 is offline  
Old 12 November 2017, 05:12   #13
ptyerman
Registered User

ptyerman's Avatar
 
Join Date: Jun 2012
Location: Worksop/UK
Age: 55
Posts: 1,262
Sounds like a possible CIA problem. Check the chip connections and if possible swap for a known good one to test.
ptyerman is offline  
Old 12 November 2017, 10:48   #14
Sephnroth
Registered User

 
Join Date: Oct 2014
Location: England
Posts: 77
I will investigate further and I will read that link in a bit gaz (sorry I just woke up!) but I'm not 100% convinced it's that kind of problem. The floppy drive hasnt worked since I bought the amiga, its one of the reasons I got it cheap - but I suspected it was the drive at fault.

The first thing I did to this was install a gotek drive and it worked -perfectly- and I used it for the best part of a year. I removed the gotek drive and sold it in a bundle with my A500 when I finally got a network card for my 1200 because I use a network share to move files around now instead of the floppy emulator But that used the same interface and powerline as a normal floppy and it was fine.

Joysticks do work in port 2 fine - me and a friend have had many a good game of pang on this machine! And I can use mice - but the button switches are failing on the original tank (but movement is fine) and with the other mouse buttons are fine but vertical movement up is tricky (horizontal movement is fine thou!) - it really *feels* like a hardware problem in all cases rather than an amiga problem.

But that does not mean its not an amiga problem!
Sephnroth is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Adapter for using the latest USB gaming mice and wireless gamepads £14.99. Mounty MarketPlace 13 02 May 2015 21:32
New Amiga USB mouse and Joystick adapter JERRY+. Really cool! PawelB MarketPlace 0 10 March 2015 12:14
A1200 - Micromys and USB mice(s) NovaCoder support.Hardware 3 23 October 2012 20:10
USB Keyboard on A1200 Tower Using PS/2 to USB Adaptor? roberthazelby support.Hardware 3 15 October 2010 22:57
PCMCIA to USB adaptor? Fingerlickin_B support.Hardware 5 02 August 2008 15:52

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 08:54.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.08076 seconds with 14 queries