English Amiga Board


Go Back   English Amiga Board > Coders > Coders. General

 
 
Thread Tools
Old 04 July 2015, 13:58   #1
ciVic
Registered User

 
Join Date: Oct 2013
Location: Germany
Posts: 30
building libcurl

Hi all,

I'm trying to compile curl (libcurl) on Amiga OS 3 as explained here:

http://curl.haxx.se/docs/install.html

However, compilation fails:

CURL_SIZEOF_LONG definition is missing

I see a lot of similar errors and a search within the curl directory does not show any definition of these values for Amiga. Any hints?
ciVic is offline  
Old 04 July 2015, 14:51   #2
thomas
Registered User
thomas's Avatar
 
Join Date: Jan 2002
Location: Germany
Posts: 5,948
Probably you have to run configure first.
thomas is offline  
Old 07 July 2015, 08:57   #3
ciVic
Registered User

 
Join Date: Oct 2013
Location: Germany
Posts: 30
At least this changed my problem. Now I can compile it by typing "make" but then I have a version with ixemul. Compiling using make -f makefile.amiga leads to

Quote:
geek@miggy:/work/curl-7.43.0/lib$ make -f makefile.amiga
gcc -I/Work/AmiTCP-SDK-4.3/netinclude -m68020-60 -O2 -msoft-float -noixemul -
g -I. -I../include -W -Wall -c -o file.o file.c
In file included from /Work/AmiTCP-SDK-4.3/netinclude/sys/types.h:23,
from ../include/curl/curlbuild.h:131,
from curl_setup.h:132,
from file.c:23:
/Work/AmiTCP-SDK-4.3/netinclude/amitcp/types.h:38: string constants not allow
ed in #if expressions
In file included from /gg/include/wchar.h:13,
from /gg/include/stdint.h:666,
from ../include/curl/curlbuild.h:138,
from curl_setup.h:132,
from file.c:23:
/Work/AmiTCP-SDK-4.3/netinclude/stdio.h:13: include:stdio.h: Device not confi
gured
ciVic is offline  
Old 08 July 2015, 11:51   #4
arti
Registered User

 
Join Date: Jul 2008
Location: Poland
Posts: 560
Maybe you have to assign "include:" as "/Work/AmiTCP-SDK-4.3/netinclude/".

Last edited by arti; 08 July 2015 at 11:52. Reason: typo
arti is offline  
Old 08 July 2015, 20:07   #5
thomas
Registered User
thomas's Avatar
 
Join Date: Jan 2002
Location: Germany
Posts: 5,948
No, this is exactly the wrong way to do it.

AmiTCP expects include: to point to the compiler's include directory. If you let it point to AmiTCP's directory, you create a loop.

IMHO AmiTCP SDK is ugly. I prefer Miami SDK.
thomas is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Building a PLIPbox ajack Hardware mods 12 15 September 2016 13:30
Libcurl for libnix arti Coders. C/C++ 0 29 June 2013 18:51
Building WinUAE 2.0.1 Mequa support.WinUAE 11 29 March 2010 23:25
help building whdload packages petee1979 project.WHDLoad 4 25 May 2009 10:29
Building me a new Amiga StarEye support.Hardware 12 02 April 2008 20:01

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 00:10.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.06529 seconds with 15 queries