English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 23 December 2004, 19:43   #1
ghost
 
Posts: n/a
WinUAE V0.9.92 crash with lzx

If i use lzx to extract some files from matrix.lzx, Winuae will crash ( Application error on WinXP).
It only crashes if the destination is on dhx. Destination on ram: works.
lzx e Temp:MatrixV1_9.lzx Matrix/matrix.info dh0:test/

Another problem:
I can not delete directories on DHx with this version of winuae.
Dos error: function isn't implemented.
This works with Ram Disk, too.


matrix.lzx (http://off.free.fr/matrix/Matrix.lzx) Matrix screen blanker
LZX 1.21 (Registered) Archive/Extract utility - 68020/68030 Version

winuaebootlog:
WinUAE 0.9.92 (NT 5.1 Service Pack 2 Admin)
(c) 1995-2001 Bernd Schmidt - Core UAE concept and implementation.
(c) 1998-2004 Toni Wilen - Win32 port, core code updates.
(c) 1996-2001 Brian King - Win32 port, Picasso96 RTG, and GUI.
(c) 1996-1999 Mathias Ortmann - Win32 port and bsdsocket support.
(c) 2000-2001 Bernd Meyer - JIT engine.
(c) 2000-2001 Bernd Roesch - MIDI input, many fixes.
Press F12 to show the Settings Dialog (GUI), Alt-F4 to quit.
End+F1 changes floppy 0, End+F2 changes floppy 1, etc.
CLOCKFREQ: QPF 2798.70MHz
CLOCKFREQ: RDTSC 2797.86MHz (busy) / 2798.68MHz (idle)
CLOCKFREQ: Using QPF (QPF ~>= RDTSC)
Testing MM-timer resolution:
1.89ms 1.92ms 0.01ms 1.91ms 1.94ms
Testing Sleep() resolution:
8.26ms 15.60ms 15.60ms 15.58ms 15.61ms
Using MultiMedia timers (resolution < 2.5ms)
Translation DLL 'D:\Amiga Emulator\Emulation\WinUAE\WinUAE_German.dll' loaded and enabled
Enumerating display devices..
'Primärer Anzeigetreiber' 'display' NULL
Sorting devices and modes..
W=1024 H=768 B=32
0: 320x200, 8-bit (75,60,70,72)
1: 320x200, 16-bit (60,70,72,75)
2: 320x200, 32-bit (60,70,72,75)
3: 320x240, 8-bit (60,70,72,75)
4: 320x240, 16-bit (60,70,72,75)
5: 320x240, 32-bit (60,70,72,75)
6: 400x300, 8-bit (60,70,72,75)
7: 400x300, 16-bit (60,70,72,75)
8: 400x300, 32-bit (60,70,72,75)
9: 480x360, 8-bit (60,70,72,75)
10: 480x360, 16-bit (60,70,72,75)
11: 480x360, 32-bit (60,70,72,75)
12: 512x384, 8-bit (60,70,72,75)
13: 512x384, 16-bit (60,70,72,75)
14: 512x384, 32-bit (60,70,72,75)
15: 640x400, 8-bit (60,70,72,75)
16: 640x400, 16-bit (60,70,72,75)
17: 640x400, 32-bit (60,70,72,75)
18: 640x480, 8-bit (60,70,72,75,85,100,120)
19: 640x480, 16-bit (60,70,72,75,85,100,120)
20: 640x480, 32-bit (60,70,72,75,85,100,120)
21: 720x480, 8-bit (60)
22: 720x480, 16-bit (60)
23: 720x480, 32-bit (60)
24: 720x576, 8-bit (60)
25: 720x576, 16-bit (60)
26: 720x576, 32-bit (60)
27: 800x600, 8-bit (60,70,72,75,85,100,120,56)
28: 800x600, 16-bit (60,70,72,75,85,100,120,56)
29: 800x600, 32-bit (60,70,72,75,85,100,120,56)
30: 848x480, 8-bit (60,70,72,75,85,100,120)
31: 848x480, 16-bit (60,70,72,75,85,100,120)
32: 848x480, 32-bit (60,70,72,75,85,100,120)
33: 960x600, 8-bit (60,70,72,75,85,100,120)
34: 960x600, 16-bit (60,70,72,75,85,100,120)
35: 960x600, 32-bit (60,70,72,75,85,100,120)
36: 1024x768, 8-bit (60,70,72,75,85,100,120)
37: 1024x768, 16-bit (60,70,72,75,85,100,120)
38: 1024x768, 32-bit (60,70,72,75,85,100,120)
39: 1152x864, 8-bit (60,70,72,75,85,100)
40: 1152x864, 16-bit (60,70,72,75,85,100)
41: 1152x864, 32-bit (60,70,72,75,85,100)
42: 1280x720, 8-bit (60,70,72,75,85,100,120)
43: 1280x720, 16-bit (60,70,72,75,85,100,120)
44: 1280x720, 32-bit (60,70,72,75,85,100,120)
45: 1280x768, 8-bit (60,70,72,75,85,100,120)
46: 1280x768, 16-bit (60,70,72,75,85,100,120)
47: 1280x768, 32-bit (60,70,72,75,85,100,120)
48: 1280x800, 8-bit (60,70,72,75,85,100,120)
49: 1280x800, 16-bit (60,70,72,75,85,100,120)
50: 1280x800, 32-bit (60,70,72,75,85,100,120)
51: 1280x960, 8-bit (60,70,72,75,85,100)
52: 1280x960, 16-bit (60,70,72,75,85,100)
53: 1280x960, 32-bit (60,70,72,75,85,100)
54: 1280x1024, 8-bit (60,70,72,75,85)
55: 1280x1024, 16-bit (60,70,72,75,85)
56: 1280x1024, 32-bit (60,70,72,75,85)
57: 1360x768, 8-bit (60,70,72,75,85,100,120)
58: 1360x768, 16-bit (60,70,72,75,85,100,120)
59: 1360x768, 32-bit (60,70,72,75,85,100,120)
60: 1600x900, 8-bit (60,70,72,75,85,100)
61: 1600x900, 16-bit (60,70,72,75,85,100)
62: 1600x900, 32-bit (60,70,72,75,85,100)
63: 1600x1024, 8-bit (60,70,72,75,85)
64: 1600x1024, 16-bit (60,70,72,75,85)
65: 1600x1024, 32-bit (60,70,72,75,85)
66: 1600x1200, 8-bit (60,70,72,75)
67: 1600x1200, 16-bit (60,70,72,75)
68: 1600x1200, 32-bit (60,70,72,75)
'Primärer Anzeigetreiber', 69 display modes (enabled)
done
PARAPORT: no ParaPort.dll, direct parallel port emulation disabled
GUID=6F1D2B60-0000D5A0-000011CF-BFC7444553540000:
'Maus' 'Maus' 00000112 (Mouse)
GUID=6F1D2B61-0000D5A0-000011CF-BFC7444553540000:
'Tastatur' 'Tastatur' 00000413 (Keyboard)
GUID=48A965B0-00000121-000011D9-8001444553540000:
'Thrustmaster FireStorm(TM) Wireless Gamepad (USB)' 'Thrustmaster FireStorm(TM) Wireless Gamepad (USB)' 00010214 (Game controller)
GUID=48ABAFA0-00000121-000011D9-8003444553540000:
'SideWinder Game Voice' 'SideWinder Game Voice' 00010419 (Unknown)
RAWINPUT: found 6 devices
Thrustmaster FireStorm(TM) Wireless Gamepad (USB) (GUID=48A965B0-00000121-000011D9-8001444553540000):
00 000 'X-Achse' (-99,0)
04 004 'Y-Achse' (-98,0)
14 020 'Z-Rotation' (-87,0)
18 024 'Schieberegler' (-79,0)
20 032 'Mehrwegeschalter (2)' (-69,1)
20 032 'Mehrwegeschalter (1)' (-69,1)
Thrustmaster FireStorm(TM) Wireless Gamepad (USB) (GUID=48A965B0-00000121-000011D9-8001444553540000):
30 048 'Taste 0' (48,-1)
31 049 'Taste 1' (49,-1)
32 050 'Taste 2' (50,-1)
33 051 'Taste 3' (51,-1)
34 052 'Taste 4' (52,-1)
35 053 'Taste 5' (53,-1)
36 054 'Taste 6' (54,-1)
37 055 'Taste 7' (55,-1)
38 056 'Taste 8' (56,-1)
39 057 'Taste 9' (57,-1)
3A 058 'Taste 10' (58,-1)
3B 059 'Taste 11' (59,-1)
Maus * (GUID=6F1D2B60-0000D5A0-000011CF-BFC7444553540000):
00 000 'X-Achse' (-99,0)
04 004 'Y-Achse' (-98,0)
08 008 'Lenkrad' (-97,0)
Maus * (GUID=6F1D2B60-0000D5A0-000011CF-BFC7444553540000):
0C 012 'Taste 0' (12,-1)
0D 013 'Taste 1' (13,-1)
0E 014 'Taste 2' (14,-1)
0F 015 'Taste 3' (15,-1)
10 016 'Taste 4' (16,-1)
Tastatur * (GUID=6F1D2B61-0000D5A0-000011CF-BFC7444553540000):
01 001 'ESC' (0,-1)
02 002 '1' (0,-1)
03 003 '2' (0,-1)
04 004 '3' (0,-1)
05 005 '4' (0,-1)
06 006 '5' (0,-1)
07 007 '6' (0,-1)
08 008 '7' (0,-1)
09 009 '8' (0,-1)
0A 010 '9' (0,-1)
0B 011 '0' (0,-1)
0C 012 'ß' (0,-1)
0D 013 'AKUT' (0,-1)
0E 014 'RÜCK' (0,-1)
0F 015 'TABULATOR' (0,-1)
10 016 'Q' (0,-1)
11 017 'W' (0,-1)
12 018 'E' (0,-1)
13 019 'R' (0,-1)
14 020 'T' (0,-1)
15 021 'Z' (0,-1)
16 022 'U' (0,-1)
17 023 'I' (0,-1)
18 024 'O' (0,-1)
19 025 'P' (0,-1)
1A 026 'ü' (0,-1)
1B 027 '+' (0,-1)
....
NATMEM: Our special area is 0x12000000
shmget of size 65536 for rtarea
load config 'D:\Amiga Emulator\Emulation\WinUAE\Configurations\default.uae':0
Volume D:\ FS=NTFS maxlen=255 flags=000700FF
Volume D:\ FS=NTFS maxlen=255 flags=000700FF
Volume D:\ FS=NTFS maxlen=255 flags=000700FF
Volume D:\ FS=NTFS maxlen=255 flags=000700FF
Volume D:\ FS=NTFS maxlen=255 flags=000700FF
load config 'D:\Amiga Emulator\Emulation\WinUAE\Configurations\Sabrina 020.uae':0
Volume D:\ FS=NTFS maxlen=255 flags=000700FF
Volume D:\ FS=NTFS maxlen=255 flags=000700FF
Volume D:\ FS=NTFS maxlen=255 flags=000700FF
Volume D:\ FS=NTFS maxlen=255 flags=000700FF
Volume D:\ FS=NTFS maxlen=255 flags=000700FF

Last edited by ghost; 24 December 2004 at 16:34. Reason: False Version in the threadtitel
 
AdSense AdSense  
Old 23 December 2004, 21:20   #2
thomas
Registered User
thomas's Avatar
 
Join Date: Jan 2002
Location: Germany
Posts: 4,604
I just tried it with both an NTFS and a FAT32 system and it worked without problems. Are you sure you use the correct processor version of LZX ?
thomas is offline  
Old 24 December 2004, 17:53   #3
ghost
 
Posts: n/a
I'm using OS 3.9 with Dopus Magellan 2 (V5.82), processor is 68020+FPU.

if I start from workbench 3.1 diskette, the errors don't occur any more at the access to the hard disk.

With Amiga Forever V6 both errors occur on drive system: and work:, but
with other mounted directories it will work !
I have copied the content from drive system: to a empty mounted directory.
I can delete directories from the new location till i boot from this new directory.
It seems to be both errors (delete and lzx) depends from each other.
If i can't delete directories on the drive then i can't extract lzx on it without a crash
by WinUAE.

I don't know any more.

Last edited by ghost; 27 December 2004 at 13:02.
 
Old 27 December 2004, 14:05   #4
ghost
 
Posts: n/a
I have copied all files from the mounted directories to hardfiles.
The Error doesn' t occur with real partitions nor hardfiles. The behaviour is exactly the same on my second computer (WinXP SP2, P4 3Ghz HT, 1GB Ram).

2.
I have increased the fastram (Z3-Ram) while the emulator is running, after rebooting the amiga system Winuae crashes and writes a dumpfile to the disc.
 
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
WinUAE random crash bippym support.WinUAE 7 19 March 2013 20:54
Winuae 2.0.1 crash Heula support.WinUAE 7 03 January 2010 10:43
another WinUAE 1.5.1 crash jharrison support.WinUAE 4 04 September 2008 16:53
Winuae 1.5.1 - Crash Detected illy5603 support.WinUAE 17 17 August 2008 02:25
WinUAE 08.17 r1 -r3 W98 crash Car support.WinUAE 2 07 December 2001 10:13

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 23:13.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Page generated in 0.11707 seconds with 11 queries