English Amiga Board


Go Back   English Amiga Board > Support > support.Apps

 
 
Thread Tools
Old 21 February 2019, 09:29   #221
Pyromania
Moderator

Pyromania's Avatar
 
Join Date: Jan 2002
Location: Chicago, IL
Posts: 2,066
Thanks for sharing Muadib, you are right, pgovotsos and emufan are awesome. Hopefully they start posting and interacting again on EAB.
Pyromania is offline  
Old 21 February 2019, 18:32   #222
Feo
Registered User

 
Join Date: Feb 2019
Location: Los Angeles, CA
Posts: 8
Thanks guys!
Still struggling getting a Raspberry Pi emulator going. I finally have an HD configured, don't know how to get my programs to it yet. Working on figuring that out next.
Muadib, I am interested on contributing to your site. I was an advanced 3d user at one time. I think I may have some images (at least), maybe some 3d objects. I do have a ton of 3d content on an Amiga 3000 at my garage but can't get it to boot plus I think the floppy is broken. I saw I also have the 3d Scanner Impulse released next to it. Can't remember if I used that on an Amiga, I think I may have.
Feo is offline  
Old 21 February 2019, 18:48   #223
midwan
Registered User

 
Join Date: Dec 2014
Location: Gothenburg
Posts: 67
Quote:
Originally Posted by Feo View Post
Thanks guys!
Still struggling getting a Raspberry Pi emulator going. I finally have an HD configured, don't know how to get my programs to it yet. Working on figuring that out next.
Muadib, I am interested on contributing to your site. I was an advanced 3d user at one time. I think I may have some images (at least), maybe some 3d objects. I do have a ton of 3d content on an Amiga 3000 at my garage but can't get it to boot plus I think the floppy is broken. I saw I also have the 3d Scanner Impulse released next to it. Can't remember if I used that on an Amiga, I think I may have.
Feel free to reach out if you need help with Amiga emulation on the RPI.
As the author of Amiberry, I might be able to help resolve any issues you have...
midwan is offline  
Old 21 February 2019, 19:16   #224
Feo
Registered User

 
Join Date: Feb 2019
Location: Los Angeles, CA
Posts: 8
THANKS!
First question...
Am I at the right place to start asking questions? or is there a preferred area/forum?
Regarding AmiBerry:
I created a HD file, but when I go into the emulator, that setting (hd drive) does not seem to stick, I always have to re-assign it before I start the emulator. Everything else gets saved right. Did I miss a step somewhere?
Also, now that I have a workbench. How do I get external files to it? for example, I have a folder structure with an Amiga version of the application I want to use on my Mac. I would like to transfer that directory structure to a folder on the hard drive I set up. But don't know how to do it. I have been doing Google searches but I think the words I am using are too generic, I am not coming up with the right results 'amiberry load files to hd'.
Feo is offline  
Old 21 February 2019, 19:27   #225
midwan
Registered User

 
Join Date: Dec 2014
Location: Gothenburg
Posts: 67
Quote:
Originally Posted by Feo View Post
THANKS!
First question...
Am I at the right place to start asking questions? or is there a preferred area/forum?
Regarding AmiBerry:
I created a HD file, but when I go into the emulator, that setting (hd drive) does not seem to stick, I always have to re-assign it before I start the emulator. Everything else gets saved right. Did I miss a step somewhere?
Also, now that I have a workbench. How do I get external files to it? for example, I have a folder structure with an Amiga version of the application I want to use on my Mac. I would like to transfer that directory structure to a folder on the hard drive I set up. But don't know how to do it. I have been doing Google searches but I think the words I am using are too generic, I am not coming up with the right results 'amiberry load files to hd'.
I wouldn't want to hijack this thread, and other people might not be interested in getting notifications for updates when it's something irrelevant to this subject, so I'd suggest we take it in one of the other platforms (choose what you prefer):

- Discord channel: https://discord.gg/3J6wPb
- Facebook page: https://www.facebook.com/amiberry.emulator
- MeWe page: https://mewe.com/p/amiberry
- Github Issues: https://github.com/midwan/amiberry/issues
midwan is offline  
Old 21 February 2019, 20:20   #226
Muadib
Registered User

Muadib's Avatar
 
Join Date: Dec 2014
Location: Stockholm/Sweden
Posts: 236
Quote:
Originally Posted by midwan View Post
I wouldn't want to hijack this thread, and other people might not be interested in getting notifications for updates when it's something irrelevant to this subject, so I'd suggest we take it in one of the other platforms (choose what you prefer):



- Discord channel: https://discord.gg/3J6wPb

- Facebook page: https://www.facebook.com/amiberry.emulator

- MeWe page: https://mewe.com/p/amiberry

- Github Issues: https://github.com/midwan/amiberry/issues
And as for Amiga 3D stuff, you can always either upload here and/or Amigaraytracers.com.

There are also a lot people fixing Amigas nowadays, so asking either here or in FB groups like 'Commodore Amiga' you can find help with ease!

muadib
Amiga Raytracing Society
Muadib is offline  
Old 22 February 2019, 12:35   #227
d4rk3lf
Registered User

d4rk3lf's Avatar
 
Join Date: Jul 2015
Location: Novi Sad, Serbia
Posts: 428
Quote:
Originally Posted by Feo View Post
I do have a ton of 3d content on an Amiga 3000 at my garage but can't get it to boot plus I think the floppy is broken.
I think you should really try and fix this. It would be unfortunate that you get your interest back in the Amiga, and still, having one at dying condition in your garage.
Lot's of people here are expert in this stuff, and all you need is to take a few pictures of the problem, and try to fix it. It shouldn't require too much time, and it should be fun time restoring.
After all, I'd like to see your old work on 3D, that is buried inside that A3000.

Of course, I am not saying you should left your rospery Pi setup. Just saying it's better having both stuff to play, then one.
d4rk3lf is offline  
Old 22 February 2019, 12:55   #228
Muadib
Registered User

Muadib's Avatar
 
Join Date: Dec 2014
Location: Stockholm/Sweden
Posts: 236
What d4rk3lf said!

And as I ve heard, although I havent been fortunate as of yet to own one, the A3000 is considered by many as the best Amiga ever!

And who knows, maybe in the not-so-far future one may be able to send jobs from his Amiga and LW to his R-Pi for rendering, eh MidWan?

muadib
Amiga Raytracing Society
Muadib is offline  
Old 22 February 2019, 16:28   #229
Feo
Registered User

 
Join Date: Feb 2019
Location: Los Angeles, CA
Posts: 8
I do want to eventually fix it. I am also very interested on what is on it. I can't even remember when exactly I put it away. It must have been around 97/98. As I went to look for it I found a small notebook on the same box. It had a storyboard for a commercial I drew for 7up. Can't remember doing that. I must have done it few years later, not sure how it ended up there but I thought it could also make another interesting project to get up to speed with 3d again. Right now I want to get the Pi going because the size of the unit, plus the fact that I can quickly switch cables to get it going is very appealing. Does not need much space! I made some more progress last night. I think I know how to get external files loaded. I am formatting an SD card right now. Yesterday I could not do it as my Mac does not have a card reader. Today I am hoping to make even more progress. :-)
Feo is offline  
Old 23 February 2019, 10:39   #230
Muadib
Registered User

Muadib's Avatar
 
Join Date: Dec 2014
Location: Stockholm/Sweden
Posts: 236
@Feo Good luck with the procedure. If you want to backup the Amiga's hard disk, one way is to connect it to a Linux box that can mount Amiga Filesystems such as FFS.

To my knowledge, all distros have such support and if not, google can provide with info on how to do this.

I imagine you can, for example, use the R-Pi for this, although you would need an IDE -> USB docking station.

muadib
Amiga Raytracing Society
amigaraytracers.com
Muadib is offline  
Old 25 June 2019, 18:29   #231
Feo
Registered User

 
Join Date: Feb 2019
Location: Los Angeles, CA
Posts: 8
Howdy guys...
I am still trying to get that Amiga on a Pi going. I have made progress, I have a booting Amiga and I can launch LW. The current roadblock is that when the LW starts, I believe as an Amiga high-res interlaces screen, the screen is chopped top and bottom a bit, and it flickers a bit too much. Not sure what to do next, but still trying. I will keep googl-ing for a fix.
Question... what was the last LightWave Amiga version?
Feo is offline  
Old 25 June 2019, 18:57   #232
Muadib
Registered User

Muadib's Avatar
 
Join Date: Dec 2014
Location: Stockholm/Sweden
Posts: 236
Hi Feo,

Congrats on your progress!!
First, the latest version was 5.0r, try looking for it on the EAB ftp server.

Now, as for the screen chopping problem, I really dont know.
What emulator are you using, Amiberry?

muadib
Amiga Raytracing Society
amigaraytracers.com
Muadib is offline  
Old 25 June 2019, 19:54   #233
midwan
Registered User

 
Join Date: Dec 2014
Location: Gothenburg
Posts: 67
@Feo
If you're using Amiberry, these issues are easily fixed:
- Increase the Width and Height of the emulation screen (in the Display Panel), to maximum. That will show the Overscan resolutions properly (which Lightwave uses) without cut-off.
- Enable Line Doubling to eliminate the interlace flicker, but at the cost of reduced performance (as this has to draw double the amount of lines, it will slow down the emulation somewhat). I recommend using Line Doubling while working on a project (e.g. modelling, setting up a scene) and disabling it when you're about to Render a scene, to maximize performance when it matters the most.

Additionally, you can enable "Frameskip" when rendering, to gain some extra performance out of it, as it will draw only every second frame on-screen. ;-)
midwan is offline  
Old 26 June 2019, 19:29   #234
Feo
Registered User

 
Join Date: Feb 2019
Location: Los Angeles, CA
Posts: 8
Thanks midwan!
That did it!!!
I think I am almost in business again :-)
I have LW 3.5, will try installing 5 today. I think that had support for AGA.
Looks like I may be able to start modelling this weekend :-)
Feo is offline  
Old 26 June 2019, 20:01   #235
Muadib
Registered User

Muadib's Avatar
 
Join Date: Dec 2014
Location: Stockholm/Sweden
Posts: 236
Congrats Feo!
Yes, LW 5.0 has AGA support, it can render in HAM8 as well!

muadib
Amiga Raytracing Society
amigaraytracers.com
Muadib is offline  
Old 27 June 2019, 07:19   #236
klx300r
Registered User
klx300r's Avatar
 
Join Date: Oct 2007
Location: Toronto, Canada
Age: 49
Posts: 810
Thumbs up

Quote:
Originally Posted by Marchie View Post
Hey 3D junkies, FINALLY finished my video on modelling and setting up a character in LW on Amiga, hope you like it!

[ Show youtube player ]

Any comments, criticisms, or requests for future vids, let me know!

wow great vid
klx300r is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Scala Tutorials? zerohour1974 support.Apps 3 24 March 2015 05:28
Cracking Tutorials? ufo Coders. General 21 31 January 2014 12:39
Vector Tutorials h0ffman Coders. General 7 24 January 2011 18:16
Tutorials for raytracers christianlucio request.Other 0 04 September 2010 18:38
AMOS tutorials Galaxy Coders. Tutorials 0 26 June 2007 13:25

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 06:48.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.08414 seconds with 14 queries