English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 17 November 2014, 22:53   #201
Thom87
LameUser
Thom87's Avatar
 
Join Date: Oct 2007
Location: Aylesbury/UK
Age: 44
Posts: 89
I've been trying run MorphOS 1.4.5 on every beta version science b10, but no success.
Is currently possible run MOS on WinUAE or is it still require improvements on PPC/board emulation?
Thom87 is offline  
Old 18 November 2014, 17:07   #202
narutard
 
Posts: n/a
Winuae crashes with BPPC 040 Rom and 68040 selection.

Narutard
 
Old 18 November 2014, 17:14   #203
huepper
Registered User

huepper's Avatar
 
Join Date: Nov 2009
Location: GDR
Age: 45
Posts: 249
Quote:
Originally Posted by narutard View Post
Winuae crashes with BPPC 040 Rom and 68040 selection.

Narutard
Logs and Configfile ???
huepper is offline  
Old 19 November 2014, 01:12   #204
narutard
 
Posts: n/a
Quote:
Originally Posted by huepper View Post
Logs and Configfile ???
Sry
Attached Files
File Type: uae A1200.uae (18.9 KB, 124 views)
File Type: txt winuaelog.txt (93.1 KB, 135 views)
 
Old 21 November 2014, 08:06   #205
zouzou
Registered User

 
Join Date: Sep 2014
Location: france
Posts: 19
@huepper
>Known ROM 'KS ROM v3.1 (A4000)' loaded

Isn't this the issue? ks for A4000 when you emulate a 1200?
zouzou is offline  
Old 23 November 2014, 02:56   #206
B14ck W01f
m68k all the way
 
Join Date: Aug 2011
Location: Koalaland
Posts: 510
I loaded my A4000 PPC config that has the hard drive containing AmigaOS 4.1 mounted. Upon startup, I get the message "Error loading qemu-uae plugin", yet that same file is sitting in my WinUAE/plugins folder.
B14ck W01f is offline  
Old 23 November 2014, 05:08   #207
ancalimon
Supernormal

ancalimon's Avatar
 
Join Date: Jul 2007
Location: Istanbul / Turkey
Age: 38
Posts: 1,229
Quote:
Originally Posted by B14ck W01f View Post
I loaded my A4000 PPC config that has the hard drive containing AmigaOS 4.1 mounted. Upon startup, I get the message "Error loading qemu-uae plugin", yet that same file is sitting in my WinUAE/plugins folder.
Check the first page. It was updated a while ago.
ancalimon is offline  
Old 24 November 2014, 00:59   #208
B14ck W01f
m68k all the way
 
Join Date: Aug 2011
Location: Koalaland
Posts: 510
Thanks!
B14ck W01f is offline  
Old 04 December 2014, 10:52   #209
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 44
Posts: 22,954
Quote:
Unfortunately only OS4 supported SCSI controller is CSPPC SCSI. IDE emulation is so slow.
Impact A4000-HC+8 (aka Impact A2000-HC+8 Series II) is supposedly OS4 compatible, perhaps it can also work in A1200 config with BlizzardPPC (256M RAM without slow IDE)? It is not real world config but it should work as long as there is no extra checks in driver.

It is not yet emulated, existing WD33C93 SCSI emulation currently depends too much on Commodore's DMAC.

Should be much faster than IDE because it is DMA SCSI controller. (But it won't be as fast as CSPPC SCSI to emulate)
Toni Wilen is offline  
Old 14 December 2014, 20:29   #210
Seiya
Registered User

Seiya's Avatar
 
Join Date: Nov 2014
Location: Italy
Posts: 935
i'm using OS4.0, but i see some strange situation: mplayer don't work. Black screen. DVplayer idem. Mp3 don't load and no audio.
is there some to setting or i lost some important files?
Seiya is online now  
Old 21 December 2014, 13:27   #211
flype
Registered User

flype's Avatar
 
Join Date: Dec 2014
Location: France
Posts: 85
Hi, someone tested AmigaOS 4.1 Final Edition Classic on the lastest WinUAE ?

If so or when so, can you please share your experience ?

Considering the availability and the new price (nearly 30€), i might buy AOS4 if it works.
My wish is that the duo WinUAE + AOS4 solution is enough for simple app development, software porting using gcc.

Does the WinUAE/SaveStates functionality works under PPC emu ?
flype is offline  
Old 21 December 2014, 14:22   #212
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 44
Posts: 22,954
Quote:
Originally Posted by flype View Post
Does the WinUAE/SaveStates functionality works under PPC emu ?
No. PPC CPU, most SCSI devices and RTG hardware emulation does not have statefile support.
Toni Wilen is offline  
Old 21 December 2014, 14:40   #213
flype
Registered User

flype's Avatar
 
Join Date: Dec 2014
Location: France
Posts: 85
Ok no problem (idea was that it would have speed up boot time as i saw that os4 boot is slow).
flype is offline  
Old 02 January 2015, 13:54   #214
chocolate_boy
Registered User
 
Join Date: Dec 2005
Location: UK
Age: 36
Posts: 213
Quote:
Originally Posted by Thom87 View Post
I've been trying run MorphOS 1.4.5 on every beta version science b10, but no success.
Is currently possible run MOS on WinUAE or is it still require improvements on PPC/board emulation?
I would also like to try, did anyone get MorphOS 1.4.5 working yet?
chocolate_boy is offline  
Old 02 January 2015, 14:05   #215
Doc
Registered User

 
Join Date: Dec 2014
Location: Everglades
Posts: 27
WinUAE 3.1 doesn't freeze on my system, but crashes (no dump, just a Windows message about WinUAE no longer working) after AOS4.1 idles for some hours. I have installed Extras, SDK, vbcc/ppc-target and spent much time actively without much problems before (WinUAE 3.0).

I noticed ejecting a CD-image (device ide:1) is not always recognized inside OS4.1.
Doc is offline  
Old 03 January 2015, 19:32   #216
FOL
PSPUAE DEV

FOL's Avatar
 
Join Date: Nov 2006
Location: Barry / UK
Age: 41
Posts: 5,713
Send a message via MSN to FOL
Quote:
Originally Posted by Doc View Post
I noticed ejecting a CD-image (device ide:1) is not always recognized inside OS4.1.
Ive had this too, but its very random.
FOL is offline  
Old 04 January 2015, 11:37   #217
Doc
Registered User

 
Join Date: Dec 2014
Location: Everglades
Posts: 27
I've just ejected an iso-image. cd0: is still accessible but empty, and shows about 80MiBs allocated. Is this an OS4.1 bug?

Also, I find it rather inconvenient that ejecting an image leads to the assignment of a physical drive to cd0:. Can this behaviour be changed? Not that it would work (see above), the drive spins up and that's it.

Edit: Forget it - silly me overlooking the obvious *rolleyes*. And now ejecting works ok.

Last edited by Doc; 04 January 2015 at 12:11.
Doc is offline  
Old 04 January 2015, 13:00   #218
Romanujan
Registered User
 
Join Date: Dec 2007
Location: Szczecin/Poland
Posts: 335
Quote:
Originally Posted by flype View Post
Hi, someone tested AmigaOS 4.1 Final Edition Classic on the lastest WinUAE ?

If so or when so, can you please share your experience ?
I have tried on latest FS-UAE (A4000/OS4 config) - works, is stable, performance is decent - but I have Core i7 4790K and I am running a 64-bit emulator (I suppose 32-bit might be slower).
Romanujan is offline  
Old 04 January 2015, 23:57   #219
ma693541
Computer Wizard

ma693541's Avatar
 
Join Date: Aug 2007
Location: Ramberg/Norway
Posts: 661
@Romanujan, How is it possible that you run AmigaOS 4.1 FE Classic on a 64-bit emulator as FS-UAE? FS-UAE are based on sources from WinUAE and the Experimental 64-bit WinUAE PPC CPU emulation is not yet supported in WinUAE 64-bit.

Last edited by ma693541; 05 January 2015 at 00:00. Reason: Missing text
ma693541 is offline  
Old 05 January 2015, 00:01   #220
FrodeSolheim
FS-UAE Developer

FrodeSolheim's Avatar
 
Join Date: Dec 2011
Location: Førde, Norway
Age: 38
Posts: 3,545
Quote:
Originally Posted by ma693541 View Post
@Romanujan, How is it possible that you run AmigaOS 4.1 FE Classic on a 64-bit emulator as FS-UAE? FS-UAE are based on sources from WinUAE and the Experimental 64-bit WinUAE PPC CPU emulation is not yet supported in WinUAE.
The QEMU-UAE PPC plugin works fine with 64-bit on operating systems other than Windows.
FrodeSolheim is online now  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
QEMU TCG as JIT replacement? KillaByte request.UAE Wishlist 21 30 January 2018 16:05
PPC emulation for winuae marauder request.UAE Wishlist 25 04 November 2014 06:13
WinUAE PPC thread B14ck W01f support.WinUAE 301 10 September 2014 16:34
WinUAE ppc support? blasterreal support.WinUAE 8 29 September 2010 00:51
PPC on WinUAE ? glue request.UAE Wishlist 4 28 January 2007 12:04

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 00:42.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.10290 seconds with 14 queries