English Amiga Board


Go Back   English Amiga Board > News

 
 
Thread Tools
Old 09 December 2016, 03:52   #1
adrdesign
Registered User

adrdesign's Avatar
 
Join Date: Nov 2013
Location: Spain
Age: 38
Posts: 267
PT2.3D port for Raspberry PI

Im having a good time with my Rpi3, tested few synths, emulators and so. Today I tried protracker using uae4arm (uae4all2 also). Noticed the latency and desisted to start making anything.

I remembered one guy ported Protracker2.3d to C and having tested in windows and mac, I thought it will worth the time to have the raspberry a try.

sudo apt-get install subversion
sudo apt-get install libsdl1.2-dev
svn checkout svn://svn.code.sf.net/p/protracker/code/trunk protracker-code
cd protracker-code
chmod +x make-linux.sh
./make-linux.sh


when finished, you can find protracker and protracker_opengl in bin/

Now you can remember those protracker days without any noticeable latency. Loading wavs and >64k instruments is allowed. Have fun. Merry xmas.

Attached: raspberry executable (libsdl1.2 needed)

PD: excuse my poor english. I think knowledge is more important
Attached Files
File Type: zip protracker.bz2.zip (313.0 KB, 52 views)
adrdesign is offline  
AdSense AdSense  
Old 09 December 2016, 18:15   #2
Foul
Registered User

Foul's Avatar
 
Join Date: Jun 2009
Location: Perigueux/France
Age: 43
Posts: 1,263
Send a message via ICQ to Foul Send a message via MSN to Foul Send a message via Skype™ to Foul
off F*** it's working !
Excellent thx
Foul is offline  
Old 09 December 2016, 20:58   #3
Devlin
Sorcerian

Devlin's Avatar
 
Join Date: Nov 2005
Location: Bradford, UK
Age: 31
Posts: 232
Getting an OpenGL error when I try to run the downloaded binary from RetroPie. Does this need an active X session?

EDIT:

Code:
src/pt_audio.c: In function ‘audioCallback’:
src/pt_audio.c:829:11: warning: cast increases required alignment of target type [-Wcast-align]
     out = (int16_t *)(stream);
           ^
getting this warning when building from source but works fine anyway

Last edited by Devlin; 09 December 2016 at 21:14.
Devlin is offline  
Old 10 December 2016, 02:49   #4
EugeneNine
Registered User

 
Join Date: Aug 2016
Location: Ohio
Posts: 162
Works on x86 64 Linux as well
EugeneNine is offline  
Old 09 July 2017, 21:26   #5
volton
Registered User

 
Join Date: Jul 2017
Location: Belorussia
Posts: 4
lay out please collected pt2.3d. I at assembly have a mistake.
volton is offline  
Old 10 July 2017, 01:01   #6
alkis
Registered User

 
Join Date: Dec 2010
Location: Athens/Greece
Age: 46
Posts: 361
Don't know if they migrated to sdl2 from 2016 to 2017, currently on rasbian needs:

sudo apt-get install libsdl2-dev
alkis is offline  
Old 10 July 2017, 16:14   #7
volton
Registered User

 
Join Date: Jul 2017
Location: Belorussia
Posts: 4
no compiled
terminal log : Compiling, please wait...
*** Error in `gcc': double free or corruption (top): 0x01dd5ae0 ***
./make-linux.sh: line 6: 7834 Aborted gcc src/*.c src/gfx/*.c -lSDL2 -lm -ldl -Wall -Wno-unused-result -Wc++-compat -Wshadow -Winit-self -Wextra -Wunused -Wunreachable-code -Wredundant-decls -Wswitch-default -march=native -mtune=native -O3 -o release/protracker
volton is offline  
Old 10 July 2017, 23:09   #8
alkis
Registered User

 
Join Date: Dec 2010
Location: Athens/Greece
Age: 46
Posts: 361
That's a compiler bug.
Try https://solarianprogrammer.com/2016/...p-17-programs/ and install gcc-6.

There is no such bug in gcc-6.
alkis is offline  
Old 11 July 2017, 16:21   #9
volton
Registered User

 
Join Date: Jul 2017
Location: Belorussia
Posts: 4
dozn't
terminal log => Compiling, please wait...
*** Error in `gcc': double free or corruption (top): 0x00994ae0 ***
./make-linux.sh: line 6: 30457 Aborted gcc src/*.c src/gfx/*.c -lSDL2 -lm -ldl -Wall -Wno-unused-result -Wc++-compat -Wshadow -Winit-self -Wextra -Wunused -Wunreachable-code -Wredundant-decls -Wswitch-default -march=native -mtune=native -O3 -o release/protracker
ps uploading please for me compiled file pt2.3d to - paul_am$mail.ru ($ ->@)
volton is offline  
Old 02 August 2017, 13:09   #10
volton
Registered User

 
Join Date: Jul 2017
Location: Belorussia
Posts: 4
troubles
[IMG][/IMG]
volton is offline  
Old 20 August 2017, 21:27   #11
adrdesign
Registered User

adrdesign's Avatar
 
Join Date: Nov 2013
Location: Spain
Age: 38
Posts: 267
I used rpi3 raspbian jessie with pixel desktop, not available ATM. You can install it after these commands

sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install -y rpi-chromium-mods
sudo apt-get install -y python-sense-emu python3-sense-emu python-sense-emu-doc

hope it works.
adrdesign is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Raspberry Pi 3 out Retroplay Retrogaming General Discussion 63 11 March 2016 19:05
Raspberry Pi 2 amigafreak68k support.FS-UAE 67 31 October 2015 23:52
Keyrah V2 on Raspberry Pi Boom^ support.Hardware 3 22 February 2015 01:04
Serial port, parallel port, and pipe device mount errors Samurai_Crow support.FS-UAE 4 13 March 2014 01:04
Amiga PT2.3d helpfile anyone? jobro request.Apps 2 05 December 2005 00:57

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 13:27.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.23470 seconds with 13 queries