English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 01 December 2007, 16:51   #1
Bolch
Registered User
 
Join Date: Apr 2007
Location: Hungary
Posts: 147
Impossible Mission 2025 (CD32) doesn't work

...Well, the title says it all!

I finally managed to get my greedy hands on the CD32 version of IM 2025, but whenever I start it in WinUAE, the screen turns black - after recognizing the CD - and then nothing happens.

I tried using many different settings (I started with the quickstart settings), but to no avail...

The other CD32 games (Chaos Engine, Darkseed, Chuck Rock 2 etc.) work fine, so it seems that the problem is only related to this one.

Could someone give me any advice?

Thanks in advance!
Bolch is offline  
Old 01 December 2007, 17:12   #2
Retro-Nerd
Missile Command Champion

Retro-Nerd's Avatar
 
Join Date: Aug 2005
Location: Germany
Age: 46
Posts: 11,271
Looks like MCI trouble again.
Quote:
48-640 [1055 000x000]: MCIErr: MCI_RESUME: 262 = 'Hardwarefehler beim Mediagerät. Stellen Sie sicher, dass es richtig arbeitet, oder fragen Sie den Gerätehersteller.'
48-718: SOUND: DirectSound driver freed
48-718: MCIErr: MCI_RESUME: 262 = 'Hardwarefehler beim Mediagerät. Stellen Sie sicher, dass es richtig arbeitet, oder fragen Sie den Gerätehersteller.'
48-734: MCIErr: MCI_RESUME: 262 = 'Hardwarefehler beim Mediagerät. Stellen Sie sicher, dass es richtig arbeitet, oder fragen Sie den Gerätehersteller.'
Retro-Nerd is offline  
Old 01 December 2007, 17:50   #3
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,222
It tries to play first track (which is data track) as cd audio..

I guess CD32 CD drive responds to this differently than emulation does.
Toni Wilen is offline  
Old 01 December 2007, 18:03   #4
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,222
Real CD32 test needed.

Does it start playing CD audio when "Amiga CD32" starts going away? If it does, which track? Or does it continue loading few more seconds after logo has disappeared? (and what happens next?)
Toni Wilen is offline  
Old 01 December 2007, 18:13   #5
Bolch
Registered User
 
Join Date: Apr 2007
Location: Hungary
Posts: 147
Unfortunately, I don't have a real CD32, so I cannot perform the test...

Anyone else perhaps?

Last edited by Bolch; 01 December 2007 at 18:28.
Bolch is offline  
Old 01 December 2007, 20:30   #6
Josh
Lord of Amiga-Manuals
Josh's Avatar
 
Join Date: Jan 2007
Location: Kassel / Germany
Age: 48
Posts: 552
I just burned the image you get from me on CD and test it on a real CD32 - it works fine...


Cheers Josh
Josh is offline  
Old 01 December 2007, 20:54   #7
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,222
Quote:
Originally Posted by Josh View Post
I just burned the image you get from me on CD and test it on a real CD32 - it works fine...
Nobody asked if it works on a real CD32.. Try again
Toni Wilen is offline  
Old 01 December 2007, 20:59   #8
Retro-Nerd
Missile Command Champion

Retro-Nerd's Avatar
 
Join Date: Aug 2005
Location: Germany
Age: 46
Posts: 11,271
Quote:
Originally Posted by Toni Wilen View Post
Nobody asked if it works on a real CD32.. Try again
He will.
Retro-Nerd is offline  
Old 01 December 2007, 21:04   #9
Josh
Lord of Amiga-Manuals
Josh's Avatar
 
Join Date: Jan 2007
Location: Kassel / Germany
Age: 48
Posts: 552
Quote:
Originally Posted by Toni Wilen View Post
Nobody asked if it works on a real CD32.. Try again
Sorry - I thougt Bolch has any problems with it. I don't read all before
So next I will shut up until I know what's up...


Cheers Josh
Josh is offline  
Old 02 December 2007, 13:08   #10
thor
Registered User
thor's Avatar
 
Join Date: Mar 2006
Location: Germany
Posts: 898
Quote:
Originally Posted by Toni Wilen View Post
Real CD32 test needed.

Does it start playing CD audio when "Amiga CD32" starts going away? If it does, which track? Or does it continue loading few more seconds after logo has disappeared? (and what happens next?)
It does not play an audio track when the logo goes away. It loads the Microprose logo with audio (but not CDDA audio) then the intro.

DoIO with a play command on data track returns CDERR_BadDataType (36).
thor is offline  
Old 19 January 2008, 20:13   #11
StevenJGore
Amiga Fanatic

StevenJGore's Avatar
 
Join Date: Feb 2004
Location: West Yorkshire, UK
Age: 41
Posts: 477
What's the latest with this issue?

Just got an IM2025 CD32 original from eBay.

In WinUAE (latest beta) the "Amiga CD32" animation loads and then resets half way through going away. It then reboots, and after the "Amiga CD32" has gone away the second time (it doesn't crash this time) the screen goes blank and stays blank.

It does this regardless of configuration (I'm using the CD32 quickstart and I've tried all three compatability settings).

Happy to provide any further info or do more testing if required.

Steve.
StevenJGore is offline  
Old 22 April 2008, 08:05   #12
laser
Banned
 
Join Date: Aug 2006
Location: Argentina
Age: 45
Posts: 648
I just tested IM2025 on winuae
screen black and remains black here like was reported by us

however I copied CD' files to hardisk and I run it from there and works on winuae on my normal HD config......but of course there are not cdda audio and the game starts on the menu.....the intro is skipped

I know that the game starts without intro cause I saw this video made on a real cd32

http://es.youtube.com/watch?v=wP6BCGAKw3E


no solution for winuae yet?
laser is offline  
Old 30 July 2010, 19:04   #13
bagpipes
Registered User

bagpipes's Avatar
 
Join Date: Feb 2009
Location: Poland
Posts: 80
Any news about emulation of this title? In new versions of WinUAE I have black screen after boot (with different configurations).
bagpipes is offline  
Old 30 July 2010, 22:11   #14
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,222
I guess I forgot about this..
Toni Wilen is offline  
Old 30 July 2010, 22:41   #15
bagpipes
Registered User

bagpipes's Avatar
 
Join Date: Feb 2009
Location: Poland
Posts: 80
Haha
bagpipes is offline  
Old 31 July 2010, 12:49   #16
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,222
I think I know what goes wrong but I can't test it today.

CD32 CD hardware "play" packet should always return status code "playing" (even if track is not audio track), next play status packet should return "play ended with error".

Currently "play" packet status is "play ended with error" which is ignored by software, it waits for real status packet which never arrives.
Toni Wilen is offline  
Old 31 July 2010, 13:54   #17
bagpipes
Registered User

bagpipes's Avatar
 
Join Date: Feb 2009
Location: Poland
Posts: 80
Great news
bagpipes is offline  
Old 01 August 2010, 17:18   #18
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,222
Confirmed, above update fixed it. (one question remains: how is it possible to accidentally play data track. Wrong track number or wrong command?)

http://www.winuae.net/files/b/winuae.zip
Toni Wilen is offline  
Old 01 August 2010, 21:03   #19
bagpipes
Registered User

bagpipes's Avatar
 
Join Date: Feb 2009
Location: Poland
Posts: 80
YEAHHH! Works great with medium compatibility. With best compatibility in game I have 160% SND. Thanks a lot for fix!!!
bagpipes is offline  
Old 07 January 2019, 20:10   #20
tito76
Registered User

tito76's Avatar
 
Join Date: Dec 2018
Location: Italia
Posts: 2
Doesn't it work again?
Black screen on new emu versions :/
tito76 is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Manual for "Impossible Mission 2025" PopoCop request.Other 7 18 June 2010 03:16
AGA mode Impossible Mission 2025 Tim Janssen support.Games 5 26 January 2009 17:22
Impossible Mission 2025 CD32 Bolch request.Old Rare Games 5 21 November 2007 22:33
Impossible Mission sareks support.Games 5 08 March 2006 14:39
Impossible Mission 2025 CD³² MethodGit Games images which need to be WHDified 27 17 April 2005 14:06

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 11:43.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.09363 seconds with 13 queries