English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 30 August 2018, 19:16   #1
mark_k
Registered User
 
Join Date: Aug 2004
Location:
Posts: 2,967
Alt-Tab and stuck key issue

I noticed a couple of issues related to Alt-Tabbing.
  • Enable pause-when-mouse-uncaptured then start emulation in windowed mode.
  • Open a CLI (or other program that prints characters you type). Type some letters.
  • Press and hold Alt then tap Tab. The Windows task switcher appears and the emulation window titlebar says [Paused].
  • Keep tapping Tab until WinUAE is selected again in the switcher, then release Alt.
  • The mouse is uncaptured. Clicking in the emulation window doesn't capture it (issue #1).
  • Move the mouse to another window, click in it, then back to the emulation window. Now clicking does capture the mouse.
  • Type some more characters. WinUAE thinks the Alt key is still pressed. You have to tap Alt for it to recognise the key is not pressed (issue #2).
Now disable pause-when-mouse-uncaptured, but leave pause-when-inactive enabled. Repeat the steps above. After Alt-Tabbing back to WinUAE, you need to activate another window then reactivate the emulation window before clicking in it recaptures the mouse. The difference is, after doing that WinUAE doesn't think Alt is still pressed.
mark_k is offline  
Old 06 September 2018, 22:08   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,129
Both (probably) fixed.
Toni Wilen is online now  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't ALT+TAB to other apps on Ubuntu TenLeftFingers support.FS-UAE 5 31 March 2016 14:49
WinUAE crashing after Alt-Tab Steve support.WinUAE 7 31 December 2013 18:38
2.3.2 alt-tab vs priority behavior Photon support.WinUAE 0 29 July 2011 02:50
HowTo Alt+Tab in Style NewDeli New to Emulation or Amiga scene 0 16 November 2009 13:33
Alt-Tab behavior solution Photon support.WinUAE 14 02 October 2009 00:35

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 17:56.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.05781 seconds with 13 queries